python 2.7 mass rebuild [release 0.12.0-3mamba;Fri May 17 2013]
This commit is contained in:
parent
ff9db85088
commit
08ee43f4f6
@ -1,2 +1,5 @@
|
|||||||
# python-SOAP
|
# python-SOAP
|
||||||
|
|
||||||
|
Web services for Python programmers, both client and servers. This
|
||||||
|
includes SOAP, WSDL, UDDI, etc.
|
||||||
|
|
||||||
|
70
python-SOAP-0.12.0-python2.6.patch
Normal file
70
python-SOAP-0.12.0-python2.6.patch
Normal file
@ -0,0 +1,70 @@
|
|||||||
|
Only in SOAPpy-0.12.0: build
|
||||||
|
diff -ru SOAPpy-0.12.0.orig/SOAPpy/Client.py SOAPpy-0.12.0/SOAPpy/Client.py
|
||||||
|
--- SOAPpy-0.12.0.orig/SOAPpy/Client.py 2005-02-21 21:27:09.000000000 +0100
|
||||||
|
+++ SOAPpy-0.12.0/SOAPpy/Client.py 2009-05-18 15:23:47.000000000 +0200
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+from __future__ import nested_scopes
|
||||||
|
"""
|
||||||
|
################################################################################
|
||||||
|
#
|
||||||
|
@@ -43,8 +44,6 @@
|
||||||
|
ident = '$Id: Client.py,v 1.27 2005/02/21 20:27:09 warnes Exp $'
|
||||||
|
from version import __version__
|
||||||
|
|
||||||
|
-from __future__ import nested_scopes
|
||||||
|
-
|
||||||
|
#import xml.sax
|
||||||
|
import urllib
|
||||||
|
from types import *
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy: Client.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy: Config.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy: Errors.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy: NS.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy: Parser.pyc
|
||||||
|
diff -ru SOAPpy-0.12.0.orig/SOAPpy/Server.py SOAPpy-0.12.0/SOAPpy/Server.py
|
||||||
|
--- SOAPpy-0.12.0.orig/SOAPpy/Server.py 2005-02-15 17:32:22.000000000 +0100
|
||||||
|
+++ SOAPpy-0.12.0/SOAPpy/Server.py 2009-05-18 15:33:31.000000000 +0200
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+from __future__ import nested_scopes
|
||||||
|
"""
|
||||||
|
################################################################################
|
||||||
|
#
|
||||||
|
@@ -43,8 +44,6 @@
|
||||||
|
ident = '$Id: Server.py,v 1.21 2005/02/15 16:32:22 warnes Exp $'
|
||||||
|
from version import __version__
|
||||||
|
|
||||||
|
-from __future__ import nested_scopes
|
||||||
|
-
|
||||||
|
#import xml.sax
|
||||||
|
import re
|
||||||
|
import socket
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy: Server.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy: SOAPBuilder.pyc
|
||||||
|
diff -ru SOAPpy-0.12.0.orig/SOAPpy/Types.py SOAPpy-0.12.0/SOAPpy/Types.py
|
||||||
|
--- SOAPpy-0.12.0.orig/SOAPpy/Types.py 2005-02-22 05:29:43.000000000 +0100
|
||||||
|
+++ SOAPpy-0.12.0/SOAPpy/Types.py 2009-05-18 15:24:19.000000000 +0200
|
||||||
|
@@ -1,3 +1,4 @@
|
||||||
|
+from __future__ import nested_scopes
|
||||||
|
"""
|
||||||
|
################################################################################
|
||||||
|
# Copyright (c) 2003, Pfizer
|
||||||
|
@@ -36,7 +37,6 @@
|
||||||
|
ident = '$Id: Types.py,v 1.19 2005/02/22 04:29:43 warnes Exp $'
|
||||||
|
from version import __version__
|
||||||
|
|
||||||
|
-from __future__ import nested_scopes
|
||||||
|
|
||||||
|
import UserList
|
||||||
|
import base64
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy: Types.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy: Utilities.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy: WSDL.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy/wstools: c14n.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy/wstools: __init__.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy/wstools: logging.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy/wstools: Namespaces.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy/wstools: TimeoutSocket.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy/wstools: Utility.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy/wstools: WSDLTools.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy/wstools: XMLname.pyc
|
||||||
|
Only in SOAPpy-0.12.0/SOAPpy/wstools: XMLSchema.pyc
|
60
python-SOAP.spec
Normal file
60
python-SOAP.spec
Normal file
@ -0,0 +1,60 @@
|
|||||||
|
Name: python-SOAP
|
||||||
|
Version: 0.12.0
|
||||||
|
Release: 3mamba
|
||||||
|
Summary: A SOAP library for python
|
||||||
|
Group: System/Libraries/Python
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Automatic Build System <autodist@mambasoft.it>
|
||||||
|
URL: http://pywebsvcs.sourceforge.net/
|
||||||
|
Source: http://downloads.sourceforge.net/pywebsvcs/SOAPpy-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-0.12.0-python2.6.patch
|
||||||
|
License: BSD
|
||||||
|
Requires: python >= %python_version
|
||||||
|
BuildRequires: python-fpconst
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: libpython-devel >= %python_version
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Web services for Python programmers, both client and servers. This
|
||||||
|
includes SOAP, WSDL, UDDI, etc.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
|
||||||
|
%setup -q -n SOAPpy-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
python setup.py build
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
python setup.py install \
|
||||||
|
--root="%{buildroot}" \
|
||||||
|
--install-headers=%{_includedir}/python \
|
||||||
|
--install-lib=%{python_sitearch}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{python_sitearch}/SOAPpy
|
||||||
|
%{python_sitearch}/SOAPpy/*.py
|
||||||
|
%{python_sitearch}/SOAPpy/*.pyc
|
||||||
|
%{python_sitearch}/SOAPpy-%{version}-py*.egg-info
|
||||||
|
%dir %{python_sitearch}/SOAPpy/wstools
|
||||||
|
%{python_sitearch}/SOAPpy/wstools/*.py
|
||||||
|
%{python_sitearch}/SOAPpy/wstools/*.pyc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.12.0-3mamba
|
||||||
|
- python 2.7 mass rebuild
|
||||||
|
|
||||||
|
* Mon May 18 2009 Automatic Build System <autodist@mambasoft.it> 0.12.0-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Aug 18 2008 gil <puntogil@libero.it> 0.12.0-1mamba
|
||||||
|
- package created by autospec
|
Reference in New Issue
Block a user