98 lines
3.1 KiB
RPMSpec
98 lines
3.1 KiB
RPMSpec
%define pkgname %(echo %name | cut -d- -f2- | tr - _)
|
|
Name: python-QDarkStyle
|
|
Version: 3.2.3
|
|
Release: 1mamba
|
|
Summary: QDarkStyle is a dark stylesheet for Python and Qt applications
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://pypi.org/project/QDarkStyle/
|
|
Source: https://pypi.debian.net/QDarkStyle/QDarkStyle-%{version}.tar.gz
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython311-devel
|
|
BuildRequires: python3.11dist(qtpy)
|
|
BuildRequires: python3.11dist(setuptools)
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: python3-devel >= 3.11.5-3mamba
|
|
|
|
%description
|
|
%{summary}.
|
|
|
|
%if 0%{?with_pyver}
|
|
%pyver_package
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n QDarkStyle-%{version}
|
|
|
|
%build
|
|
CFLAGS="%{optflags}" %{__python} setup.py build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%{__python} setup.py install \
|
|
-O1 --skip-build \
|
|
--root="%{buildroot}" \
|
|
--install-headers=%{python_inc} \
|
|
--install-lib=%{python_sitearch} \
|
|
--record=%{name}.filelist
|
|
|
|
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
|
|
|
%if "%{?with_pyver}" != "3"
|
|
# Rename any conflicting file outside of python site packages tree
|
|
for f in %{_bindir}/qdarkstyle{,.example,.utils}; do
|
|
mv %{buildroot}${f}{,-%{?pyappend}}
|
|
done
|
|
%endif
|
|
|
|
sed -i "\,%{_bindir},d" %{name}.filelist
|
|
|
|
%files %{?pyappend} -f %{name}.filelist
|
|
%defattr(-,root,root)
|
|
%{_bindir}/qdarkstyle*
|
|
%dir %{python_sitearch}/%{pkgname}-%{version}-py*.egg-info
|
|
%{python_sitearch}/%{pkgname}-%{version}-py*.egg-info/*
|
|
|
|
%changelog
|
|
* Wed Nov 29 2023 Automatic Build System <autodist@mambasoft.it> 3.2.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 28 2023 Automatic Build System <autodist@mambasoft.it> 3.2.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Nov 11 2023 Automatic Build System <autodist@mambasoft.it> 3.2.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 26 2023 Automatic Build System <autodist@mambasoft.it> 3.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 26 2023 Automatic Build System <autodist@mambasoft.it> 3.1-3mamba
|
|
- rebuilt by autoport with build requirements: python3-devel>=3.11.5-3mamba
|
|
|
|
* Sun Apr 09 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 3.1-2mamba
|
|
- py310: resolve bindir conflicts
|
|
|
|
* Sat Apr 08 2023 Automatic Build System <autodist@mambasoft.it> 3.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 07 2023 Sdk Build System <sdk@mambasoft.it> 3.0.3-3mamba
|
|
- rebuilt with python 3.10
|
|
|
|
* Sun Feb 13 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.3-2mamba
|
|
- rebuilt with distdeps
|
|
|
|
* Mon Nov 29 2021 Automatic Build System <autodist@mambasoft.it> 3.0.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 02 2021 Automatic Build System <autodist@mambasoft.it> 3.0.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 01 2021 Automatic Build System <autodist@mambasoft.it> 3.0.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jan 20 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.8.1-1mamba
|
|
- package created using the webbuild interface
|