update to 1.3.2
patch for use with python-ipaddress with python2 [release 1.3.2-1mamba;Thu Dec 10 2015]
This commit is contained in:
parent
506e200531
commit
757869be54
12
pypolicy-spf-1.3.2-python2.patch
Normal file
12
pypolicy-spf-1.3.2-python2.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru pypolicyd-spf-1.3.2.orig/policyd-spf pypolicyd-spf-1.3.2/policyd-spf
|
||||
--- pypolicyd-spf-1.3.2.orig/policyd-spf 2015-08-13 04:45:08.000000000 +0200
|
||||
+++ pypolicyd-spf-1.3.2/policyd-spf 2015-12-10 13:43:29.323754410 +0100
|
||||
@@ -39,6 +39,8 @@
|
||||
import policydspfsupp
|
||||
try:
|
||||
import ipaddress
|
||||
+ if bytes is str:
|
||||
+ from ipaddress import Bytes
|
||||
except ImportError:
|
||||
import ipaddr as ipaddress
|
||||
try:
|
@ -1,5 +1,6 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: pypolicyd-spf
|
||||
Version: 1.3.1
|
||||
Version: 1.3.2
|
||||
Release: 1mamba
|
||||
Summary: A Postfix policy engine for Sender Policy Framework (SPF) checking
|
||||
Group: System/Libraries
|
||||
@ -7,14 +8,15 @@ Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://launchpad.net/pypolicyd-spf/
|
||||
Source: https://launchpad.net/pypolicyd-spf/%{version}.3.1/+download/pypolicyd-spf-%{version}.tar.gz
|
||||
Source: https://launchpad.net/pypolicyd-spf/%{majver}/%{version}/+download/pypolicyd-spf-%{version}.tar.gz
|
||||
Patch0: pypolicy-spf-1.3.2-python2.patch
|
||||
License: GPL, Apache License 2.0
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libpython-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: python >= %python_version
|
||||
Requires: pyspf
|
||||
Requires: python-ipaddr
|
||||
Requires: python-ipaddress
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
@ -23,6 +25,7 @@ It is implemented in pure Python and uses the python-spf (pyspf) module. Updated
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
CFLAGS="%{optflags}" %{__python} setup.py build
|
||||
@ -43,5 +46,9 @@ sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
||||
%doc COPYING
|
||||
|
||||
%changelog
|
||||
* Thu Dec 10 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.2-1mamba
|
||||
- update to 1.3.2
|
||||
- patch for use with python-ipaddress with python2
|
||||
|
||||
* Wed May 20 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.1-1mamba
|
||||
- package created using the webbuild interface
|
||||
|
Loading…
Reference in New Issue
Block a user