84 lines
2.2 KiB
RPMSpec
84 lines
2.2 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f 1-2)
|
|
%define group sources
|
|
Name: pyorbit
|
|
Version: 2.24.0
|
|
Release: 3mamba
|
|
Summary: Python bindings for ORBit2
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.pygtk.org/
|
|
Source: http://ftp.gnome.org/pub/GNOME/%{group}/pyorbit/%{majver}/%{name}-%{version}.tar.bz2
|
|
License: LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: ORBit2-devel
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libIDL-devel
|
|
BuildRequires: libglib-devel
|
|
BuildRequires: libpython-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: pkgconfig
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
|
|
|
%description
|
|
PyOrbit is an extension module for python that gives you access to the ORBit2 CORBA ORB.
|
|
|
|
%package devel
|
|
Summary: Devel package for %{name}
|
|
Group: Development/Libraries
|
|
Requires: %{name} = %{version}
|
|
|
|
%description devel
|
|
PyOrbit is an extension module for python that gives you access to the ORBit2 CORBA ORB.
|
|
This package contains static libraries and header files need for development.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%configure
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
%makeinstall \
|
|
pythondir=%{python_sitearch} \
|
|
pyexecdir=%{python_sitearch}
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{python_sitearch}/*.py*
|
|
%{python_sitearch}/*.la
|
|
%{python_sitearch}/*.so
|
|
%doc AUTHORS COPYING
|
|
|
|
%files devel
|
|
%defattr(-,root,root)
|
|
%dir %{_includedir}/pyorbit-2
|
|
%{_includedir}/pyorbit-2/*.h
|
|
%{_libdir}/pkgconfig/*.pc
|
|
%doc ChangeLog INSTALL NEWS README TODO
|
|
|
|
%changelog
|
|
* Sat May 18 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.0-3mamba
|
|
- python 2.7 mass rebuild
|
|
|
|
* Fri Oct 24 2008 gil <puntogil@libero.it> 2.24.0-2mamba
|
|
- rebuild with new ORBit2
|
|
|
|
* Fri Oct 24 2008 gil <puntogil@libero.it> 2.24.0-1mamba
|
|
- update to 2.24.0
|
|
|
|
* Sat Jul 19 2008 gil <puntogil@libero.it> 2.14.3-1mamba
|
|
- update to 2.14.3
|
|
|
|
* Tue Aug 09 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.1-2qilnx
|
|
- rebuilt with Python 2.4
|
|
|
|
* Thu Nov 25 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.0.1-1qilnx
|
|
- package created by autospec
|