pygtk/pygtk.spec

201 lines
6.2 KiB
RPMSpec

%define majver %(echo %version | cut -d. -f 1-2)
Name: pygtk
Version: 2.24.0
Release: 6mamba
Summary: Python bindings for GTK+
Group: Development/Bindings
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.pygtk.org/
Source: http://ftp.gnome.org/pub/GNOME/sources/pygtk/%{majver}/pygtk-%{version}.tar.bz2
Patch0: pygtk-2.10.4-buildroot_fix.patch
Patch1: pygtk-2.24.0-libpango-1.44.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libatk-devel
BuildRequires: libcairo-devel
BuildRequires: libexpat-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libglade-devel
BuildRequires: libglib-devel
BuildRequires: libglitz-devel
BuildRequires: libgtk2-devel
BuildRequires: libpango-devel
BuildRequires: libpixman-devel
BuildRequires: libpng-devel
BuildRequires: libpython-devel
BuildRequires: libselinux-devel
BuildRequires: libstdc++6-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libxcb-util-devel
BuildRequires: libXdmcp-devel
BuildRequires: libxml2-devel
BuildRequires: libXrender-devel
BuildRequires: libz-devel
BuildRequires: pygobject2-devel
BuildRequires: python
BuildRequires: pycairo-devel
## AUTOBUILDREQ-END
BuildRequires: python-numpy
BuildRequires: python
Provides: pygtk2
Obsoletes: pygtk2
Requires: pygobject2
Requires: python-cairo
#Requires: python-numpy
Requires(pre): python
%description
PyGTK provides a convenient wrapper for the GTK library for use in Python programs, and takes care of many of the boring details such as managing memory and type casting.
When combined with PyORBit and gnome-python, it can be used to write full featured Gnome applications.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Provides: pygtk2-devel
Obsoletes: pygtk2-devel
%description devel
PyGTK provides a convenient wrapper for the GTK library for use in Python programs, and takes care of many of the boring details such as managing memory and type casting.
When combined with PyORBit and gnome-python, it can be used to write full featured Gnome applications.
This package contains files required to build wrappers for GTK+ addon libraries so that they interoperate with pygtk.
%package demos
Summary: Sample programs for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Provides: pygtk2-demos
Obsoletes: pygtk2-demos
%description demos
Sample programs for %{name}.
%prep
%setup -q -n pygtk-%{version}
#%patch0 -p1
%patch1 -p1
%build
%configure \
--enable-thread \
--disable-numpy \
PYTHON=%{__python27}
%make
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
export tagname=CC
%makeinstall \
LIBTOOL=/usr/bin/libtool
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files
%defattr(-,root,root)
%{python27_sitearch}/gtk-2.0/gtk/*.py*
%{python27_sitearch}/gtk-2.0/*.la
%{python27_sitearch}/gtk-2.0/*.so
%{python27_sitearch}/gtk-2.0/gtk/*.la
%{python27_sitearch}/gtk-2.0/gtk/*.so
%{_datadir}/pygtk/2.0/defs/pangocairo.override
%doc AUTHORS COPYING
#ChangeLog MAPPING NEWS README TODO
%files devel
%defattr(-,root,root)
%{_bindir}/pygtk-codegen-2.0
%dir %{_includedir}/pygtk-2.0/
%{_includedir}/pygtk-2.0/pygtk/*.h
%dir %{_datadir}/pygtk/
#%{_datadir}/pygtk/2.0/codegen/*
%{_datadir}/pygtk/2.0/defs/*.defs
%{_libdir}/pkgconfig/*.pc
%dir %{_datadir}/gtk-doc/html/pygtk
%{_datadir}/gtk-doc/html/pygtk/*
%files demos
%defattr(-,root,root)
%{_bindir}/pygtk-demo
%{_libdir}/pygtk/2.0/demos/*
%{_libdir}/pygtk/2.0/pygtk-demo*
%doc examples
%changelog
* Sun Apr 11 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.0-6mamba
- rebuilt without numpy
* Tue May 30 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.0-5mamba
- rebuilt to fix path on x86_64
* Sat May 18 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.0-4mamba
- python 2.7 mass rebuild
* Sat Jan 21 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.0-3mamba
- don't use %py_require macro to avoid requiring python3 and libpython3
* Thu Jan 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.0-2mamba
- require pygobject2, not pygobject
* Fri Sep 16 2011 Automatic Build System <autodist@mambasoft.it> 2.24.0-1mamba
- automatic version update by autodist
* Wed Sep 29 2010 Automatic Build System <autodist@mambasoft.it> 2.22.0-1mamba
- automatic update to 2.22.0 by autodist
* Sat May 29 2010 Automatic Build System <autodist@mambasoft.it> 2.17.0-1mamba
- automatic update to 2.17.0 by autodist
* Sat Oct 17 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.16.0-2mamba
- rebuilt with python-numpy
* Tue Sep 29 2009 Automatic Build System <autodist@mambasoft.it> 2.16.0-1mamba
- automatic update by autodist
* Thu May 21 2009 Automatic Build System <autodist@mambasoft.it> 2.14.1-2mamba
- automatic rebuild by autodist
* Wed May 06 2009 Automatic Build System <autodist@mambasoft.it> 2.14.1-1mamba
- automatic update by autodist
* Thu Dec 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.1-2mamba
- automatic rebuild by autodist
* Wed Oct 01 2008 gil <puntogil@libero.it> 2.12.1-1mamba
- update to 2.12.1
- removed patch
* Thu Sep 20 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.0-1mamba
- update to 2.12.0
* Thu Sep 20 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.6-1mamba
- update to 2.10.6
- added requirement for pygoject and pycairo
* Fri Mar 16 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.4-1qilnx
- update to version 2.10.4 by autospec
- added buildroot patch again; updated py-compile
- examples moved to demos package
* Mon Feb 05 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.3-1qilnx
- update to version 2.10.3 by autospec
- renamed from pygtk2 to pygtk
* Mon Nov 06 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2.6.3-1qilnx
- update to version 2.6.3 by autospec
* Tue Aug 09 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.2-1qilnx
- update to version 2.6.2 by autospec
* Thu Nov 25 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.4.1-1qilnx
- package created by autospec