rebuilt without numpy [release 2.24.0-6mamba;Sun Apr 11 2021]
This commit is contained in:
parent
a52153a874
commit
4475077373
39
pygtk-2.24.0-libpango-1.44.patch
Normal file
39
pygtk-2.24.0-libpango-1.44.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
From 877164b6b70780468a31d8211f29421b6f34b0c8 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mathieu Bridon <bochecha@daitauha.fr>
|
||||||
|
Date: Thu, 24 Oct 2019 22:58:36 +0200
|
||||||
|
Subject: [PATCH] Drop the PangoFont find_shaper virtual method
|
||||||
|
|
||||||
|
This API has been removed from Pango 1.44.6, because it was completely
|
||||||
|
unused by anything.
|
||||||
|
|
||||||
|
However, PyGTK tries to bind everything, even unused API.
|
||||||
|
|
||||||
|
Removing this from PyGTK means we can build it against the latest Pango
|
||||||
|
again.
|
||||||
|
---
|
||||||
|
pango.defs | 9 ---------
|
||||||
|
1 file changed, 9 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/pango.defs b/pango.defs
|
||||||
|
index 2a79ecc..862667a 100644
|
||||||
|
--- a/pango.defs
|
||||||
|
+++ b/pango.defs
|
||||||
|
@@ -1391,15 +1391,6 @@
|
||||||
|
)
|
||||||
|
)
|
||||||
|
|
||||||
|
-(define-virtual find_shaper
|
||||||
|
- (of-object "PangoFont")
|
||||||
|
- (return-type "PangoEngineShape*")
|
||||||
|
- (parameters
|
||||||
|
- '("PangoLanguage*" "lang")
|
||||||
|
- '("guint32" "ch")
|
||||||
|
- )
|
||||||
|
-)
|
||||||
|
-
|
||||||
|
(define-virtual get_glyph_extents
|
||||||
|
(of-object "PangoFont")
|
||||||
|
(return-type "none")
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
24
pygtk.spec
24
pygtk.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: pygtk
|
Name: pygtk
|
||||||
Version: 2.24.0
|
Version: 2.24.0
|
||||||
Release: 5mamba
|
Release: 6mamba
|
||||||
Summary: Python bindings for GTK+
|
Summary: Python bindings for GTK+
|
||||||
Group: Development/Bindings
|
Group: Development/Bindings
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -11,6 +11,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: http://www.pygtk.org/
|
URL: http://www.pygtk.org/
|
||||||
Source: http://ftp.gnome.org/pub/GNOME/sources/pygtk/%{majver}/pygtk-%{version}.tar.bz2
|
Source: http://ftp.gnome.org/pub/GNOME/sources/pygtk/%{majver}/pygtk-%{version}.tar.bz2
|
||||||
Patch0: pygtk-2.10.4-buildroot_fix.patch
|
Patch0: pygtk-2.10.4-buildroot_fix.patch
|
||||||
|
Patch1: pygtk-2.24.0-libpango-1.44.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -43,12 +44,11 @@ BuildRequires: pycairo-devel
|
|||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: python-numpy
|
BuildRequires: python-numpy
|
||||||
BuildRequires: python
|
BuildRequires: python
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
Provides: pygtk2
|
Provides: pygtk2
|
||||||
Obsoletes: pygtk2
|
Obsoletes: pygtk2
|
||||||
Requires: pygobject2
|
Requires: pygobject2
|
||||||
Requires: python-cairo
|
Requires: python-cairo
|
||||||
Requires: python-numpy
|
#Requires: python-numpy
|
||||||
Requires(pre): python
|
Requires(pre): python
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -81,12 +81,13 @@ Sample programs for %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n pygtk-%{version}
|
%setup -q -n pygtk-%{version}
|
||||||
#%patch0 -p1
|
#%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
--enable-thread \
|
--enable-thread \
|
||||||
--enable-numpy \
|
--disable-numpy \
|
||||||
PYTHON=%{__python}
|
PYTHON=%{__python27}
|
||||||
|
|
||||||
%make
|
%make
|
||||||
|
|
||||||
@ -101,11 +102,11 @@ export tagname=CC
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{python_sitearch}/gtk-2.0/gtk/*.py*
|
%{python27_sitearch}/gtk-2.0/gtk/*.py*
|
||||||
%{python_sitearch}/gtk-2.0/*.la
|
%{python27_sitearch}/gtk-2.0/*.la
|
||||||
%{python_sitearch}/gtk-2.0/*.so
|
%{python27_sitearch}/gtk-2.0/*.so
|
||||||
%{python_sitearch}/gtk-2.0/gtk/*.la
|
%{python27_sitearch}/gtk-2.0/gtk/*.la
|
||||||
%{python_sitearch}/gtk-2.0/gtk/*.so
|
%{python27_sitearch}/gtk-2.0/gtk/*.so
|
||||||
%{_datadir}/pygtk/2.0/defs/pangocairo.override
|
%{_datadir}/pygtk/2.0/defs/pangocairo.override
|
||||||
%doc AUTHORS COPYING
|
%doc AUTHORS COPYING
|
||||||
#ChangeLog MAPPING NEWS README TODO
|
#ChangeLog MAPPING NEWS README TODO
|
||||||
@ -130,6 +131,9 @@ export tagname=CC
|
|||||||
%doc examples
|
%doc examples
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Apr 11 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.0-6mamba
|
||||||
|
- rebuilt without numpy
|
||||||
|
|
||||||
* Tue May 30 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.0-5mamba
|
* Tue May 30 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.0-5mamba
|
||||||
- rebuilt to fix path on x86_64
|
- rebuilt to fix path on x86_64
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user