automatic version update by autodist [release 3.12.1-1mamba;Tue Apr 15 2014]

This commit is contained in:
Automatic Build System 2024-01-06 10:38:19 +01:00
parent eb11750797
commit d9e05e4257
3 changed files with 387 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# pygobject
PyGObject provides a convenient wrapper for the GObject+ library for use in Python programs, and takes care of many of the boring details such as managing memory and type casting. When combined with PyGTK, PyORBit and gnome-python, it can be used to write full featured Gnome applications.

View File

@ -0,0 +1,199 @@
diff -Nru pygobject-2.12.3.orig/gobject/Makefile.in pygobject-2.12.3/gobject/Makefile.in
--- pygobject-2.12.3.orig/gobject/Makefile.in 2006-11-18 15:53:19.000000000 +0100
+++ pygobject-2.12.3/gobject/Makefile.in 2007-03-16 19:18:18.000000000 +0100
@@ -718,7 +718,7 @@
else :; fi; \
done; \
test -z "$$dlist" || \
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(DESTDIR)$(pygobjectdir)" $$dlist
+ PYTHON=$(PYTHON) $(py_compile) --basedir "$(pygobjectdir)" --destdir $(DESTDIR) $$dlist
uninstall-pygobjectPYTHON:
@$(NORMAL_UNINSTALL)
diff -Nru pygobject-2.12.3.orig/Makefile.in pygobject-2.12.3/Makefile.in
--- pygobject-2.12.3.orig/Makefile.in 2006-11-18 15:53:18.000000000 +0100
+++ pygobject-2.12.3/Makefile.in 2007-03-16 19:17:54.000000000 +0100
@@ -383,7 +383,7 @@
else :; fi; \
done; \
test -z "$$dlist" || \
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(DESTDIR)$(pkgpyexecdir)" $$dlist
+ PYTHON=$(PYTHON) $(py_compile) --basedir "$(pkgpyexecdir)" --destdir $(DESTDIR) $$dlist
uninstall-pkgpyexecPYTHON:
@$(NORMAL_UNINSTALL)
@@ -406,7 +406,7 @@
else :; fi; \
done; \
test -z "$$dlist" || \
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(DESTDIR)$(pyexecdir)" $$dlist
+ PYTHON=$(PYTHON) $(py_compile) --basedir "$(pyexecdir)" --destdir $(DESTDIR) $$dlist
uninstall-pyexecPYTHON:
@$(NORMAL_UNINSTALL)
diff -Nru pygobject-2.12.3.orig/py-compile pygobject-2.12.3/py-compile
--- pygobject-2.12.3.orig/py-compile 2006-08-28 23:10:12.000000000 +0200
+++ pygobject-2.12.3/py-compile 2007-03-16 19:17:10.000000000 +0100
@@ -1,9 +1,9 @@
#!/bin/sh
# py-compile - Compile a Python program
-scriptversion=2004-01-12.23
+scriptversion=2005-05-14.22
-# Copyright (C) 2000, 2001, 2003, 2004 Free Software Foundation, Inc.
+# Copyright (C) 2000, 2001, 2003, 2004, 2005 Free Software Foundation, Inc.
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -17,8 +17,8 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
-# 02111-1307, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+# 02110-1301, USA.
# As a special exception to the GNU General Public License, if you
# distribute this file as part of a program that contains a
@@ -34,34 +34,54 @@
fi
basedir=
+destdir=
+files=
+while test $# -ne 0; do
+ case "$1" in
+ --basedir)
+ basedir=$2
+ if test -z "$basedir"; then
+ echo "$0: Missing argument to --basedir." 1>&2
+ exit 1
+ fi
+ shift
+ ;;
+ --destdir)
+ destdir=$2
+ if test -z "$destdir"; then
+ echo "$0: Missing argument to --destdir." 1>&2
+ exit 1
+ fi
+ shift
+ ;;
+ -h|--h*)
+ cat <<\EOF
+Usage: py-compile [--help] [--version] [--basedir DIR] [--destdir DIR] FILES..."
+
+Byte compile some python scripts FILES. Use --destdir to specify any
+leading directory path to the FILES that you don't want to include in the
+byte compiled file. Specify --basedir for any additional path information you
+do want to be shown in the byte compiled file.
-case "$1" in
- --basedir)
- basedir=$2
- if test -z "$basedir"; then
- echo "$0: Missing argument to --basedir." 1>&2
- exit 1
- fi
- shift 2
- ;;
- -h|--h*)
- cat <<\EOF
-Usage: py-compile [--help] [--version] [--basedir DIR] FILES..."
-
-Byte compile some python scripts FILES. This should be performed
-after they have been moved to the final installation location
+Example:
+ py-compile --destdir /tmp/pkg-root --basedir /usr/share/test test.py test2.py
Report bugs to <bug-automake@gnu.org>.
EOF
- exit 0
- ;;
- -v|--v*)
- echo "py-compile $scriptversion"
- exit 0
- ;;
-esac
+ exit $?
+ ;;
+ -v|--v*)
+ echo "py-compile $scriptversion"
+ exit $?
+ ;;
+ *)
+ files="$files $1"
+ ;;
+ esac
+ shift
+done
-if [ $# = 0 ]; then
+if test -z "$files"; then
echo "$0: No files given. Try \`$0 --help' for more information." 1>&2
exit 1
fi
@@ -69,38 +89,51 @@
# if basedir was given, then it should be prepended to filenames before
# byte compilation.
if [ -z "$basedir" ]; then
- trans="path = file"
+ pathtrans="path = file"
else
- trans="path = os.path.join('$basedir', file)"
+ pathtrans="path = os.path.join('$basedir', file)"
+fi
+
+# if destdir was given, then it needs to be prepended to the filename to
+# byte compile but not go into the compiled file.
+if [ -z "$destdir" ]; then
+ filetrans="filepath = path"
+else
+ filetrans="filepath = os.path.normpath('$destdir' + os.sep + path)"
fi
$PYTHON -c "
import sys, os, string, py_compile
-files = '''$*'''
+files = '''$files'''
+
print 'Byte-compiling python modules...'
for file in string.split(files):
- $trans
- if not os.path.exists(path) or not (len(path) >= 3 and path[-3:] == '.py'):
+ $pathtrans
+ $filetrans
+ if not os.path.exists(filepath) or not (len(filepath) >= 3
+ and filepath[-3:] == '.py'):
continue
print file,
sys.stdout.flush()
- py_compile.compile(path)
+ py_compile.compile(filepath, filepath + 'c', path)
print" || exit $?
# this will fail for python < 1.5, but that doesn't matter ...
$PYTHON -O -c "
import sys, os, string, py_compile
-files = '''$*'''
+files = '''$files'''
print 'Byte-compiling python modules (optimized versions) ...'
for file in string.split(files):
- $trans
- if not os.path.exists(path) or not (len(path) >= 3 and path[-3:] == '.py'):
+ $pathtrans
+ $filetrans
+ if not os.path.exists(filepath) or not (len(filepath) >= 3
+ and filepath[-3:] == '.py'):
continue
print file,
sys.stdout.flush()
- py_compile.compile(path)
+ py_compile.compile(filepath, filepath + 'o', path)
print" 2>/dev/null || :
# Local Variables:

186
pygobject.spec Normal file
View File

@ -0,0 +1,186 @@
%define majver %(echo %version | cut -d. -f 1-2)
Name: pygobject
Version: 3.12.1
Release: 1mamba
Summary: A convenient wrapper for the GObject+ library for use in Python programs
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.pygtk.org
Source: http://ftp.gnome.org/pub/GNOME/sources/pygobject/%{majver}/pygobject-%{version}.tar.xz
Patch0: %{name}-2.12.3-buildroot_fix.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libcairo-devel
BuildRequires: libexpat-devel
BuildRequires: libffi-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libGL-devel
BuildRequires: libglib-devel
BuildRequires: libpixman-devel
BuildRequires: libpng-devel
BuildRequires: libpthread-stubs-devel
BuildRequires: libpython-devel
BuildRequires: libselinux-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libXdmcp-devel
BuildRequires: libXrender-devel
BuildRequires: libz-devel
BuildRequires: udev-devel
## AUTOBUILDREQ-END
BuildRequires: py2cairo-devel
Requires: python >= %python_version
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
PyGObject provides a convenient wrapper for the GObject+ library for use in Python programs, and takes care of many of the boring details such as managing memory and type casting. When combined with PyGTK, PyORBit and gnome-python, it can be used to write full featured Gnome applications.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
PyGObject provides a convenient wrapper for the GObject+ library for use in Python programs, and takes care of many of the boring details such as managing memory and type casting. When combined with PyGTK, PyORBit and gnome-python, it can be used to write full featured Gnome applications.
This package contains static libraries and header files need for development.
%prep
%setup -q
#%patch0 -p1
%build
%configure \
--enable-docs \
PYTHON=%{__python}
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{python_sitearch}/*
#%{_libdir}/libpyglib-gi-2.0-python%{python_version}.so.*
%doc AUTHORS COPYING
%files devel
%defattr(-,root,root)
%dir %{_includedir}/pygobject-3.0
%{_includedir}/pygobject-3.0/pygobject.h
#%{_libdir}/libpyglib-gi-2.0-python%{python_version}.la
#%{_libdir}/libpyglib-gi-2.0-python%{python_version}.so
%{_libdir}/pkgconfig/*.pc
%doc ChangeLog NEWS README
%changelog
* Tue Apr 15 2014 Automatic Build System <autodist@mambasoft.it> 3.12.1-1mamba
- automatic version update by autodist
* Sun Mar 30 2014 Automatic Build System <autodist@mambasoft.it> 3.12.0-1mamba
- automatic version update by autodist
* Mon Nov 11 2013 Automatic Build System <autodist@mambasoft.it> 3.10.2-1mamba
- automatic version update by autodist
* Mon Oct 28 2013 Automatic Build System <autodist@mambasoft.it> 3.10.1-1mamba
- automatic version update by autodist
* Sat Sep 28 2013 Automatic Build System <autodist@mambasoft.it> 3.10.0-1mamba
- automatic update by autodist
* Mon Jul 08 2013 Automatic Build System <autodist@mambasoft.it> 3.8.3-1mamba
- automatic version update by autodist
* Sun May 19 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.8.2-2mamba
- python 2.7 rebuild
* Mon May 13 2013 Automatic Build System <autodist@mambasoft.it> 3.8.2-1mamba
- automatic version update by autodist
* Mon Apr 15 2013 Automatic Build System <autodist@mambasoft.it> 3.8.1-1mamba
- automatic version update by autodist
* Thu Mar 28 2013 Automatic Build System <autodist@mambasoft.it> 3.8.0-1mamba
- automatic version update by autodist
* Mon Oct 22 2012 Automatic Build System <autodist@mambasoft.it> 3.7.1-1mamba
- automatic version update by autodist
* Thu Oct 18 2012 Automatic Build System <autodist@mambasoft.it> 3.4.1.1-1mamba
- automatic version update by autodist
* Mon Oct 15 2012 Automatic Build System <autodist@mambasoft.it> 3.4.1-1mamba
- automatic version update by autodist
* Thu Sep 27 2012 Automatic Build System <autodist@mambasoft.it> 3.4.0-1mamba
- automatic version update by autodist
* Mon May 14 2012 Automatic Build System <autodist@mambasoft.it> 3.2.2-1mamba
- automatic version update by autodist
* Thu May 10 2012 Automatic Build System <autodist@mambasoft.it> 3.2.1-1mamba
- automatic version update by autodist
* Mon Apr 02 2012 Automatic Build System <autodist@mambasoft.it> 3.2.0-1mamba
- automatic version update by autodist
* Wed Oct 19 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 3.0.1-1mamba
- update to 3.0.1
* Sun Jun 19 2011 Automatic Build System <autodist@mambasoft.it> 2.28.6-1mamba
- automatic update by autodist
* Fri Apr 15 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.28.3-1mamba
- update to 2.28.3
* Mon Oct 04 2010 Automatic Build System <autodist@mambasoft.it> 2.26.0-1mamba
- automatic update to 2.26.0 by autodist
* Sat Sep 25 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.21.5-2mamba
- rebuilt with libffi 3.0.9
* Tue Aug 17 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.21.5-1mamba
- update to 2.21.5
* Wed Jun 30 2010 Automatic Build System <autodist@mambasoft.it> 2.21.4-1mamba
- automatic update to 2.21.4 by autodist
* Mon Jun 21 2010 Automatic Build System <autodist@mambasoft.it> 2.21.3-1mamba
- automatic update to 2.21.3 by autodist
* Fri Jun 11 2010 Automatic Build System <autodist@mambasoft.it> 2.21.2-1mamba
- automatic update to 2.21.2 by autodist
* Mon May 31 2010 Automatic Build System <autodist@mambasoft.it> 2.21.1-1mamba
- automatic update to 2.21.1 by autodist
* Mon Sep 28 2009 Automatic Build System <autodist@mambasoft.it> 2.20.0-1mamba
- automatic update to 2.20.0 by autodist
* Thu Dec 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.15.4-2mamba
- rebuilt with python 2.6
* Wed Oct 01 2008 gil <puntogil@libero.it> 2.15.4-1mamba
- update to 2.15.4
- removed patch
* Thu Sep 20 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.14.0-1mamba
- update to 2.14.0
* Fri Mar 16 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.3-2qilnx
- added buildroot_fix patch to remove buildroot in compiled files
* Mon Feb 05 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.12.3-1qilnx
- package created by autospec