automatic version update by autodist [release 3.48.2-1mamba;Fri Apr 26 2024]
This commit is contained in:
parent
431a7f6c4d
commit
0f69a2eb8c
@ -1,199 +0,0 @@
|
|||||||
diff -Nru pygobject-2.12.3.orig/gobject/Makefile.in pygobject-2.12.3/gobject/Makefile.in
|
|
||||||
--- pygobject-2.12.3.orig/gobject/Makefile.in 2006-11-18 15:53:19.000000000 +0100
|
|
||||||
+++ pygobject-2.12.3/gobject/Makefile.in 2007-03-16 19:18:18.000000000 +0100
|
|
||||||
@@ -718,7 +718,7 @@
|
|
||||||
else :; fi; \
|
|
||||||
done; \
|
|
||||||
test -z "$$dlist" || \
|
|
||||||
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(DESTDIR)$(pygobjectdir)" $$dlist
|
|
||||||
+ PYTHON=$(PYTHON) $(py_compile) --basedir "$(pygobjectdir)" --destdir $(DESTDIR) $$dlist
|
|
||||||
|
|
||||||
uninstall-pygobjectPYTHON:
|
|
||||||
@$(NORMAL_UNINSTALL)
|
|
||||||
diff -Nru pygobject-2.12.3.orig/Makefile.in pygobject-2.12.3/Makefile.in
|
|
||||||
--- pygobject-2.12.3.orig/Makefile.in 2006-11-18 15:53:18.000000000 +0100
|
|
||||||
+++ pygobject-2.12.3/Makefile.in 2007-03-16 19:17:54.000000000 +0100
|
|
||||||
@@ -383,7 +383,7 @@
|
|
||||||
else :; fi; \
|
|
||||||
done; \
|
|
||||||
test -z "$$dlist" || \
|
|
||||||
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(DESTDIR)$(pkgpyexecdir)" $$dlist
|
|
||||||
+ PYTHON=$(PYTHON) $(py_compile) --basedir "$(pkgpyexecdir)" --destdir $(DESTDIR) $$dlist
|
|
||||||
|
|
||||||
uninstall-pkgpyexecPYTHON:
|
|
||||||
@$(NORMAL_UNINSTALL)
|
|
||||||
@@ -406,7 +406,7 @@
|
|
||||||
else :; fi; \
|
|
||||||
done; \
|
|
||||||
test -z "$$dlist" || \
|
|
||||||
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(DESTDIR)$(pyexecdir)" $$dlist
|
|
||||||
+ PYTHON=$(PYTHON) $(py_compile) --basedir "$(pyexecdir)" --destdir $(DESTDIR) $$dlist
|
|
||||||
|
|
||||||
uninstall-pyexecPYTHON:
|
|
||||||
@$(NORMAL_UNINSTALL)
|
|
||||||
diff -Nru pygobject-2.12.3.orig/py-compile pygobject-2.12.3/py-compile
|
|
||||||
--- pygobject-2.12.3.orig/py-compile 2006-08-28 23:10:12.000000000 +0200
|
|
||||||
+++ pygobject-2.12.3/py-compile 2007-03-16 19:17:10.000000000 +0100
|
|
||||||
@@ -1,9 +1,9 @@
|
|
||||||
#!/bin/sh
|
|
||||||
# py-compile - Compile a Python program
|
|
||||||
|
|
||||||
-scriptversion=2004-01-12.23
|
|
||||||
+scriptversion=2005-05-14.22
|
|
||||||
|
|
||||||
-# Copyright (C) 2000, 2001, 2003, 2004 Free Software Foundation, Inc.
|
|
||||||
+# Copyright (C) 2000, 2001, 2003, 2004, 2005 Free Software Foundation, Inc.
|
|
||||||
|
|
||||||
# This program is free software; you can redistribute it and/or modify
|
|
||||||
# it under the terms of the GNU General Public License as published by
|
|
||||||
@@ -17,8 +17,8 @@
|
|
||||||
|
|
||||||
# You should have received a copy of the GNU General Public License
|
|
||||||
# along with this program; if not, write to the Free Software
|
|
||||||
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
|
|
||||||
-# 02111-1307, USA.
|
|
||||||
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
|
|
||||||
+# 02110-1301, USA.
|
|
||||||
|
|
||||||
# As a special exception to the GNU General Public License, if you
|
|
||||||
# distribute this file as part of a program that contains a
|
|
||||||
@@ -34,34 +34,54 @@
|
|
||||||
fi
|
|
||||||
|
|
||||||
basedir=
|
|
||||||
+destdir=
|
|
||||||
+files=
|
|
||||||
+while test $# -ne 0; do
|
|
||||||
+ case "$1" in
|
|
||||||
+ --basedir)
|
|
||||||
+ basedir=$2
|
|
||||||
+ if test -z "$basedir"; then
|
|
||||||
+ echo "$0: Missing argument to --basedir." 1>&2
|
|
||||||
+ exit 1
|
|
||||||
+ fi
|
|
||||||
+ shift
|
|
||||||
+ ;;
|
|
||||||
+ --destdir)
|
|
||||||
+ destdir=$2
|
|
||||||
+ if test -z "$destdir"; then
|
|
||||||
+ echo "$0: Missing argument to --destdir." 1>&2
|
|
||||||
+ exit 1
|
|
||||||
+ fi
|
|
||||||
+ shift
|
|
||||||
+ ;;
|
|
||||||
+ -h|--h*)
|
|
||||||
+ cat <<\EOF
|
|
||||||
+Usage: py-compile [--help] [--version] [--basedir DIR] [--destdir DIR] FILES..."
|
|
||||||
+
|
|
||||||
+Byte compile some python scripts FILES. Use --destdir to specify any
|
|
||||||
+leading directory path to the FILES that you don't want to include in the
|
|
||||||
+byte compiled file. Specify --basedir for any additional path information you
|
|
||||||
+do want to be shown in the byte compiled file.
|
|
||||||
|
|
||||||
-case "$1" in
|
|
||||||
- --basedir)
|
|
||||||
- basedir=$2
|
|
||||||
- if test -z "$basedir"; then
|
|
||||||
- echo "$0: Missing argument to --basedir." 1>&2
|
|
||||||
- exit 1
|
|
||||||
- fi
|
|
||||||
- shift 2
|
|
||||||
- ;;
|
|
||||||
- -h|--h*)
|
|
||||||
- cat <<\EOF
|
|
||||||
-Usage: py-compile [--help] [--version] [--basedir DIR] FILES..."
|
|
||||||
-
|
|
||||||
-Byte compile some python scripts FILES. This should be performed
|
|
||||||
-after they have been moved to the final installation location
|
|
||||||
+Example:
|
|
||||||
+ py-compile --destdir /tmp/pkg-root --basedir /usr/share/test test.py test2.py
|
|
||||||
|
|
||||||
Report bugs to <bug-automake@gnu.org>.
|
|
||||||
EOF
|
|
||||||
- exit 0
|
|
||||||
- ;;
|
|
||||||
- -v|--v*)
|
|
||||||
- echo "py-compile $scriptversion"
|
|
||||||
- exit 0
|
|
||||||
- ;;
|
|
||||||
-esac
|
|
||||||
+ exit $?
|
|
||||||
+ ;;
|
|
||||||
+ -v|--v*)
|
|
||||||
+ echo "py-compile $scriptversion"
|
|
||||||
+ exit $?
|
|
||||||
+ ;;
|
|
||||||
+ *)
|
|
||||||
+ files="$files $1"
|
|
||||||
+ ;;
|
|
||||||
+ esac
|
|
||||||
+ shift
|
|
||||||
+done
|
|
||||||
|
|
||||||
-if [ $# = 0 ]; then
|
|
||||||
+if test -z "$files"; then
|
|
||||||
echo "$0: No files given. Try \`$0 --help' for more information." 1>&2
|
|
||||||
exit 1
|
|
||||||
fi
|
|
||||||
@@ -69,38 +89,51 @@
|
|
||||||
# if basedir was given, then it should be prepended to filenames before
|
|
||||||
# byte compilation.
|
|
||||||
if [ -z "$basedir" ]; then
|
|
||||||
- trans="path = file"
|
|
||||||
+ pathtrans="path = file"
|
|
||||||
else
|
|
||||||
- trans="path = os.path.join('$basedir', file)"
|
|
||||||
+ pathtrans="path = os.path.join('$basedir', file)"
|
|
||||||
+fi
|
|
||||||
+
|
|
||||||
+# if destdir was given, then it needs to be prepended to the filename to
|
|
||||||
+# byte compile but not go into the compiled file.
|
|
||||||
+if [ -z "$destdir" ]; then
|
|
||||||
+ filetrans="filepath = path"
|
|
||||||
+else
|
|
||||||
+ filetrans="filepath = os.path.normpath('$destdir' + os.sep + path)"
|
|
||||||
fi
|
|
||||||
|
|
||||||
$PYTHON -c "
|
|
||||||
import sys, os, string, py_compile
|
|
||||||
|
|
||||||
-files = '''$*'''
|
|
||||||
+files = '''$files'''
|
|
||||||
+
|
|
||||||
print 'Byte-compiling python modules...'
|
|
||||||
for file in string.split(files):
|
|
||||||
- $trans
|
|
||||||
- if not os.path.exists(path) or not (len(path) >= 3 and path[-3:] == '.py'):
|
|
||||||
+ $pathtrans
|
|
||||||
+ $filetrans
|
|
||||||
+ if not os.path.exists(filepath) or not (len(filepath) >= 3
|
|
||||||
+ and filepath[-3:] == '.py'):
|
|
||||||
continue
|
|
||||||
print file,
|
|
||||||
sys.stdout.flush()
|
|
||||||
- py_compile.compile(path)
|
|
||||||
+ py_compile.compile(filepath, filepath + 'c', path)
|
|
||||||
print" || exit $?
|
|
||||||
|
|
||||||
# this will fail for python < 1.5, but that doesn't matter ...
|
|
||||||
$PYTHON -O -c "
|
|
||||||
import sys, os, string, py_compile
|
|
||||||
|
|
||||||
-files = '''$*'''
|
|
||||||
+files = '''$files'''
|
|
||||||
print 'Byte-compiling python modules (optimized versions) ...'
|
|
||||||
for file in string.split(files):
|
|
||||||
- $trans
|
|
||||||
- if not os.path.exists(path) or not (len(path) >= 3 and path[-3:] == '.py'):
|
|
||||||
+ $pathtrans
|
|
||||||
+ $filetrans
|
|
||||||
+ if not os.path.exists(filepath) or not (len(filepath) >= 3
|
|
||||||
+ and filepath[-3:] == '.py'):
|
|
||||||
continue
|
|
||||||
print file,
|
|
||||||
sys.stdout.flush()
|
|
||||||
- py_compile.compile(path)
|
|
||||||
+ py_compile.compile(filepath, filepath + 'o', path)
|
|
||||||
print" 2>/dev/null || :
|
|
||||||
|
|
||||||
# Local Variables:
|
|
@ -1,16 +1,15 @@
|
|||||||
%define majver %(echo %version | cut -d. -f 1-2)
|
%define majver %(echo %version | cut -d. -f 1-2)
|
||||||
|
|
||||||
Name: pygobject
|
Name: pygobject
|
||||||
Version: 3.46.0
|
Version: 3.48.2
|
||||||
Release: 2mamba
|
Release: 1mamba
|
||||||
Summary: A convenient wrapper for the GObject+ library for use in Python programs
|
Summary: A convenient wrapper for the GObject+ library for use in Python programs
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://pygobject.readthedocs.io/en/latest/
|
URL: https://pygobject.gnome.org/
|
||||||
Source: https://download.gnome.org/sources/pygobject/%{majver}/pygobject-%{version}.tar.xz
|
Source: https://download.gnome.org/sources/pygobject/%{majver}/pygobject-%{version}.tar.xz
|
||||||
Patch0: %{name}-2.12.3-buildroot_fix.patch
|
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -21,15 +20,12 @@ BuildRequires: libglib-devel
|
|||||||
BuildRequires: libpython311-devel
|
BuildRequires: libpython311-devel
|
||||||
BuildRequires: python3.11dist(pycairo)
|
BuildRequires: python3.11dist(pycairo)
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: python-meson-py3
|
||||||
BuildRequires: python3-devel >= 3.11.5-3mamba
|
BuildRequires: python3-devel >= 3.11.5-3mamba
|
||||||
|
|
||||||
%description
|
%description
|
||||||
PyGObject provides a convenient wrapper for the GObject+ library for use in Python programs, and takes care of many of the boring details such as managing memory and type casting. When combined with PyGTK, PyORBit and gnome-python, it can be used to write full featured Gnome applications.
|
PyGObject provides a convenient wrapper for the GObject+ library for use in Python programs, and takes care of many of the boring details such as managing memory and type casting. When combined with PyGTK, PyORBit and gnome-python, it can be used to write full featured Gnome applications.
|
||||||
|
|
||||||
%if "%{?with_pyver}"
|
|
||||||
%pyver_package
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Devel package for %{name}
|
Summary: Devel package for %{name}
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -38,27 +34,32 @@ Group: Development/Libraries
|
|||||||
PyGObject provides a convenient wrapper for the GObject+ library for use in Python programs, and takes care of many of the boring details such as managing memory and type casting. When combined with PyGTK, PyORBit and gnome-python, it can be used to write full featured Gnome applications.
|
PyGObject provides a convenient wrapper for the GObject+ library for use in Python programs, and takes care of many of the boring details such as managing memory and type casting. When combined with PyGTK, PyORBit and gnome-python, it can be used to write full featured Gnome applications.
|
||||||
This package contains static libraries and header files need for development.
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%if "%{?with_pyver}"
|
||||||
|
%define py_requires_append \
|
||||||
|
Obsoletes: pygobject-py310 < 3.48.2 \
|
||||||
|
Obsoletes: pygobject-devel < 3.48.2
|
||||||
|
%pyver_package
|
||||||
|
%endif
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CFLAGS="%{optflags}" %{__python} setup.py build
|
CFLAGS="%{optflags}" %{__python} -m build --no-isolation --wheel
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%{__python} setup.py install \
|
%{__python} -m installer --destdir=%{buildroot} dist/*.whl
|
||||||
-O1 --skip-build \
|
|
||||||
--root="%{buildroot}" \
|
|
||||||
--install-headers=%{python_inc} \
|
|
||||||
--install-lib=%{python_sitearch} \
|
|
||||||
--record=%{name}.filelist
|
|
||||||
|
|
||||||
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
#%if "%{?with_pyver}" != "3"
|
||||||
|
## Rename any conflicting file outside of python site packages tree
|
||||||
|
#for f in %{_bindir}/pdm; do
|
||||||
|
# mv %{buildroot}${f}{,-%{?pyappend}}
|
||||||
|
#done
|
||||||
|
#%endi
|
||||||
|
|
||||||
%ifarch x86_64 aarch64
|
%ifarch x86_64 aarch64
|
||||||
[ -e %{buildroot}%{_prefix}/lib/pkgconfig ] && {
|
[ -e %{buildroot}%{_prefix}/lib/pkgconfig ] && {
|
||||||
sed -i "s|%{_prefix}/lib/pkgconfig|%{_libdir}/pkgconfig|" %{name}.filelist
|
|
||||||
mv %{buildroot}%{_prefix}/lib/pkgconfig %{buildroot}%{_libdir}
|
mv %{buildroot}%{_prefix}/lib/pkgconfig %{buildroot}%{_libdir}
|
||||||
}
|
}
|
||||||
%endif
|
%endif
|
||||||
@ -66,22 +67,21 @@ sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
|||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%files %{?pyappend} -f %{name}.filelist
|
%files %{?pyappend}
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{python_sitearch}/PyGObject-%{version}-py*.egg-info
|
%dir %{python_sitearch}/pygobject-%{version}.dist-info
|
||||||
%{python_sitearch}/PyGObject-%{version}-py*.egg-info/*
|
%{python_sitearch}/pygobject-%{version}.dist-info/*
|
||||||
%exclude %{_includedir}
|
%dir %{python_sitearch}/gi
|
||||||
%exclude %{_libdir}/pkgconfig
|
%{python_sitearch}/gi/*
|
||||||
|
%dir %{python_sitearch}/pygtkcompat
|
||||||
|
%{python_sitearch}/pygtkcompat/*
|
||||||
|
%{_includedir}/python*/pygobject/pygobject-3.0/pygobject.h
|
||||||
%doc COPYING
|
%doc COPYING
|
||||||
|
|
||||||
%files devel
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%dir %{_includedir}/pygobject-3.0
|
|
||||||
%{_includedir}/pygobject-3.0/pygobject.h
|
|
||||||
%{_libdir}/pkgconfig/*.pc
|
|
||||||
%doc NEWS
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 26 2024 Automatic Build System <autodist@openmamba.org> 3.48.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Tue Sep 26 2023 Automatic Build System <autodist@mambasoft.it> 3.46.0-2mamba
|
* Tue Sep 26 2023 Automatic Build System <autodist@mambasoft.it> 3.46.0-2mamba
|
||||||
- rebuilt by autoport with build requirements: python3-devel>=3.11.5-3mamba
|
- rebuilt by autoport with build requirements: python3-devel>=3.11.5-3mamba
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user