update to 0.43.4 [release 0.43.4-1mamba;Thu Aug 01 2013]

This commit is contained in:
Automatic Build System 2024-01-06 10:35:57 +01:00
parent 65dadd6c55
commit eb51f8ba8d
6 changed files with 183 additions and 0 deletions

View File

@ -1,2 +1,7 @@
# puredata
PD (aka Pure Data) is a real-time graphical programming environment for audio, video, and graphical processing. It is the third major branch of the family of patcher programming languages known as Max (Max/FTS, ISPW Max, Max/MSP, jMax, etc.) originally developed by Miller Puckette and company at IRCAM. The core of Pd is written and maintained by Miller Puckette and includes the work of many developers, making the whole package very much a community effort.
Pd was created to explore ideas of how to further refine the Max paradigm with the core ideas of allowing data to be treated in a more open-ended way and opening it up to applications outside of audio and MIDI, such as graphics and video.
It is easy to extend Pd by writing object classes ("externals") or patches ("abstractions"). The work of many developers is already available as part of the standard Pd packages and the Pd developer community is growing rapidly. Recent developments include a system of abstractions for building performance environments; a library of objects for physical modeling; and a library of objects for generating and processing video in realtime.
Pd is free software and can be downloaded either as an OS-specific package, source package, or directly from CVS. Pd was written to be multi-platform and therefore is quite portable; versions exist for Win32, IRIX, GNU/Linux, BSD, and MacOS X running on anything from a PocketPC to an old Mac to a brand new PC. It is possible to write externals and patches that work with Max/MSP and Pd using flext and cyclone.

17
pd-0.41-4-filetmp.patch Normal file
View File

@ -0,0 +1,17 @@
--- pd-0.41-4/src/makefile.in 2008-10-01 16:56:06.000000000 +0200
+++ pd-0.41-4/src/makefile.in-gil 2008-10-01 17:00:53.000000000 +0200
@@ -181,10 +181,10 @@
install -d $(DESTDIR)$(pddocdir)/7.stuff/$$dir ; \
install -m644 -p ../doc/7.stuff/$$dir/*.* $(DESTDIR)$(pddocdir)/7.stuff/$$dir ; \
done
- mv $(ABOUT_FILE) $(ABOUT_FILE).tmp
- cat $(ABOUT_FILE).tmp | sed 's|PD_VERSION|Pd version $(PD_VERSION)|' \
- > $(ABOUT_FILE)
- rm $(ABOUT_FILE).tmp
+ mv $(DESTDIR)$(ABOUT_FILE) $(DESTDIR)$(ABOUT_FILE).tmp
+ cat $(DESTDIR)$(ABOUT_FILE).tmp | sed 's|PD_VERSION|Pd version $(PD_VERSION)|' \
+ > $(DESTDIR)$(ABOUT_FILE)
+ rm $(DESTDIR)$(ABOUT_FILE).tmp
cp -pr ../extra $(DESTDIR)$(libpddir)/
rm -f $(DESTDIR)$(libpddir)/extra/*/*.o
install -d $(DESTDIR)$(includedir)

43
pd-0.41-4-makefile.patch Normal file
View File

@ -0,0 +1,43 @@
--- pd-0.41-4/src/makefile.in 2008-03-15 01:03:00.000000000 +0100
+++ pd-0.41-4/src/makefile.in-gil 2008-10-01 16:51:54.000000000 +0200
@@ -163,30 +163,30 @@
ABOUT_FILE=$(pddocdir)/1.manual/1.introduction.txt
install: all
- install -d $(libpdbindir)
- install $(BIN_DIR)/$(GUINAME) $(libpdbindir)/$(GUINAME)
- install $(BIN_DIR)/pd-watchdog $(libpdbindir)/pd-watchdog
- install -m644 $(BIN_DIR)/pd.tk $(libpdbindir)/pd.tk
+ install -d $(DESTDIR)$(libpdbindir)
+ install $(BIN_DIR)/$(GUINAME) $(DESTDIR)$(libpdbindir)/$(GUINAME)
+ install $(BIN_DIR)/pd-watchdog $(DESTDIR)$(libpdbindir)/pd-watchdog
+ install -m644 $(BIN_DIR)/pd.tk $(DESTDIR)$(libpdbindir)/pd.tk
install -d $(DESTDIR)$(bindir)
install $(BINARYMODE) $(PDEXEC) $(DESTDIR)$(bindir)/pd
install -m755 $(BIN_DIR)/pdsend $(DESTDIR)$(bindir)/pdsend
install -m755 $(BIN_DIR)/pdreceive $(DESTDIR)$(bindir)/pdreceive
for dir in $(shell ls -1 ../doc | grep -v CVS); do \
echo "installing $$dir"; \
- install -d $(pddocdir)/$$dir ; \
- install -m644 -p ../doc/$$dir/*.* $(pddocdir)/$$dir ; \
+ install -d $(DESTDIR)$(pddocdir)/$$dir ; \
+ install -m644 -p ../doc/$$dir/*.* $(DESTDIR)$(pddocdir)/$$dir ; \
done
for dir in $(shell ls -1 ../doc/7.stuff | grep -v CVS); do \
echo "installing 7.stuff/$$dir"; \
- install -d $(pddocdir)/7.stuff/$$dir ; \
- install -m644 -p ../doc/7.stuff/$$dir/*.* $(pddocdir)/7.stuff/$$dir ; \
+ install -d $(DESTDIR)$(pddocdir)/7.stuff/$$dir ; \
+ install -m644 -p ../doc/7.stuff/$$dir/*.* $(DESTDIR)$(pddocdir)/7.stuff/$$dir ; \
done
mv $(ABOUT_FILE) $(ABOUT_FILE).tmp
cat $(ABOUT_FILE).tmp | sed 's|PD_VERSION|Pd version $(PD_VERSION)|' \
> $(ABOUT_FILE)
rm $(ABOUT_FILE).tmp
- cp -pr ../extra $(libpddir)/
- rm -f $(libpddir)/extra/*/*.o
+ cp -pr ../extra $(DESTDIR)$(libpddir)/
+ rm -f $(DESTDIR)$(libpddir)/extra/*/*.o
install -d $(DESTDIR)$(includedir)
install -m644 m_pd.h $(DESTDIR)$(includedir)/m_pd.h
install -d $(DESTDIR)$(mandir)/man1

View File

@ -0,0 +1,12 @@
diff -Nru pd-0.42-5.orig/src/makefile.in pd-0.42-5/src/makefile.in
--- pd-0.42-5.orig/src/makefile.in 2009-08-08 20:27:21.000000000 +0200
+++ pd-0.42-5/src/makefile.in 2009-08-08 20:27:39.000000000 +0200
@@ -163,7 +163,7 @@
BINARYMODE=@binarymode@
-ABOUT_FILE=$(DESTDIR)$(pddocdir)/1.manual/1.introduction.txt
+ABOUT_FILE=$(pddocdir)/1.manual/1.introduction.txt
install: all
install -d $(DESTDIR)$(libpdbindir)
install $(BIN_DIR)/$(GUINAME) $(DESTDIR)$(libpdbindir)/$(GUINAME)

BIN
puredata.png Normal file

Binary file not shown.

After

Width:  |  Height:  |  Size: 2.2 KiB

106
puredata.spec Normal file
View File

@ -0,0 +1,106 @@
%define majver %(echo %version | cut -d. -f1-2)
%define minver %(echo %version | cut -d. -f3)
Name: puredata
Version: 0.43.4
Release: 1mamba
Summary: A real-time graphical programming environment for audio, video, and graphical processing
Group: Graphical Desktop/Applications/Multimedia
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://puredata.info
Source0: http://downloads.sourceforge.net/project/pure-data/pure-data/%{version}/pd-%{majver}-%{minver}.src.tar.gz
Source1: %{name}.png
Patch0: pd-0.41-4-makefile.patch
Patch1: pd-0.41-4-filetmp.patch
Patch2: %{name}-0.42.5-DESTDIR.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libalsa-devel
BuildRequires: libjack-devel
BuildRequires: libtcl-devel
BuildRequires: libtk-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
PD (aka Pure Data) is a real-time graphical programming environment for audio, video, and graphical processing. It is the third major branch of the family of patcher programming languages known as Max (Max/FTS, ISPW Max, Max/MSP, jMax, etc.) originally developed by Miller Puckette and company at IRCAM. The core of Pd is written and maintained by Miller Puckette and includes the work of many developers, making the whole package very much a community effort.
Pd was created to explore ideas of how to further refine the Max paradigm with the core ideas of allowing data to be treated in a more open-ended way and opening it up to applications outside of audio and MIDI, such as graphics and video.
It is easy to extend Pd by writing object classes ("externals") or patches ("abstractions"). The work of many developers is already available as part of the standard Pd packages and the Pd developer community is growing rapidly. Recent developments include a system of abstractions for building performance environments; a library of objects for physical modeling; and a library of objects for generating and processing video in realtime.
Pd is free software and can be downloaded either as an OS-specific package, source package, or directly from CVS. Pd was written to be multi-platform and therefore is quite portable; versions exist for Win32, IRIX, GNU/Linux, BSD, and MacOS X running on anything from a PocketPC to an old Mac to a brand new PC. It is possible to write externals and patches that work with Max/MSP and Pd using flext and cyclone.
%prep
%setup -q -n pd-%{majver}-%{minver}
#%patch0 -p1
%patch1 -p1
%patch2 -p1
%build
cd src
%configure --enable-jack --enable-alsa
make -j1
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
cd src
%makeinstall MANINSTDIR=%{buildroot}/%{_mandir}
mkdir -p %{buildroot}%{_datadir}/pixmaps
mkdir -p %{buildroot}%{_datadir}/applications
install -m 644 %{S:1} %{buildroot}%{_datadir}/pixmaps
cat > %{buildroot}%{_datadir}/applications/puredata.desktop << EOF
[Desktop Entry]
Encoding=UTF-8
Type=Application
Name=PureData
GenericName=Sound Editor
Comment=Synth
Icon=/usr/share/pixmaps/puredata.png
Exec=/usr/bin/pd
Terminal=false
Categories=Application;AudioVideo;Synthesis;
EOF
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files
%defattr(-,root,root)
%{_bindir}/pd
%{_bindir}/pdreceive
%{_bindir}/pdsend
%{_datadir}/pixmaps/puredata.png
%{_datadir}/applications/puredata.desktop
%{_includedir}/m_pd.h
%dir %{_libdir}/pd
%{_libdir}/pd/*
%{_mandir}/man1/pd.1.gz
%{_mandir}/man1/pdreceive.1.gz
%{_mandir}/man1/pdsend.1.gz
%doc README.txt
%changelog
* Thu Aug 01 2013 Automatic Build System <autodist@mambasoft.it> 0.43.4-1mamba
- update to 0.43.4
* Thu Aug 01 2013 Automatic Build System <autodist@mambasoft.it> 0.42.5-2mamba
- automatic rebuild by autodist
* Mon Jul 27 2009 Automatic Build System <autodist@mambasoft.it> 0.42.5-1mamba
- update to 0.42.5
* Mon Jul 27 2009 Automatic Build System <autodist@mambasoft.it> 0.42-1mamba
- automatic update by autodist
* Thu Oct 02 2008 gil <puntogil@libero.it> 0.41-2mamba
- changed configure options, added: enable-jackenable-alsa
* Wed Oct 01 2008 gil <puntogil@libero.it> 0.41-1mamba
- update to 0.41
- added desktop file
* Fri Jan 06 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1-1qilnx
- package created by autospec