243 lines
7.6 KiB
RPMSpec
243 lines
7.6 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f 1-2)
|
|
%define maj3ver %(echo %version | cut -d. -f 1-3)
|
|
%define gitver %(echo %version | cut -d. -f1-2 | tr . _)
|
|
%define medver %(echo %version | cut -d. -f2)
|
|
%define minver %(echo %version | cut -d. -f3)
|
|
|
|
Name: ptlib
|
|
Version: 2.18.8
|
|
Release: 1mamba
|
|
Summary: Portable Tools Libary for opal
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://sourceforge.net/projects/opalvoip
|
|
Source: https://sourceforge.net/projects/opalvoip/files/v3.%{medver}%20Cygni/Stable%20%{minver}/ptlib-%{version}.tar.bz2
|
|
#Source: https+git://git.code.sf.net/p/opalvoip/ptlib/v%{gitver}/ptlib-%{version}.tar.bz2
|
|
#Source: http://ftp.acc.umu.se/pub/GNOME/sources/ptlib/%{majver}/ptlib-%{version}.tar.xz
|
|
Patch3: ptlib-2.18.8-gcc-12.2.0.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libMagick-devel
|
|
BuildRequires: libSDL2-devel
|
|
BuildRequires: libalsa-devel
|
|
BuildRequires: libavcodec-ffmpeg-devel
|
|
BuildRequires: libavformat-ffmpeg-devel
|
|
BuildRequires: libavutil-ffmpeg-devel
|
|
BuildRequires: libesound-devel
|
|
BuildRequires: libexpat-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libjpeg-devel
|
|
BuildRequires: liblua-devel
|
|
BuildRequires: libncurses-devel
|
|
BuildRequires: libodbc-devel
|
|
BuildRequires: libopenldap-devel
|
|
BuildRequires: libopenssl-devel
|
|
BuildRequires: libpcap-devel
|
|
BuildRequires: libpulseaudio-devel
|
|
BuildRequires: libreadline-devel
|
|
BuildRequires: libsasl2-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: libswresample-ffmpeg-devel
|
|
BuildRequires: libswscale-ffmpeg-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libraw1394-devel >= 1.2.0
|
|
|
|
%description
|
|
Portable Tools Libary for opal.
|
|
|
|
%package -n libpt
|
|
Group: System/Libraries
|
|
Summary: Portable Tools Libary for opal
|
|
Provides: ptlib
|
|
Obsoletes: ptlib <= 2.10.11
|
|
Provides: libpw
|
|
Obsoletes: libpw < 2.18.8
|
|
|
|
%description -n libpt
|
|
Portable Tools Libary for opal.
|
|
|
|
%package -n libpt-devel
|
|
Group: Development/Libraries
|
|
Summary: Portable Windows Library development files
|
|
Requires: libpt = %{?epoch:%epoch:}%{version}-%{release}
|
|
Provides: ptlib-devel
|
|
Obsoletes: ptlib-devel <= 2.10.11
|
|
Provides: libpw-devel
|
|
Obsoletes: libpw-devel < 2.18.8
|
|
|
|
%description -n libpt-devel
|
|
Header files and libraries for developing applications that use ptlib.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
%patch3 -p1
|
|
|
|
%build
|
|
export PKG_CONFIG_PATH=%{_libdir}/ffmpeg4/pkgconfig
|
|
|
|
%configure \
|
|
--enable-plugins \
|
|
--enable-alsa \
|
|
--enable-pulse \
|
|
--enable-v4l2 \
|
|
--enable-bsdvideo \
|
|
--enable-dc \
|
|
--enable-exceptions \
|
|
--disable-gstreamer \
|
|
--disable-avc
|
|
|
|
# --enable-exceptions required by ekiga 3.2.0
|
|
|
|
%make opt PLATFORM_TYPE="" PTLIB_BASE=pt DSYMUTIL=/bin/true
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall PLATFORM_TYPE="" PTLIB_BASE=pt DSYMUTIL=/bin/true
|
|
|
|
install -d %{buildroot}%{_bindir}
|
|
|
|
perl -pi -e 's@PTLIBDIR.*=.*@PTLIBDIR = /usr/share/ptlib@' %{buildroot}%{_datadir}/ptlib/make/ptbuildopts.mak
|
|
|
|
install version.h %{buildroot}%{_datadir}/ptlib
|
|
|
|
# fix library permissions
|
|
find %{buildroot}%{_libdir} -name \*.so* -exec chmod 755 {} \;
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -p /sbin/ldconfig
|
|
%postun -p /sbin/ldconfig
|
|
|
|
%files -n libpt
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libpt.so.*
|
|
%dir %{_libdir}/ptlib-%{maj3ver}
|
|
%dir %{_libdir}/ptlib-%{maj3ver}/device
|
|
%dir %{_libdir}/ptlib-%{maj3ver}/device/sound
|
|
%{_libdir}/ptlib-%{maj3ver}/device/sound/alsa_ptplugin.so
|
|
%{_libdir}/ptlib-%{maj3ver}/device/sound/esd_ptplugin.so
|
|
%{_libdir}/ptlib-%{maj3ver}/device/sound/oss_ptplugin.so
|
|
%{_libdir}/ptlib-%{maj3ver}/device/sound/pulse_ptplugin.so
|
|
%dir %{_libdir}/ptlib-%{maj3ver}/device/videoinput
|
|
#%{_libdir}/ptlib-%{maj3ver}/device/videoinput/avc_ptplugin.so
|
|
%{_libdir}/ptlib-%{maj3ver}/device/videoinput/v4l2_ptplugin.so
|
|
|
|
%files -n libpt-devel
|
|
%defattr(-,root,root)
|
|
%{_libdir}/libpt.so
|
|
%{_libdir}/libpt_s.a
|
|
%{_includedir}/ptlib.h
|
|
%{_includedir}/ptlib_config.h
|
|
%{_includedir}/ptlib_wx.h
|
|
%dir %{_includedir}/ptlib
|
|
%{_includedir}/ptlib/*
|
|
%dir %{_includedir}/ptclib
|
|
%{_includedir}/ptclib/*
|
|
%dir %{_datadir}/ptlib
|
|
%{_datadir}/ptlib/*
|
|
%{_libdir}/pkgconfig/ptlib.pc
|
|
|
|
%changelog
|
|
* Tue Dec 13 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.18.8-1mamba
|
|
- update to 2.18.8
|
|
|
|
* Sun Jan 17 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.11-1mamba
|
|
- update to 2.10.11
|
|
|
|
* Thu Feb 21 2013 Automatic Build System <autodist@mambasoft.it> 2.10.10-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Dec 03 2012 Automatic Build System <autodist@mambasoft.it> 2.10.9-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 02 2012 Automatic Build System <autodist@mambasoft.it> 2.10.7-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 03 2011 Automatic Build System <autodist@mambasoft.it> 2.10.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jul 30 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.1-1mamba
|
|
- update to 2.10.1
|
|
|
|
* Tue Jun 01 2010 Automatic Build System <autodist@mambasoft.it> 2.6.7-1mamba
|
|
- update to 2.6.7
|
|
|
|
* Wed Sep 30 2009 Automatic Build System <autodist@mambasoft.it> 2.6.5-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Jul 08 2009 Automatic Build System <autodist@mambasoft.it> 2.6.4-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Jun 04 2009 Automatic Build System <autodist@mambasoft.it> 2.6.2-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sat May 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.1-2mamba
|
|
- added version.h file
|
|
- obsolete libpw
|
|
|
|
* Mon May 11 2009 gil <puntogil@libero.it> 2.6.1-1mamba
|
|
- update to 2.6.1
|
|
|
|
* Fri Nov 21 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Tue Oct 21 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-1mamba
|
|
- update to 2.4.2
|
|
|
|
* Tue Sep 30 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.1-1mamba
|
|
- update to 2.4.1
|
|
- renamed to libpt; providing and obsoleting libpw
|
|
|
|
* Fri Sep 28 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.10-1mamba
|
|
- update to 1.10.10
|
|
|
|
* Mon Sep 17 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.7-1mamba
|
|
- update to 1.10.7
|
|
- gcc42 atomic patch added to fix opal build
|
|
|
|
* Fri Jan 26 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.3-1qilnx
|
|
- update to version 1.10.3 by autospec
|
|
|
|
* Tue Sep 19 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.1-2qilnx
|
|
- enabled v4l2 plugin
|
|
|
|
* Tue Jul 25 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.1-1qilnx
|
|
- update to version 1.10.1 by autospec
|
|
|
|
* Tue Mar 14 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.10.0-1qilnx
|
|
- update to version 1.10.0 by autospec
|
|
|
|
* Thu Sep 15 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.8.7-1qilnx
|
|
- update to version 1.8.7 by autospec
|
|
- do not move 'ptlib-config' to the %{_bindir} directory
|
|
|
|
* Tue Aug 02 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.8.4-2qilnx
|
|
- rebuilt
|
|
|
|
* Mon Jun 13 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.4-1qilnx
|
|
- update to version 1.8.4 by autospec
|
|
|
|
* Wed Sep 15 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.6.3-1qilnx
|
|
- new version build (Janus Patch4 from www.voxgratia.org)
|
|
|
|
* Wed Sep 15 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.5-1qilnx
|
|
- new version build
|
|
|
|
* Fri Mar 05 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.3-1qilnx
|
|
- new version build
|
|
|
|
* Fri Mar 05 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.2-1qilnx
|
|
- new version build
|
|
|
|
* Wed May 14 2003 Silvan Calarco <silvan.calarco@qinet.it> 1.4.11-2qilnx
|
|
- added post ldconfig
|
|
|
|
* Wed May 14 2003 Silvan Calarco <silvan.calarco@qinet.it> 1.4.11-1qilnx
|
|
- first build
|