update to 2.18.8 [release 2.18.8-1mamba;Tue Dec 13 2022]
This commit is contained in:
parent
b0a48e7bd3
commit
b4aff27df8
@ -1,5 +1,4 @@
|
||||
# ptlib
|
||||
|
||||
PWLib is a moderately large class library that has its genesis many years ago as a method to product applications to run on both Microsoft Windows and Unix X-Window systems.
|
||||
It also was to have a Macintosh port as well but this never eventuated.
|
||||
Portable Tools Libary for opal.
|
||||
|
||||
|
@ -1,39 +0,0 @@
|
||||
--- ptlib-2.10.11/./src/ptlib/common/getdate.y 2013-08-15 01:20:26.000000000 +0200
|
||||
+++ /mnt/chroot/cauldron/home/dan/rpm/BUILD/ptlib-2.10.11/src/ptlib/common/getdate.y 2013-12-15 00:24:27.866481490 +0100
|
||||
@@ -121,9 +121,9 @@
|
||||
static int yylex();
|
||||
|
||||
#ifdef __GNUC__
|
||||
-static int yyerror(char const *msg);
|
||||
+static int yyerror(void *, char const *msg);
|
||||
#else
|
||||
-static void yyerror(char const *msg);
|
||||
+static void yyerror(void *, char const *msg);
|
||||
#endif
|
||||
|
||||
|
||||
@@ -132,7 +132,8 @@
|
||||
|
||||
%}
|
||||
|
||||
-%pure_parser
|
||||
+%pure-parser
|
||||
+%parse-param {void *parseParam}
|
||||
|
||||
%union {
|
||||
time_t Number;
|
||||
@@ -1018,12 +1019,12 @@
|
||||
#endif
|
||||
|
||||
#ifdef __GNUC__
|
||||
-int yyerror(const char * s)
|
||||
+int yyerror(void *var, const char * s)
|
||||
{
|
||||
return 0;
|
||||
}
|
||||
#else
|
||||
-static void yyerror(const char * s)
|
||||
+static void yyerror(void *var, const char * s)
|
||||
{
|
||||
}
|
||||
#endif
|
22
ptlib-2.18.8-gcc-12.2.0.patch
Normal file
22
ptlib-2.18.8-gcc-12.2.0.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- ptlib-2.18.8/src/ptlib/common/pchannel.cxx.orig 2022-12-13 13:06:48.361569790 +0100
|
||||
+++ ptlib-2.18.8/src/ptlib/common/pchannel.cxx 2022-12-13 13:07:50.769126154 +0100
|
||||
@@ -149,7 +149,7 @@
|
||||
{
|
||||
PChannelStreamBuffer * buf = dynamic_cast<PChannelStreamBuffer *>(rdbuf());
|
||||
#if P_HAS_SET_RDBUF
|
||||
- set_rdbuf(NULL);
|
||||
+ rdbuf(NULL);
|
||||
#elif !defined(_MSC_VER)
|
||||
init(NULL);
|
||||
#endif
|
||||
--- ptlib-2.18.8/src/ptlib/common/contain.cxx.orig 2022-12-13 13:09:55.608244429 +0100
|
||||
+++ ptlib-2.18.8/src/ptlib/common/contain.cxx 2022-12-13 13:10:11.291208728 +0100
|
||||
@@ -2612,7 +2612,7 @@
|
||||
{
|
||||
PStringStream::Buffer * buf = dynamic_cast<PStringStream::Buffer *>(rdbuf());
|
||||
#if P_HAS_SET_RDBUF
|
||||
- set_rdbuf(NULL);
|
||||
+ rdbuf(NULL);
|
||||
#elif !defined(_MSC_VER)
|
||||
init(NULL);
|
||||
#endif
|
116
ptlib.spec
116
ptlib.spec
@ -1,79 +1,106 @@
|
||||
# NOTE: latest ptlib from opal is in package libpt
|
||||
#%define ekiga_ver 3.0.1
|
||||
%define majver %(echo %version | cut -d. -f 1-2)
|
||||
%define maj3ver %(echo %version | cut -d. -f 1-3)
|
||||
%define gitver %(echo %version | cut -d. -f1-2 | tr . _)
|
||||
%define medver %(echo %version | cut -d. -f2)
|
||||
%define minver %(echo %version | cut -d. -f3)
|
||||
|
||||
Name: ptlib
|
||||
Version: 2.10.11
|
||||
Version: 2.18.8
|
||||
Release: 1mamba
|
||||
Summary: Portable Windows Library
|
||||
Summary: Portable Tools Libary for opal
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.ekiga.org
|
||||
Source: http://ftp.acc.umu.se/pub/GNOME/sources/ptlib/%{majver}/ptlib-%{version}.tar.xz
|
||||
Patch0: ptlib-2.10.11-bison-3.0.4.patch
|
||||
URL: https://sourceforge.net/projects/opalvoip
|
||||
Source: https://sourceforge.net/projects/opalvoip/files/v3.%{medver}%20Cygni/Stable%20%{minver}/ptlib-%{version}.tar.bz2
|
||||
#Source: https+git://git.code.sf.net/p/opalvoip/ptlib/v%{gitver}/ptlib-%{version}.tar.bz2
|
||||
#Source: http://ftp.acc.umu.se/pub/GNOME/sources/ptlib/%{majver}/ptlib-%{version}.tar.xz
|
||||
Patch3: ptlib-2.18.8-gcc-12.2.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libMagick-devel
|
||||
BuildRequires: libSDL2-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libavcodec-ffmpeg-devel
|
||||
BuildRequires: libavformat-ffmpeg-devel
|
||||
BuildRequires: libavutil-ffmpeg-devel
|
||||
BuildRequires: libesound-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblua-devel
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libodbc-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpcap-devel
|
||||
BuildRequires: libpulseaudio-devel
|
||||
BuildRequires: libreadline-devel
|
||||
BuildRequires: libsasl2-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libv4l-devel
|
||||
BuildRequires: libswresample-ffmpeg-devel
|
||||
BuildRequires: libswscale-ffmpeg-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libraw1394-devel >= 1.2.0
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
PWLib is a moderately large class library that has its genesis many years ago as a method to product applications to run on both Microsoft Windows and Unix X-Window systems.
|
||||
It also was to have a Macintosh port as well but this never eventuated.
|
||||
Portable Tools Libary for opal.
|
||||
|
||||
%package devel
|
||||
%package -n libpt
|
||||
Group: System/Libraries
|
||||
Summary: Portable Tools Libary for opal
|
||||
Provides: ptlib
|
||||
Obsoletes: ptlib <= 2.10.11
|
||||
Provides: libpw
|
||||
Obsoletes: libpw < 2.18.8
|
||||
|
||||
%description -n libpt
|
||||
Portable Tools Libary for opal.
|
||||
|
||||
%package -n libpt-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Portable Windows Library development files
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Conflicts: libpt-devel
|
||||
Requires: libpt = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: ptlib-devel
|
||||
Obsoletes: ptlib-devel <= 2.10.11
|
||||
Provides: libpw-devel
|
||||
Obsoletes: libpw-devel < 2.18.8
|
||||
|
||||
%description devel
|
||||
Header files and libraries for developing applications that use pwlib.
|
||||
%description -n libpt-devel
|
||||
Header files and libraries for developing applications that use ptlib.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n ptlib-%{version}
|
||||
%patch0 -p1
|
||||
%setup -q
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
#autoconf
|
||||
export PKG_CONFIG_PATH=%{_libdir}/ffmpeg4/pkgconfig
|
||||
|
||||
%configure \
|
||||
--enable-plugins \
|
||||
--enable-alsa \
|
||||
--enable-oss \
|
||||
--enable-v4l \
|
||||
--enable-pulse \
|
||||
--enable-v4l2 \
|
||||
--enable-bsdvideo \
|
||||
--disable-avc \
|
||||
--enable-dc \
|
||||
--enable-exceptions
|
||||
--enable-exceptions \
|
||||
--disable-gstreamer \
|
||||
--disable-avc
|
||||
|
||||
# --enable-exceptions required by ekiga 3.2.0
|
||||
|
||||
%make optshared PLATFORM_TYPE="" PTLIB_BASE=pt
|
||||
%make opt PLATFORM_TYPE="" PTLIB_BASE=pt DSYMUTIL=/bin/true
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall PLATFORM_TYPE="" PTLIB_BASE=pt
|
||||
%makeinstall PLATFORM_TYPE="" PTLIB_BASE=pt DSYMUTIL=/bin/true
|
||||
|
||||
install -d %{buildroot}%{_bindir}
|
||||
|
||||
# we cannot move 'ptlib-config' to %{_bindir}: it breaks 'unix.mak'
|
||||
ln -sf %{_datadir}/ptlib/make/ptlib-config \
|
||||
%{buildroot}%{_bindir}/ptlib-config
|
||||
|
||||
perl -pi -e 's@PTLIBDIR.*=.*@PTLIBDIR = /usr/share/ptlib@' %{buildroot}%{_datadir}/ptlib/make/ptbuildopts.mak
|
||||
|
||||
install version.h %{buildroot}%{_datadir}/ptlib
|
||||
@ -81,31 +108,33 @@ install version.h %{buildroot}%{_datadir}/ptlib
|
||||
# fix library permissions
|
||||
find %{buildroot}%{_libdir} -name \*.so* -exec chmod 755 {} \;
|
||||
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%files -n libpt
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libpt.so.*
|
||||
%dir %{_libdir}/ptlib-%{version}
|
||||
%dir %{_libdir}/ptlib-%{version}/devices
|
||||
%dir %{_libdir}/ptlib-%{version}/devices/sound
|
||||
%{_libdir}/ptlib-%{version}/devices/sound/*
|
||||
%dir %{_libdir}/ptlib-%{version}/devices/videoinput
|
||||
%{_libdir}/ptlib-%{version}/devices/videoinput/*
|
||||
%doc History.txt ReadMe.txt
|
||||
%dir %{_libdir}/ptlib-%{maj3ver}
|
||||
%dir %{_libdir}/ptlib-%{maj3ver}/device
|
||||
%dir %{_libdir}/ptlib-%{maj3ver}/device/sound
|
||||
%{_libdir}/ptlib-%{maj3ver}/device/sound/alsa_ptplugin.so
|
||||
%{_libdir}/ptlib-%{maj3ver}/device/sound/esd_ptplugin.so
|
||||
%{_libdir}/ptlib-%{maj3ver}/device/sound/oss_ptplugin.so
|
||||
%{_libdir}/ptlib-%{maj3ver}/device/sound/pulse_ptplugin.so
|
||||
%dir %{_libdir}/ptlib-%{maj3ver}/device/videoinput
|
||||
#%{_libdir}/ptlib-%{maj3ver}/device/videoinput/avc_ptplugin.so
|
||||
%{_libdir}/ptlib-%{maj3ver}/device/videoinput/v4l2_ptplugin.so
|
||||
|
||||
%files devel
|
||||
%files -n libpt-devel
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/ptlib-config
|
||||
%{_libdir}/libpt.so
|
||||
%{_libdir}/libpt_s.a
|
||||
%{_includedir}/ptlib.h
|
||||
%{_includedir}/ptbuildopts.h
|
||||
%{_includedir}/ptlib_config.h
|
||||
%{_includedir}/ptlib_wx.h
|
||||
%dir %{_includedir}/ptlib
|
||||
%{_includedir}/ptlib/*
|
||||
%dir %{_includedir}/ptclib
|
||||
@ -115,6 +144,9 @@ find %{buildroot}%{_libdir} -name \*.so* -exec chmod 755 {} \;
|
||||
%{_libdir}/pkgconfig/ptlib.pc
|
||||
|
||||
%changelog
|
||||
* Tue Dec 13 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 2.18.8-1mamba
|
||||
- update to 2.18.8
|
||||
|
||||
* Sun Jan 17 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.11-1mamba
|
||||
- update to 2.10.11
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user