update to 2.10.11 [release 2.10.11-1mamba;Sun Jan 17 2016]
This commit is contained in:
parent
c788d30fc4
commit
b0a48e7bd3
@ -1,2 +1,5 @@
|
|||||||
# ptlib
|
# ptlib
|
||||||
|
|
||||||
|
PWLib is a moderately large class library that has its genesis many years ago as a method to product applications to run on both Microsoft Windows and Unix X-Window systems.
|
||||||
|
It also was to have a Macintosh port as well but this never eventuated.
|
||||||
|
|
||||||
|
39
ptlib-2.10.11-bison-3.0.4.patch
Normal file
39
ptlib-2.10.11-bison-3.0.4.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
--- ptlib-2.10.11/./src/ptlib/common/getdate.y 2013-08-15 01:20:26.000000000 +0200
|
||||||
|
+++ /mnt/chroot/cauldron/home/dan/rpm/BUILD/ptlib-2.10.11/src/ptlib/common/getdate.y 2013-12-15 00:24:27.866481490 +0100
|
||||||
|
@@ -121,9 +121,9 @@
|
||||||
|
static int yylex();
|
||||||
|
|
||||||
|
#ifdef __GNUC__
|
||||||
|
-static int yyerror(char const *msg);
|
||||||
|
+static int yyerror(void *, char const *msg);
|
||||||
|
#else
|
||||||
|
-static void yyerror(char const *msg);
|
||||||
|
+static void yyerror(void *, char const *msg);
|
||||||
|
#endif
|
||||||
|
|
||||||
|
|
||||||
|
@@ -132,7 +132,8 @@
|
||||||
|
|
||||||
|
%}
|
||||||
|
|
||||||
|
-%pure_parser
|
||||||
|
+%pure-parser
|
||||||
|
+%parse-param {void *parseParam}
|
||||||
|
|
||||||
|
%union {
|
||||||
|
time_t Number;
|
||||||
|
@@ -1018,12 +1019,12 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifdef __GNUC__
|
||||||
|
-int yyerror(const char * s)
|
||||||
|
+int yyerror(void *var, const char * s)
|
||||||
|
{
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
#else
|
||||||
|
-static void yyerror(const char * s)
|
||||||
|
+static void yyerror(void *var, const char * s)
|
||||||
|
{
|
||||||
|
}
|
||||||
|
#endif
|
210
ptlib.spec
Normal file
210
ptlib.spec
Normal file
@ -0,0 +1,210 @@
|
|||||||
|
# NOTE: latest ptlib from opal is in package libpt
|
||||||
|
#%define ekiga_ver 3.0.1
|
||||||
|
%define majver %(echo %version | cut -d. -f 1-2)
|
||||||
|
Name: ptlib
|
||||||
|
Version: 2.10.11
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Portable Windows Library
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.ekiga.org
|
||||||
|
Source: http://ftp.acc.umu.se/pub/GNOME/sources/ptlib/%{majver}/ptlib-%{version}.tar.xz
|
||||||
|
Patch0: ptlib-2.10.11-bison-3.0.4.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libSDL-devel
|
||||||
|
BuildRequires: libalsa-devel
|
||||||
|
BuildRequires: libexpat-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libodbc-devel
|
||||||
|
BuildRequires: libopenldap-devel
|
||||||
|
BuildRequires: libopenssl-devel
|
||||||
|
BuildRequires: libpulseaudio-devel
|
||||||
|
BuildRequires: libsasl2-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libv4l-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libraw1394-devel >= 1.2.0
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
PWLib is a moderately large class library that has its genesis many years ago as a method to product applications to run on both Microsoft Windows and Unix X-Window systems.
|
||||||
|
It also was to have a Macintosh port as well but this never eventuated.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Portable Windows Library development files
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Conflicts: libpt-devel
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Header files and libraries for developing applications that use pwlib.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n ptlib-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
#autoconf
|
||||||
|
%configure \
|
||||||
|
--enable-plugins \
|
||||||
|
--enable-alsa \
|
||||||
|
--enable-oss \
|
||||||
|
--enable-v4l \
|
||||||
|
--enable-v4l2 \
|
||||||
|
--enable-bsdvideo \
|
||||||
|
--disable-avc \
|
||||||
|
--enable-dc \
|
||||||
|
--enable-exceptions
|
||||||
|
|
||||||
|
# --enable-exceptions required by ekiga 3.2.0
|
||||||
|
|
||||||
|
%make optshared PLATFORM_TYPE="" PTLIB_BASE=pt
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall PLATFORM_TYPE="" PTLIB_BASE=pt
|
||||||
|
|
||||||
|
install -d %{buildroot}%{_bindir}
|
||||||
|
|
||||||
|
# we cannot move 'ptlib-config' to %{_bindir}: it breaks 'unix.mak'
|
||||||
|
ln -sf %{_datadir}/ptlib/make/ptlib-config \
|
||||||
|
%{buildroot}%{_bindir}/ptlib-config
|
||||||
|
|
||||||
|
perl -pi -e 's@PTLIBDIR.*=.*@PTLIBDIR = /usr/share/ptlib@' %{buildroot}%{_datadir}/ptlib/make/ptbuildopts.mak
|
||||||
|
|
||||||
|
install version.h %{buildroot}%{_datadir}/ptlib
|
||||||
|
|
||||||
|
# fix library permissions
|
||||||
|
find %{buildroot}%{_libdir} -name \*.so* -exec chmod 755 {} \;
|
||||||
|
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libpt.so.*
|
||||||
|
%dir %{_libdir}/ptlib-%{version}
|
||||||
|
%dir %{_libdir}/ptlib-%{version}/devices
|
||||||
|
%dir %{_libdir}/ptlib-%{version}/devices/sound
|
||||||
|
%{_libdir}/ptlib-%{version}/devices/sound/*
|
||||||
|
%dir %{_libdir}/ptlib-%{version}/devices/videoinput
|
||||||
|
%{_libdir}/ptlib-%{version}/devices/videoinput/*
|
||||||
|
%doc History.txt ReadMe.txt
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/ptlib-config
|
||||||
|
%{_libdir}/libpt.so
|
||||||
|
%{_libdir}/libpt_s.a
|
||||||
|
%{_includedir}/ptlib.h
|
||||||
|
%{_includedir}/ptbuildopts.h
|
||||||
|
%dir %{_includedir}/ptlib
|
||||||
|
%{_includedir}/ptlib/*
|
||||||
|
%dir %{_includedir}/ptclib
|
||||||
|
%{_includedir}/ptclib/*
|
||||||
|
%dir %{_datadir}/ptlib
|
||||||
|
%{_datadir}/ptlib/*
|
||||||
|
%{_libdir}/pkgconfig/ptlib.pc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Jan 17 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.11-1mamba
|
||||||
|
- update to 2.10.11
|
||||||
|
|
||||||
|
* Thu Feb 21 2013 Automatic Build System <autodist@mambasoft.it> 2.10.10-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Dec 03 2012 Automatic Build System <autodist@mambasoft.it> 2.10.9-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Sep 02 2012 Automatic Build System <autodist@mambasoft.it> 2.10.7-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Oct 03 2011 Automatic Build System <autodist@mambasoft.it> 2.10.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Jul 30 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.1-1mamba
|
||||||
|
- update to 2.10.1
|
||||||
|
|
||||||
|
* Tue Jun 01 2010 Automatic Build System <autodist@mambasoft.it> 2.6.7-1mamba
|
||||||
|
- update to 2.6.7
|
||||||
|
|
||||||
|
* Wed Sep 30 2009 Automatic Build System <autodist@mambasoft.it> 2.6.5-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Jul 08 2009 Automatic Build System <autodist@mambasoft.it> 2.6.4-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu Jun 04 2009 Automatic Build System <autodist@mambasoft.it> 2.6.2-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat May 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.1-2mamba
|
||||||
|
- added version.h file
|
||||||
|
- obsolete libpw
|
||||||
|
|
||||||
|
* Mon May 11 2009 gil <puntogil@libero.it> 2.6.1-1mamba
|
||||||
|
- update to 2.6.1
|
||||||
|
|
||||||
|
* Fri Nov 21 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Tue Oct 21 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-1mamba
|
||||||
|
- update to 2.4.2
|
||||||
|
|
||||||
|
* Tue Sep 30 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.1-1mamba
|
||||||
|
- update to 2.4.1
|
||||||
|
- renamed to libpt; providing and obsoleting libpw
|
||||||
|
|
||||||
|
* Fri Sep 28 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.10-1mamba
|
||||||
|
- update to 1.10.10
|
||||||
|
|
||||||
|
* Mon Sep 17 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.7-1mamba
|
||||||
|
- update to 1.10.7
|
||||||
|
- gcc42 atomic patch added to fix opal build
|
||||||
|
|
||||||
|
* Fri Jan 26 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.3-1qilnx
|
||||||
|
- update to version 1.10.3 by autospec
|
||||||
|
|
||||||
|
* Tue Sep 19 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.1-2qilnx
|
||||||
|
- enabled v4l2 plugin
|
||||||
|
|
||||||
|
* Tue Jul 25 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.10.1-1qilnx
|
||||||
|
- update to version 1.10.1 by autospec
|
||||||
|
|
||||||
|
* Tue Mar 14 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.10.0-1qilnx
|
||||||
|
- update to version 1.10.0 by autospec
|
||||||
|
|
||||||
|
* Thu Sep 15 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.8.7-1qilnx
|
||||||
|
- update to version 1.8.7 by autospec
|
||||||
|
- do not move 'ptlib-config' to the %{_bindir} directory
|
||||||
|
|
||||||
|
* Tue Aug 02 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.8.4-2qilnx
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
|
* Mon Jun 13 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.8.4-1qilnx
|
||||||
|
- update to version 1.8.4 by autospec
|
||||||
|
|
||||||
|
* Wed Sep 15 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.6.3-1qilnx
|
||||||
|
- new version build (Janus Patch4 from www.voxgratia.org)
|
||||||
|
|
||||||
|
* Wed Sep 15 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.5-1qilnx
|
||||||
|
- new version build
|
||||||
|
|
||||||
|
* Fri Mar 05 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.3-1qilnx
|
||||||
|
- new version build
|
||||||
|
|
||||||
|
* Fri Mar 05 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.2-1qilnx
|
||||||
|
- new version build
|
||||||
|
|
||||||
|
* Wed May 14 2003 Silvan Calarco <silvan.calarco@qinet.it> 1.4.11-2qilnx
|
||||||
|
- added post ldconfig
|
||||||
|
|
||||||
|
* Wed May 14 2003 Silvan Calarco <silvan.calarco@qinet.it> 1.4.11-1qilnx
|
||||||
|
- first build
|
Loading…
Reference in New Issue
Block a user