rebuilt with ImageMagick 6.8.8.7 [release 3.62-3mamba;Mon Mar 03 2014]

This commit is contained in:
Automatic Build System 2024-01-06 10:34:20 +01:00
parent 4a5eea986a
commit 4776ed4afb
6 changed files with 301 additions and 0 deletions

View File

@ -1,2 +1,32 @@
# pstoedit
PStoEdit translates PostScript and PDF graphics into other vector formats.
Implementing support for other formats should be very easy.
The architecture of pstoedit consists of a PostScript frontend which needs to call a PostScript interpreter like Ghostscript and the individual backends which are pugged into a kind of framework.
This framework can be used independently from the PostScript frontend from any other program.
The framework provides a uniform interface to all different backends.
Currently pstoedit can generate the following formats:
- Tgif .obj format (for tgif version >= 3)
- fig format for xfig
- pdf Adobe Portable Document Format
- gnuplot format
- Flattened PostScript (with or without Bezier curves)
- DXF - CAD exchange format
- LWO - LightWave 3D
- RIB - RenderMan
- RPL - Real3D
- Idraw format (a special format of EPS that Idraw can read)
- Tcl/Tk
- HPGL
- AI - Adobe Illustrator Format (based on ps2ai.ps, not a real pstoedit)
- WMF - Windows Meta Files
- PIC format for troff/groff
- MetaPost format per usage with TeX/LaTeX
- LaTeX2e picture
- Kontour
- GNU Metafile (plotutils/libplot)
- Sketch (http://sketch.sourceforge.net)
- Mathematica
- trough ImageMagick to any format supported by ImageMagick

View File

@ -0,0 +1,21 @@
diff -Nru pstoedit-3.45.orig/src/drvswf.cpp pstoedit-3.45/src/drvswf.cpp
--- pstoedit-3.45.orig/src/drvswf.cpp 2007-07-22 13:27:36.000000000 +0200
+++ pstoedit-3.45/src/drvswf.cpp 2008-11-19 19:01:23.000000000 +0100
@@ -373,7 +373,7 @@
printf("s->end();\n" "SWFDisplayItem * d = movie->add(s);\n" "d->move(0, 0); }\n");
// delete s;
- delete d;
+// delete d;
}
@@ -474,7 +474,7 @@
SWFDisplayItem_setMatrix(d->item, ma, mb, mc, md, mx, my);
#endif
- delete d;
+// delete d;
// delete f; // causes memory problems otherwise - at the cost of leaks - Hmmm
// delete t;

12
pstoedit-3.45-gcc43.patch Normal file
View File

@ -0,0 +1,12 @@
--- pstoedit-3.45/src/cppcomp.h~ 2007-07-22 13:27:40.000000000 +0200
+++ pstoedit-3.45/src/cppcomp.h 2008-02-17 11:53:46.000000000 +0100
@@ -37,6 +37,9 @@
#define _unix
#endif
+#include <cstring>
+#include <cstdlib>
+
#if defined (_MSC_VER) && (_MSC_VER >= 1100)
// MSVC 5 and 6 have ANSI C++ header files, but the compilation
// is much slower and object files get bigger.

12
pstoedit-3.45-gcc44.patch Normal file
View File

@ -0,0 +1,12 @@
diff -Nru pstoedit-3.45.orig/src/dynload.cpp pstoedit-3.45/src/dynload.cpp
--- pstoedit-3.45.orig/src/dynload.cpp 2007-07-22 13:27:36.000000000 +0200
+++ pstoedit-3.45/src/dynload.cpp 2009-06-01 03:37:27.000000000 +0200
@@ -138,7 +138,7 @@
dlclose(handle);
#elif defined(_WIN32)
(void) WINFREELIB((HINSTANCE) handle);
-#elif
+#else
#error "system unsupported so far"
#endif
handle = 0;

View File

@ -0,0 +1,24 @@
diff -Nru pstoedit-3.45.orig/configure pstoedit-3.45/configure
--- pstoedit-3.45.orig/configure 2007-08-10 22:26:10.000000000 +0200
+++ pstoedit-3.45/configure 2008-06-17 10:15:20.000000000 +0200
@@ -22282,7 +22282,7 @@
else
{ echo "$as_me:$LINENO: result: GNU" >&5
echo "${ECHO_T}GNU" >&6; }
- SPECIAL_CXXFLAGS="-DBUGGYGPP -pedantic -Wall -Wwrite-strings -Wcast-qual -Wpointer-arith "
+ SPECIAL_CXXFLAGS="-DBUGGYGPP -Wall -Wwrite-strings -Wcast-qual -Wpointer-arith "
fi
CXXFLAGS="-g"
elif test `echo "$CXX" | egrep -c 'xlC$'` -eq 1; then
diff -Nru pstoedit-3.45.orig/configure.ac pstoedit-3.45/configure.ac
--- pstoedit-3.45.orig/configure.ac 2007-08-10 22:23:26.000000000 +0200
+++ pstoedit-3.45/configure.ac 2008-06-17 10:15:28.000000000 +0200
@@ -394,7 +394,7 @@
AC_SUBST(LDLIBS)
else
AC_MSG_RESULT([GNU])
- SPECIAL_CXXFLAGS="-DBUGGYGPP -pedantic -Wall -Wwrite-strings -Wcast-qual -Wpointer-arith "
+ SPECIAL_CXXFLAGS="-DBUGGYGPP -Wall -Wwrite-strings -Wcast-qual -Wpointer-arith "
fi
CXXFLAGS="-g"
elif test `echo "$CXX" | egrep -c 'xlC$'` -eq 1; then

202
pstoedit.spec Normal file
View File

@ -0,0 +1,202 @@
%define libname lib%{name}
Name: pstoedit
Version: 3.62
Release: 3mamba
Summary: Translates PostScript and PDF graphics into other vector formats
Group: Applications/Graphics
Vendor: openmamba
Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@qilinux.it>
URL: http://www.pstoedit.net/pstoedit
Source: http://downloads.sourceforge.net/sourceforge/pstoedit/pstoedit-%{version}.tar.gz
Patch0: %{name}-3.45-gcc4_no_pedantic.patch
Patch1: %{name}-3.45-gcc43.patch
Patch2: %{name}-3.45-drvswf.patch
Patch3: %{name}-3.45-gcc44.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: ghostscript-devel
BuildRequires: glibc-devel
BuildRequires: ImageMagick-devel
BuildRequires: libEMF-devel
BuildRequires: libexpat-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgcc
BuildRequires: libgd-devel
BuildRequires: libjpeg-devel
BuildRequires: libming-devel
BuildRequires: libplot-devel
BuildRequires: libpng-devel
BuildRequires: libstdc++6-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libXdmcp-devel
BuildRequires: libXpm-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: libbzip2-devel
BuildRequires: liblcms-devel
BuildRequires: libtiff-devel
Requires: %{libname} >= %{?epoch:%epoch:}%{version}-%{release}
Requires: ghostscript >= 7.07.1
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
PStoEdit translates PostScript and PDF graphics into other vector formats.
Implementing support for other formats should be very easy.
The architecture of pstoedit consists of a PostScript frontend which needs to call a PostScript interpreter like Ghostscript and the individual backends which are pugged into a kind of framework.
This framework can be used independently from the PostScript frontend from any other program.
The framework provides a uniform interface to all different backends.
Currently pstoedit can generate the following formats:
- Tgif .obj format (for tgif version >= 3)
- fig format for xfig
- pdf Adobe Portable Document Format
- gnuplot format
- Flattened PostScript (with or without Bezier curves)
- DXF - CAD exchange format
- LWO - LightWave 3D
- RIB - RenderMan
- RPL - Real3D
- Idraw format (a special format of EPS that Idraw can read)
- Tcl/Tk
- HPGL
- AI - Adobe Illustrator Format (based on ps2ai.ps, not a real pstoedit)
- WMF - Windows Meta Files
- PIC format for troff/groff
- MetaPost format per usage with TeX/LaTeX
- LaTeX2e picture
- Kontour
- GNU Metafile (plotutils/libplot)
- Sketch (http://sketch.sourceforge.net)
- Mathematica
- trough ImageMagick to any format supported by ImageMagick
%package -n %{libname}
Summary: Libraries for application which use %{name}
Group: System/Multimedia
%description -n %{libname}
PStoEdit translates PostScript and PDF graphics into other vector formats.
%package -n %{libname}-devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
%description -n %{libname}-devel
PStoEdit translates PostScript and PDF graphics into other vector formats.
This package contains static libraries and header files need for development.
%prep
%setup -q
#%patch0 -p1
%patch1 -p1
#%patch2 -p1
#%patch3 -p1
%build
%configure \
--with-libemf-include=%{_includedir}/libEMF
%make -j1
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall
install -D doc/%{name}.1 \
%{buildroot}%{_mandir}/man1/%{name}.1
for f in %{buildroot}%{_libdir}/*.la %{buildroot}%{_libdir}/%{name}/*.la; do
sed -i "s:%{buildroot}::g" $f
done
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%post -n %{libname} -p /sbin/ldconfig
%postun -n %{libname} -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/%{name}
%{_datadir}/%{name}/*
%{_mandir}/man1/%{name}.*
%doc copying
%files -n %{libname}
%defattr(-,root,root)
%{_libdir}/*.so.*
%{_libdir}/%{name}/*.so.*
%files -n %{libname}-devel
%defattr(-,root,root)
#%{_bindir}/%{name}-config
%{_includedir}/%{name}/*.h
%{_libdir}/*.la
%{_libdir}/*.so
%{_libdir}/%{name}/*.la
%{_libdir}/%{name}/*.so
%{_libdir}/pkgconfig/*.pc
%{_datadir}/aclocal/%{name}.m4
%doc examples/*.ps
%changelog
* Mon Mar 03 2014 Automatic Build System <autodist@mambasoft.it> 3.62-3mamba
- rebuilt with ImageMagick 6.8.8.7
* Tue Aug 27 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 3.62-2mamba
- libpng 1.6 mass rebuild
* Tue Apr 30 2013 Automatic Build System <autodist@mambasoft.it> 3.62-1mamba
- automatic version update by autodist
* Fri Nov 09 2012 Automatic Build System <autodist@mambasoft.it> 3.61-1mamba
- automatic version update by autodist
* Sun Aug 28 2011 Automatic Build System <autodist@mambasoft.it> 3.60-1mamba
- automatic version update by autodist
* Fri Jan 22 2010 Automatic Build System <autodist@mambasoft.it> 3.50-6mamba
- automatic rebuild by autodist
* Thu Jan 21 2010 Automatic Build System <autodist@mambasoft.it> 3.50-5mamba
- automatic rebuild by autodist
* Thu Jan 21 2010 Automatic Build System <autodist@mambasoft.it> 3.50-4mamba
- automatic rebuild by autodist
* Thu Jan 21 2010 Automatic Build System <autodist@mambasoft.it> 3.50-3mamba
- automatic rebuild by autodist
* Thu Jan 21 2010 Automatic Build System <autodist@mambasoft.it> 3.50-2mamba
- automatic rebuild by autodist
* Wed Jan 20 2010 Automatic Build System <autodist@mambasoft.it> 3.50-1mamba
- update to 3.50
* Mon Jun 01 2009 Automatic Build System <autodist@mambasoft.it> 3.45-4mamba
- automatic rebuild by autodist
* Wed Feb 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 3.45-3mamba
- automatic rebuild by autodist
* Wed Nov 19 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.45-2mamba
- automatic rebuild by autodist
* Tue Jun 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.45-1mamba
- update to 3.45
* Tue Oct 31 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 3.44-1qilnx
- update to version 3.44 by autospec
* Mon Jan 02 2006 Davide Madrisan <davide.madrisan@qilinux.it> 3.42-1qilnx
- update to version 3.42 by autospec
* Thu Jul 28 2005 Davide Madrisan <davide.madrisan@qilinux.it> 3.40-1qilnx
- package created by autospec