legacy package [release 26.1-2mamba;Mon Sep 16 2024]

This commit is contained in:
Silvan Calarco 2024-09-18 10:38:32 +02:00
parent 880c6da3f6
commit 2492be80be
3 changed files with 180 additions and 40 deletions

View File

@ -0,0 +1,25 @@
From 2e62ef1eaa2e712afc5f87aa2c55d478fe96230d Mon Sep 17 00:00:00 2001
From: Antonio Rojas <arojas@archlinux.org>
Date: Wed, 5 Jul 2023 13:03:11 +0200
Subject: [PATCH] Handle BUILD_TYPE=None in protobuf-module.cmake
Fixes Protobuf_PROTOC_EXECUTABLE being undefined in that case.
---
cmake/protobuf-module.cmake.in | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/cmake/protobuf-module.cmake.in b/cmake/protobuf-module.cmake.in
index 0bb05e38fad..e5b2b2e4b3a 100644
--- a/cmake/protobuf-module.cmake.in
+++ b/cmake/protobuf-module.cmake.in
@@ -153,6 +153,10 @@ if(NOT Protobuf_PROTOC_EXECUTABLE AND TARGET protobuf::protoc)
get_target_property(Protobuf_PROTOC_EXECUTABLE protobuf::protoc
IMPORTED_LOCATION_NOCONFIG)
endif()
+ if(NOT EXISTS "${Protobuf_PROTOC_EXECUTABLE}")
+ get_target_property(Protobuf_PROTOC_EXECUTABLE protobuf::protoc
+ IMPORTED_LOCATION_NONE)
+ endif()
endif()
# Version info variable

View File

@ -0,0 +1,36 @@
diff --git a/cmake/libprotobuf-lite.cmake b/cmake/libprotobuf-lite.cmake
index 9b1de677b4f..276c99c489e 100644
--- a/cmake/libprotobuf-lite.cmake
+++ b/cmake/libprotobuf-lite.cmake
@@ -30,6 +30,7 @@ if(protobuf_BUILD_SHARED_LIBS)
endif()
set_target_properties(libprotobuf-lite PROPERTIES
VERSION ${protobuf_VERSION}
+ SOVERSION ${protobuf_VERSION_MINOR}
OUTPUT_NAME ${LIB_PREFIX}protobuf-lite
DEBUG_POSTFIX "${protobuf_DEBUG_POSTFIX}")
add_library(protobuf::libprotobuf-lite ALIAS libprotobuf-lite)
diff --git a/cmake/libprotobuf.cmake b/cmake/libprotobuf.cmake
index aa3efc9a68a..0f34d20b97d 100644
--- a/cmake/libprotobuf.cmake
+++ b/cmake/libprotobuf.cmake
@@ -33,6 +33,7 @@ if(protobuf_BUILD_SHARED_LIBS)
endif()
set_target_properties(libprotobuf PROPERTIES
VERSION ${protobuf_VERSION}
+ SOVERSION ${protobuf_VERSION_MINOR}
OUTPUT_NAME ${LIB_PREFIX}protobuf
DEBUG_POSTFIX "${protobuf_DEBUG_POSTFIX}")
add_library(protobuf::libprotobuf ALIAS libprotobuf)
diff --git a/cmake/libprotoc.cmake b/cmake/libprotoc.cmake
index 72b4a1abb92..91e8bbeb04e 100644
--- a/cmake/libprotoc.cmake
+++ b/cmake/libprotoc.cmake
@@ -24,6 +24,7 @@ endif()
set_target_properties(libprotoc PROPERTIES
COMPILE_DEFINITIONS LIBPROTOC_EXPORTS
VERSION ${protobuf_VERSION}
+ SOVERSION ${protobuf_VERSION_MINOR}
OUTPUT_NAME ${LIB_PREFIX}protoc
DEBUG_POSTFIX "${protobuf_DEBUG_POSTFIX}")
add_library(protobuf::libprotoc ALIAS libprotoc)

View File

@ -1,16 +1,19 @@
Name: protobuf26
Version: 3.15.8
Version: 26.1
Release: 2mamba
Summary: A way of encoding structured data in an efficient yet extensible format
Group: Development/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://code.google.com/p/protobuf/
Source: https://github.com/google/protobuf.git/v%{version}/protobuf-%{version}.tar.bz2
URL: https://protobuf.dev/
Source: https://github.com/protocolbuffers/protobuf.git/v%{version}/protobuf-%{version}.tar.bz2
Patch1: protobuf-24.3-upstream-fix-Protobuf_PROTOC_EXECUTABLE.patch
Patch2: protobuf-25.3-soversion.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libabseil-cpp-devel
BuildRequires: libgcc
BuildRequires: libstdc++6-devel
BuildRequires: libz-devel
@ -32,48 +35,33 @@ This package contains shared libraries for %{name}.
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n lib%{name}-devel
This package contains static libraries and header files needed for development of Protocol Buffer
%package -n python-%{name}
Summary: Python bindings for %{name}
Group: System/Libraries/Python
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n python-%{name}
This package contains the python bindings to %{protobuf} library.
%debug_package
%prep
%setup -q -n protobuf-%{version}
./autogen.sh
#-D -T
#:<< _EOF
%define _default_patch_fuzz 2
%patch 1 -p1 -b .upstream-fix-Protobuf_PROTOC_EXECUTABLE
%patch 2 -p1 -b .soversion
%build
%configure
%cmake \
-Dprotobuf_BUILD_SHARED_LIBS=ON \
-Dprotobuf_USE_EXTERNAL_GTEST=ON \
-Dprotobuf_ABSL_PROVIDER=package
%make \
%ifarch arm
LDFLAGS="-latomic"
%endif
cd python
CFLAGS="%{optflags}" %{__python3} setup.py build
%cmake_build
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
cd python
%{__python3} setup.py install \
-O1 --skip-build \
--root="%{buildroot}" \
--install-headers=%{python3_inc} \
--install-lib=%{python3_sitearch} \
--record=%{name}.filelist
sed -i "s,.*/man/.*,&.gz," %{name}.filelist
%cmake_install
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@ -83,7 +71,7 @@ sed -i "s,.*/man/.*,&.gz," %{name}.filelist
%files
%defattr(-,root,root)
%{_bindir}/protoc
%{_bindir}/protoc*
%files -n lib%{name}
%defattr(-,root,root)
@ -95,21 +83,112 @@ sed -i "s,.*/man/.*,&.gz," %{name}.filelist
%defattr(-,root,root)
%dir %{_includedir}/google/protobuf
%{_includedir}/google/protobuf/*
%{_libdir}/libprotobuf*.a
%{_libdir}/libprotobuf*.la
%{_includedir}/java/core/src/main/resources/google/protobuf/java_features.proto
%{_includedir}/upb_generator/mangle.h
%{_includedir}/utf8_range.h
%{_includedir}/utf8_validity.h
%{_libdir}/libprotobuf*.so
%{_libdir}/libprotoc.a
%{_libdir}/libprotoc.la
%{_libdir}/libprotoc.so
%{_libdir}/libutf8_range.a
%{_libdir}/libutf8_validity.a
%dir %{_libdir}/cmake/protobuf
%{_libdir}/cmake/protobuf/protobuf-*.cmake
%dir %{_libdir}/cmake/utf8_range
%{_libdir}/cmake/utf8_range/utf8_range-*.cmake
%{_libdir}/pkgconfig/protobuf*.pc
%files -n python-%{name} -f python/%{name}.filelist
%defattr(-,root,root)
%{_libdir}/pkgconfig/utf8_range.pc
%changelog
* Wed May 12 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.15.8-2mamba
* Mon Sep 16 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 26.1-2mamba
- legacy package
* Fri Apr 05 2024 Automatic Build System <autodist@openmamba.org> 26.1-1mamba
- automatic version update by autodist
* Mon Feb 19 2024 Automatic Build System <autodist@openmamba.org> 25.3-1mamba
- automatic version update by autodist
* Tue Jul 04 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 21.12-2mamba
- added python 3.10 subpackage
* Sat Dec 17 2022 Automatic Build System <autodist@mambasoft.it> 21.12-1mamba
- automatic version update by autodist
* Fri Dec 09 2022 Automatic Build System <autodist@mambasoft.it> 21.11-1mamba
- automatic version update by autodist
* Thu Dec 01 2022 Automatic Build System <autodist@mambasoft.it> 21.10-1mamba
- automatic version update by autodist
* Thu Oct 27 2022 Automatic Build System <autodist@mambasoft.it> 21.9-1mamba
- automatic version update by autodist
* Thu Oct 20 2022 Automatic Build System <autodist@mambasoft.it> 21.8-1mamba
- automatic version update by autodist
* Fri Sep 30 2022 Automatic Build System <autodist@mambasoft.it> 21.7-1mamba
- automatic version update by autodist
* Sat Sep 17 2022 Automatic Build System <autodist@mambasoft.it> 21.6-1mamba
- automatic version update by autodist
* Wed Aug 10 2022 Automatic Build System <autodist@mambasoft.it> 21.5-1mamba
- automatic version update by autodist
* Tue Jul 26 2022 Automatic Build System <autodist@mambasoft.it> 21.4-1mamba
- automatic version update by autodist
* Thu Jul 21 2022 Automatic Build System <autodist@mambasoft.it> 21.3-1mamba
- automatic version update by autodist
* Tue Jun 28 2022 Automatic Build System <autodist@mambasoft.it> 21.2-1mamba
- automatic version update by autodist
* Sun May 29 2022 Automatic Build System <autodist@mambasoft.it> 21.1-1mamba
- automatic version update by autodist
* Sat Apr 23 2022 Automatic Build System <autodist@mambasoft.it> 3.20.1-1mamba
- automatic version update by autodist
* Sat Jan 29 2022 Automatic Build System <autodist@mambasoft.it> 3.19.4-1mamba
- automatic version update by autodist
* Thu Jan 13 2022 Automatic Build System <autodist@mambasoft.it> 3.19.3-1mamba
- automatic version update by autodist
* Thu Jan 06 2022 Automatic Build System <autodist@mambasoft.it> 3.19.2-1mamba
- automatic version update by autodist
* Fri Oct 29 2021 Automatic Build System <autodist@mambasoft.it> 3.19.1-1mamba
- automatic version update by autodist
* Thu Oct 21 2021 Automatic Build System <autodist@mambasoft.it> 3.19.0-1mamba
- automatic version update by autodist
* Sat Oct 09 2021 Automatic Build System <autodist@mambasoft.it> 3.18.1-1mamba
- automatic version update by autodist
* Thu Sep 16 2021 Automatic Build System <autodist@mambasoft.it> 3.18.0-1mamba
- automatic version update by autodist
* Wed Jun 09 2021 Automatic Build System <autodist@mambasoft.it> 3.17.3-1mamba
- automatic version update by autodist
* Thu Jun 03 2021 Automatic Build System <autodist@mambasoft.it> 3.17.2-1mamba
- automatic version update by autodist
* Tue May 25 2021 Automatic Build System <autodist@mambasoft.it> 3.17.1-1mamba
- automatic version update by autodist
* Sat May 15 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.17.0-2mamba
- libprotobuf-devel: require protobuf; python-protobuf: use distdeps; fixed url
* Fri May 14 2021 Automatic Build System <autodist@mambasoft.it> 3.17.0-1mamba
- automatic version update by autodist
* Sun May 09 2021 Automatic Build System <autodist@mambasoft.it> 3.16.0-1mamba
- automatic version update by autodist
* Fri Apr 09 2021 Automatic Build System <autodist@mambasoft.it> 3.15.8-1mamba
- automatic version update by autodist