obsolete legacy packages [release 28.1-2mamba;Mon Sep 16 2024]
This commit is contained in:
parent
915e20ecec
commit
06a45f9d00
@ -1,16 +0,0 @@
|
||||
diff -ruN a/python/setup.py b/python/setup.py
|
||||
--- a/python/setup.py 2022-12-13 01:03:12.000000000 +0100
|
||||
+++ b/python/setup.py 2023-04-06 22:12:36.199029178 +0200
|
||||
@@ -220,10 +220,10 @@
|
||||
return False
|
||||
|
||||
|
||||
-if __name__ == '__main__':
|
||||
+if True:
|
||||
ext_module_list = []
|
||||
warnings_as_errors = '--warnings_as_errors'
|
||||
- if GetOptionFromArgv('--cpp_implementation'):
|
||||
+ if True:
|
||||
# Link libprotobuf.a and libprotobuf-lite.a statically with the
|
||||
# extension. Note that those libraries have to be compiled with
|
||||
# -fPIC for this to work.
|
@ -1,6 +1,6 @@
|
||||
Name: protobuf
|
||||
Version: 26.1
|
||||
Release: 1mamba
|
||||
Version: 28.1
|
||||
Release: 2mamba
|
||||
Summary: A way of encoding structured data in an efficient yet extensible format
|
||||
Group: Development/Tools
|
||||
Vendor: openmamba
|
||||
@ -8,7 +8,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://protobuf.dev/
|
||||
Source: https://github.com/protocolbuffers/protobuf.git/v%{version}/protobuf-%{version}.tar.bz2
|
||||
Patch0: protobuf-24.3-pep517.patch
|
||||
Patch1: protobuf-24.3-upstream-fix-Protobuf_PROTOC_EXECUTABLE.patch
|
||||
Patch2: protobuf-25.3-soversion.patch
|
||||
License: BSD
|
||||
@ -20,7 +19,9 @@ BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Obsoletes: protobuf26 <= 3.15.8-2mamba
|
||||
Obsoletes: protobuf23 <= 3.12.4-3mamba
|
||||
Obsoletes: protobuf29 <= 3.17.3-2mamba
|
||||
Obsoletes: protobuf32 <= 21.12-3mamba
|
||||
|
||||
%description
|
||||
Protocol Buffers are a way of encoding structured data in an efficient yet extensible format. Google uses Protocol Buffers for almost all of its internal RPC protocols and file formats.
|
||||
@ -28,7 +29,9 @@ Protocol Buffers are a way of encoding structured data in an efficient yet exten
|
||||
%package -n lib%{name}
|
||||
Group: System/Libraries
|
||||
Summary: Shared libraries for %{name}
|
||||
Obsoletes: libprotobuf26 <= 3.15.8-2mamba
|
||||
Obsoletes: libprotobuf23 <= 3.12.4-3mamba
|
||||
Obsoletes: libprotobuf29 <= 3.17.3-2mamba
|
||||
Obsoletes: libprotobuf32 <= 21.12-3mamba
|
||||
|
||||
%description -n lib%{name}
|
||||
Protocol Buffers are a way of encoding structured data in an efficient yet extensible format. Google uses Protocol Buffers for almost all of its internal RPC protocols and file formats.
|
||||
@ -41,7 +44,9 @@ Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: protobuf-devel
|
||||
Obsoletes: protobuf-devel < 3.17.0
|
||||
Obsoletes: libprotobuf26-devel <= 3.15.8-2mamba
|
||||
Obsoletes: libprotobuf23-devel <= 3.12.4-3mamba
|
||||
Obsoletes: libprotobuf29-devel <= 3.17.3-2mamba
|
||||
Obsoletes: libprotobuf32-devel <= 21.12-3mamba
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
This package contains static libraries and header files needed for development of Protocol Buffer
|
||||
@ -53,10 +58,8 @@ This package contains static libraries and header files needed for development o
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
|
||||
%define _default_patch_fuzz 2
|
||||
#%patch 0 -p1 -b .pep517
|
||||
%patch 1 -p1 -b .upstream-fix-Protobuf_PROTOC_EXECUTABLE
|
||||
%patch 2 -p1 -b .soversion
|
||||
%patch 1 -p1 -F2 -b .upstream-fix-Protobuf_PROTOC_EXECUTABLE
|
||||
%patch 2 -p1 -F2 -b .soversion
|
||||
|
||||
%build
|
||||
%cmake \
|
||||
@ -73,8 +76,6 @@ This package contains static libraries and header files needed for development o
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
@ -92,12 +93,15 @@ This package contains static libraries and header files needed for development o
|
||||
%{_includedir}/google/protobuf/*
|
||||
%{_includedir}/java/core/src/main/resources/google/protobuf/java_features.proto
|
||||
%{_includedir}/upb_generator/mangle.h
|
||||
%dir %{_includedir}/upb
|
||||
%{_includedir}/upb/*
|
||||
%{_includedir}/utf8_range.h
|
||||
%{_includedir}/utf8_validity.h
|
||||
%{_libdir}/libupb.a
|
||||
%{_libdir}/libprotobuf*.so
|
||||
%{_libdir}/libprotoc.so
|
||||
%{_libdir}/libutf8_range.a
|
||||
%{_libdir}/libutf8_validity.a
|
||||
%{_libdir}/libutf8_range.so
|
||||
%{_libdir}/libutf8_validity.so
|
||||
%dir %{_libdir}/cmake/protobuf
|
||||
%{_libdir}/cmake/protobuf/protobuf-*.cmake
|
||||
%dir %{_libdir}/cmake/utf8_range
|
||||
@ -106,6 +110,30 @@ This package contains static libraries and header files needed for development o
|
||||
%{_libdir}/pkgconfig/utf8_range.pc
|
||||
|
||||
%changelog
|
||||
* Mon Sep 16 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 28.1-2mamba
|
||||
- obsolete legacy packages
|
||||
|
||||
* Thu Sep 12 2024 Automatic Build System <autodist@openmamba.org> 28.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Sep 01 2024 Automatic Build System <autodist@openmamba.org> 28.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Aug 28 2024 Automatic Build System <autodist@openmamba.org> 27.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Aug 01 2024 Automatic Build System <autodist@openmamba.org> 27.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jun 26 2024 Automatic Build System <autodist@openmamba.org> 27.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jun 06 2024 Automatic Build System <autodist@openmamba.org> 27.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun May 26 2024 Automatic Build System <autodist@openmamba.org> 27.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Apr 05 2024 Automatic Build System <autodist@openmamba.org> 26.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user