automatic version update by autodist [release 4.8.0-1mamba;Wed Nov 14 2012]
This commit is contained in:
parent
30d08230c9
commit
c5e48ee92b
139
proj-4.8.0-add-missing-header.patch
Normal file
139
proj-4.8.0-add-missing-header.patch
Normal file
@ -0,0 +1,139 @@
|
||||
diff -Nru proj-4.8.0.orig/src/org_proj4_PJ.h proj-4.8.0/src/org_proj4_PJ.h
|
||||
--- proj-4.8.0.orig/src/org_proj4_PJ.h 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ proj-4.8.0/src/org_proj4_PJ.h 2012-11-13 12:31:56.152399854 +0100
|
||||
@@ -0,0 +1,135 @@
|
||||
+/* DO NOT EDIT THIS FILE - it is machine generated */
|
||||
+#include <jni.h>
|
||||
+/* Header for class org_proj4_PJ */
|
||||
+
|
||||
+#ifndef _Included_org_proj4_PJ
|
||||
+#define _Included_org_proj4_PJ
|
||||
+#ifdef __cplusplus
|
||||
+extern "C" {
|
||||
+#endif
|
||||
+#undef org_proj4_PJ_DIMENSION_MAX
|
||||
+#define org_proj4_PJ_DIMENSION_MAX 100L
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: allocatePJ
|
||||
+ * Signature: (Ljava/lang/String;)J
|
||||
+ */
|
||||
+JNIEXPORT jlong JNICALL Java_org_proj4_PJ_allocatePJ
|
||||
+ (JNIEnv *, jclass, jstring);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: allocateGeoPJ
|
||||
+ * Signature: (Lorg/proj4/PJ;)J
|
||||
+ */
|
||||
+JNIEXPORT jlong JNICALL Java_org_proj4_PJ_allocateGeoPJ
|
||||
+ (JNIEnv *, jclass, jobject);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: getVersion
|
||||
+ * Signature: ()Ljava/lang/String;
|
||||
+ */
|
||||
+JNIEXPORT jstring JNICALL Java_org_proj4_PJ_getVersion
|
||||
+ (JNIEnv *, jclass);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: getDefinition
|
||||
+ * Signature: ()Ljava/lang/String;
|
||||
+ */
|
||||
+JNIEXPORT jstring JNICALL Java_org_proj4_PJ_getDefinition
|
||||
+ (JNIEnv *, jobject);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: getType
|
||||
+ * Signature: ()Lorg/proj4/PJ$Type;
|
||||
+ */
|
||||
+JNIEXPORT jobject JNICALL Java_org_proj4_PJ_getType
|
||||
+ (JNIEnv *, jobject);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: getSemiMajorAxis
|
||||
+ * Signature: ()D
|
||||
+ */
|
||||
+JNIEXPORT jdouble JNICALL Java_org_proj4_PJ_getSemiMajorAxis
|
||||
+ (JNIEnv *, jobject);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: getSemiMinorAxis
|
||||
+ * Signature: ()D
|
||||
+ */
|
||||
+JNIEXPORT jdouble JNICALL Java_org_proj4_PJ_getSemiMinorAxis
|
||||
+ (JNIEnv *, jobject);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: getEccentricitySquared
|
||||
+ * Signature: ()D
|
||||
+ */
|
||||
+JNIEXPORT jdouble JNICALL Java_org_proj4_PJ_getEccentricitySquared
|
||||
+ (JNIEnv *, jobject);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: getAxisDirections
|
||||
+ * Signature: ()[C
|
||||
+ */
|
||||
+JNIEXPORT jcharArray JNICALL Java_org_proj4_PJ_getAxisDirections
|
||||
+ (JNIEnv *, jobject);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: getGreenwichLongitude
|
||||
+ * Signature: ()D
|
||||
+ */
|
||||
+JNIEXPORT jdouble JNICALL Java_org_proj4_PJ_getGreenwichLongitude
|
||||
+ (JNIEnv *, jobject);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: getLinearUnitToMetre
|
||||
+ * Signature: (Z)D
|
||||
+ */
|
||||
+JNIEXPORT jdouble JNICALL Java_org_proj4_PJ_getLinearUnitToMetre
|
||||
+ (JNIEnv *, jobject, jboolean);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: transform
|
||||
+ * Signature: (Lorg/proj4/PJ;I[DII)V
|
||||
+ */
|
||||
+JNIEXPORT void JNICALL Java_org_proj4_PJ_transform
|
||||
+ (JNIEnv *, jobject, jobject, jint, jdoubleArray, jint, jint);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: getLastError
|
||||
+ * Signature: ()Ljava/lang/String;
|
||||
+ */
|
||||
+JNIEXPORT jstring JNICALL Java_org_proj4_PJ_getLastError
|
||||
+ (JNIEnv *, jobject);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: toString
|
||||
+ * Signature: ()Ljava/lang/String;
|
||||
+ */
|
||||
+JNIEXPORT jstring JNICALL Java_org_proj4_PJ_toString
|
||||
+ (JNIEnv *, jobject);
|
||||
+
|
||||
+/*
|
||||
+ * Class: org_proj4_PJ
|
||||
+ * Method: finalize
|
||||
+ * Signature: ()V
|
||||
+ */
|
||||
+JNIEXPORT void JNICALL Java_org_proj4_PJ_finalize
|
||||
+ (JNIEnv *, jobject);
|
||||
+
|
||||
+#ifdef __cplusplus
|
||||
+}
|
||||
+#endif
|
||||
+#endif
|
90
proj.spec
Normal file
90
proj.spec
Normal file
@ -0,0 +1,90 @@
|
||||
Name: proj
|
||||
Version: 4.8.0
|
||||
Release: 1mamba
|
||||
Summary: Cartographic Projections Library
|
||||
Group: System/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://trac.osgeo.org/proj/
|
||||
Source: http://download.osgeo.org/proj/proj-%{version}.tar.gz
|
||||
Patch0: proj-4.8.0-add-missing-header.patch
|
||||
License: GPL
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Cartographic Projections Library.
|
||||
|
||||
%package -n libproj
|
||||
Summary: Cartographic Projections Library
|
||||
Group: System/Libraries
|
||||
|
||||
%description -n libproj
|
||||
Cartographic Projections Library.
|
||||
|
||||
%package -n libproj-devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libproj-devel
|
||||
Cartographic Projections Library.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/cs2cs
|
||||
%{_bindir}/geod
|
||||
%{_bindir}/invgeod
|
||||
%{_bindir}/invproj
|
||||
%{_bindir}/nad2bin
|
||||
#%{_bindir}/nad2nad
|
||||
%{_bindir}/proj
|
||||
%{_mandir}/man1/cs2cs.1.gz
|
||||
%{_mandir}/man1/geod.1.gz
|
||||
#%{_mandir}/man1/nad2nad.1.gz
|
||||
%{_mandir}/man1/proj.1.gz
|
||||
|
||||
%files -n libproj
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libproj.so.*
|
||||
%dir %{_datadir}/proj
|
||||
%{_datadir}/proj/*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n libproj-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}
|
||||
%{_includedir}/*.h
|
||||
%{_libdir}/libproj.a
|
||||
%{_libdir}/libproj.la
|
||||
%{_libdir}/libproj.so
|
||||
%{_mandir}/man3/pj_init.3.gz
|
||||
%{_libdir}/pkgconfig/proj.pc
|
||||
%doc ChangeLog NEWS README
|
||||
|
||||
%changelog
|
||||
* Wed Nov 14 2012 Automatic Build System <autodist@mambasoft.it> 4.8.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Nov 05 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 4.7.0-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user