automatic version update by autodist [release 9.5.0-1mamba;Thu Sep 19 2024]
This commit is contained in:
parent
a9058df4b1
commit
973957b9f3
@ -1,139 +0,0 @@
|
|||||||
diff -Nru proj-4.8.0.orig/src/org_proj4_PJ.h proj-4.8.0/src/org_proj4_PJ.h
|
|
||||||
--- proj-4.8.0.orig/src/org_proj4_PJ.h 1970-01-01 01:00:00.000000000 +0100
|
|
||||||
+++ proj-4.8.0/src/org_proj4_PJ.h 2012-11-13 12:31:56.152399854 +0100
|
|
||||||
@@ -0,0 +1,135 @@
|
|
||||||
+/* DO NOT EDIT THIS FILE - it is machine generated */
|
|
||||||
+#include <jni.h>
|
|
||||||
+/* Header for class org_proj4_PJ */
|
|
||||||
+
|
|
||||||
+#ifndef _Included_org_proj4_PJ
|
|
||||||
+#define _Included_org_proj4_PJ
|
|
||||||
+#ifdef __cplusplus
|
|
||||||
+extern "C" {
|
|
||||||
+#endif
|
|
||||||
+#undef org_proj4_PJ_DIMENSION_MAX
|
|
||||||
+#define org_proj4_PJ_DIMENSION_MAX 100L
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: allocatePJ
|
|
||||||
+ * Signature: (Ljava/lang/String;)J
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jlong JNICALL Java_org_proj4_PJ_allocatePJ
|
|
||||||
+ (JNIEnv *, jclass, jstring);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: allocateGeoPJ
|
|
||||||
+ * Signature: (Lorg/proj4/PJ;)J
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jlong JNICALL Java_org_proj4_PJ_allocateGeoPJ
|
|
||||||
+ (JNIEnv *, jclass, jobject);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: getVersion
|
|
||||||
+ * Signature: ()Ljava/lang/String;
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jstring JNICALL Java_org_proj4_PJ_getVersion
|
|
||||||
+ (JNIEnv *, jclass);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: getDefinition
|
|
||||||
+ * Signature: ()Ljava/lang/String;
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jstring JNICALL Java_org_proj4_PJ_getDefinition
|
|
||||||
+ (JNIEnv *, jobject);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: getType
|
|
||||||
+ * Signature: ()Lorg/proj4/PJ$Type;
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jobject JNICALL Java_org_proj4_PJ_getType
|
|
||||||
+ (JNIEnv *, jobject);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: getSemiMajorAxis
|
|
||||||
+ * Signature: ()D
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jdouble JNICALL Java_org_proj4_PJ_getSemiMajorAxis
|
|
||||||
+ (JNIEnv *, jobject);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: getSemiMinorAxis
|
|
||||||
+ * Signature: ()D
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jdouble JNICALL Java_org_proj4_PJ_getSemiMinorAxis
|
|
||||||
+ (JNIEnv *, jobject);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: getEccentricitySquared
|
|
||||||
+ * Signature: ()D
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jdouble JNICALL Java_org_proj4_PJ_getEccentricitySquared
|
|
||||||
+ (JNIEnv *, jobject);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: getAxisDirections
|
|
||||||
+ * Signature: ()[C
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jcharArray JNICALL Java_org_proj4_PJ_getAxisDirections
|
|
||||||
+ (JNIEnv *, jobject);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: getGreenwichLongitude
|
|
||||||
+ * Signature: ()D
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jdouble JNICALL Java_org_proj4_PJ_getGreenwichLongitude
|
|
||||||
+ (JNIEnv *, jobject);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: getLinearUnitToMetre
|
|
||||||
+ * Signature: (Z)D
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jdouble JNICALL Java_org_proj4_PJ_getLinearUnitToMetre
|
|
||||||
+ (JNIEnv *, jobject, jboolean);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: transform
|
|
||||||
+ * Signature: (Lorg/proj4/PJ;I[DII)V
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT void JNICALL Java_org_proj4_PJ_transform
|
|
||||||
+ (JNIEnv *, jobject, jobject, jint, jdoubleArray, jint, jint);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: getLastError
|
|
||||||
+ * Signature: ()Ljava/lang/String;
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jstring JNICALL Java_org_proj4_PJ_getLastError
|
|
||||||
+ (JNIEnv *, jobject);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: toString
|
|
||||||
+ * Signature: ()Ljava/lang/String;
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT jstring JNICALL Java_org_proj4_PJ_toString
|
|
||||||
+ (JNIEnv *, jobject);
|
|
||||||
+
|
|
||||||
+/*
|
|
||||||
+ * Class: org_proj4_PJ
|
|
||||||
+ * Method: finalize
|
|
||||||
+ * Signature: ()V
|
|
||||||
+ */
|
|
||||||
+JNIEXPORT void JNICALL Java_org_proj4_PJ_finalize
|
|
||||||
+ (JNIEnv *, jobject);
|
|
||||||
+
|
|
||||||
+#ifdef __cplusplus
|
|
||||||
+}
|
|
||||||
+#endif
|
|
||||||
+#endif
|
|
11
proj.spec
11
proj.spec
@ -1,5 +1,5 @@
|
|||||||
Name: proj
|
Name: proj
|
||||||
Version: 9.4.1
|
Version: 9.5.0
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Cartographic Projections Library
|
Summary: Cartographic Projections Library
|
||||||
Group: System/Tools
|
Group: System/Tools
|
||||||
@ -8,7 +8,6 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://proj.org/en/9.2/
|
URL: https://proj.org/en/9.2/
|
||||||
Source: http://download.osgeo.org/proj/proj-%{version}.tar.gz
|
Source: http://download.osgeo.org/proj/proj-%{version}.tar.gz
|
||||||
Patch0: proj-4.8.0-add-missing-header.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -43,7 +42,6 @@ This package contains static libraries and header files needed for development.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build
|
%cmake -d build
|
||||||
@ -81,7 +79,7 @@ This package contains static libraries and header files needed for development.
|
|||||||
%{_libdir}/libproj.so.*
|
%{_libdir}/libproj.so.*
|
||||||
%dir %{_datadir}/proj
|
%dir %{_datadir}/proj
|
||||||
%{_datadir}/proj/*
|
%{_datadir}/proj/*
|
||||||
%doc AUTHORS COPYING
|
%doc AUTHORS.md COPYING
|
||||||
|
|
||||||
%files -n libproj-devel
|
%files -n libproj-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -97,9 +95,12 @@ This package contains static libraries and header files needed for development.
|
|||||||
%{_libdir}/cmake/proj4/proj*.cmake
|
%{_libdir}/cmake/proj4/proj*.cmake
|
||||||
%dir %{_datadir}/doc/proj
|
%dir %{_datadir}/doc/proj
|
||||||
%{_datadir}/doc/proj/*
|
%{_datadir}/doc/proj/*
|
||||||
%doc ChangeLog README
|
%doc ChangeLog README.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 19 2024 Automatic Build System <autodist@openmamba.org> 9.5.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sun Jun 02 2024 Automatic Build System <autodist@openmamba.org> 9.4.1-1mamba
|
* Sun Jun 02 2024 Automatic Build System <autodist@openmamba.org> 9.4.1-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user