lgecay package [release 3.3.17-5mamba;Sat Aug 19 2023]
This commit is contained in:
parent
ca669e2ff1
commit
bf4c6ba739
@ -1,2 +1,5 @@
|
||||
# procps-ng3
|
||||
|
||||
This project provides command line and full screen utilities for browsing procfs, a "pseudo" file system dynamically generated by the kernel to provide information about the status of entries in its process table (such as whether the process is running, stopped, or a "zombie").
|
||||
It contains free, kill, pkill, pgrep, pmap, ps, pwdx, skill, slabtop, snice, sysctl, tload, top, uptime, vmstat, w, and watch.
|
||||
|
||||
|
12
procps-3.2.8-kernel-3.0.patch
Normal file
12
procps-3.2.8-kernel-3.0.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru procps-3.2.8.orig/proc/version.c procps-3.2.8/proc/version.c
|
||||
--- procps-3.2.8.orig/proc/version.c 2011-09-18 17:05:50.489893190 +0200
|
||||
+++ procps-3.2.8/proc/version.c 2011-09-18 17:07:03.757693608 +0200
|
||||
@@ -39,7 +39,7 @@
|
||||
|
||||
if (uname(&uts) == -1) /* failure implies impending death */
|
||||
exit(1);
|
||||
- if (sscanf(uts.release, "%d.%d.%d", &x, &y, &z) < 3)
|
||||
+ if (sscanf(uts.release, "%d.%d.%d", &x, &y, &z) < 2)
|
||||
fprintf(stderr, /* *very* unlikely to happen by accident */
|
||||
"Non-standard uts for running kernel:\n"
|
||||
"release %s=%d.%d.%d gives version code %d\n",
|
35
procps-3.2.8-sysinfo_7numbers.patch
Normal file
35
procps-3.2.8-sysinfo_7numbers.patch
Normal file
@ -0,0 +1,35 @@
|
||||
diff -upr procps-3.2.8.orig/proc/sysinfo.c procps-3.2.8/proc/sysinfo.c
|
||||
--- procps-3.2.8.orig/proc/sysinfo.c 2008-03-24 04:33:43.000000000 +0000
|
||||
+++ procps-3.2.8/proc/sysinfo.c 2011-02-07 18:14:16.476982472 +0000
|
||||
@@ -212,6 +212,7 @@ static int check_for_privs(void){
|
||||
static void init_libproc(void) __attribute__((constructor));
|
||||
static void init_libproc(void){
|
||||
have_privs = check_for_privs();
|
||||
+ init_Linux_version();
|
||||
// ought to count CPUs in /proc/stat instead of relying
|
||||
// on glibc, which foolishly tries to parse /proc/cpuinfo
|
||||
//
|
||||
diff -upr procps-3.2.8.orig/proc/version.c procps-3.2.8/proc/version.c
|
||||
--- procps-3.2.8.orig/proc/version.c 2003-01-29 01:11:43.000000000 +0000
|
||||
+++ procps-3.2.8/proc/version.c 2011-02-07 18:13:12.283649138 +0000
|
||||
@@ -33,8 +33,7 @@ void display_version(void) {
|
||||
|
||||
int linux_version_code;
|
||||
|
||||
-static void init_Linux_version(void) __attribute__((constructor));
|
||||
-static void init_Linux_version(void) {
|
||||
+void init_Linux_version(void) {
|
||||
static struct utsname uts;
|
||||
int x = 0, y = 0, z = 0; /* cleared in case sscanf() < 3 */
|
||||
|
||||
diff -upr procps-3.2.8.orig/proc/version.h procps-3.2.8/proc/version.h
|
||||
--- procps-3.2.8.orig/proc/version.h 2002-12-15 00:08:32.000000000 +0000
|
||||
+++ procps-3.2.8/proc/version.h 2011-02-07 18:14:20.263649138 +0000
|
||||
@@ -14,6 +14,7 @@
|
||||
|
||||
EXTERN_C_BEGIN
|
||||
|
||||
+extern void init_Linux_version(void);
|
||||
extern void display_version(void); /* display suite version */
|
||||
extern const char procps_version[]; /* global buf for suite version */
|
||||
|
186
procps-ng3.spec
Normal file
186
procps-ng3.spec
Normal file
@ -0,0 +1,186 @@
|
||||
Name: procps-ng3
|
||||
Version: 3.3.17
|
||||
Release: 5mamba
|
||||
Summary: Command line and full screen utilities for browsing procfs
|
||||
Group: System/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://sourceforge.net/projects/procps-ng
|
||||
Source: http://sourceforge.net/projects/procps-ng/files/Production/procps-ng-%{version}.tar.xz
|
||||
Patch0: procps-3.2.8-sysinfo_7numbers.patch
|
||||
Patch1: procps-3.2.8-kernel-3.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libsystemd-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Provides: /bin/kill
|
||||
Provides: /bin/pidof
|
||||
Provides: /bin/ps
|
||||
|
||||
%description
|
||||
This project provides command line and full screen utilities for browsing procfs, a "pseudo" file system dynamically generated by the kernel to provide information about the status of entries in its process table (such as whether the process is running, stopped, or a "zombie").
|
||||
It contains free, kill, pkill, pgrep, pmap, ps, pwdx, skill, slabtop, snice, sysctl, tload, top, uptime, vmstat, w, and watch.
|
||||
|
||||
%package -n libprocps3
|
||||
Group: System/Libraries
|
||||
Summary: Shared libraries for %{name}
|
||||
|
||||
%description -n libprocps3
|
||||
This package contains shared libraries for %{name}.
|
||||
|
||||
%package -n libprocps3-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: libprocps3 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: pkg-config
|
||||
|
||||
%description -n libprocps3-devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n procps-%{version}
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--with-systemd \
|
||||
--disable-modern-top
|
||||
|
||||
%make \
|
||||
CC=%{_target_platform}-gcc
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%find_lang %{name} --all-name --with-man
|
||||
|
||||
rm -rf %{buildroot}%{_datadir}/doc/procps-ng
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n libprocps3 -p /sbin/ldconfig
|
||||
%postun -n libprocps3 -p /sbin/ldconfig
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/kill
|
||||
%{_bindir}/pidof
|
||||
%{_bindir}/ps
|
||||
%{_sbindir}/sysctl
|
||||
%{_bindir}/free
|
||||
%{_bindir}/pgrep
|
||||
%{_bindir}/pkill
|
||||
%{_bindir}/pmap
|
||||
%{_bindir}/pwait
|
||||
%{_bindir}/pwdx
|
||||
#%{_bindir}/skill
|
||||
%{_bindir}/slabtop
|
||||
#%{_bindir}/snice
|
||||
%{_bindir}/tload
|
||||
%{_bindir}/top
|
||||
%{_bindir}/uptime
|
||||
%{_bindir}/vmstat
|
||||
%{_bindir}/w
|
||||
%{_bindir}/watch
|
||||
%{_mandir}/man?/*
|
||||
|
||||
%files -n libprocps3
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libprocps.so.*
|
||||
%doc AUTHORS COPYING*
|
||||
|
||||
%files -n libprocps3-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/proc
|
||||
%{_includedir}/proc/*.h
|
||||
%{_libdir}/libprocps.a
|
||||
%{_libdir}/libprocps.so
|
||||
%{_libdir}/pkgconfig/libprocps.pc
|
||||
%doc NEWS
|
||||
|
||||
%changelog
|
||||
* Sat Aug 19 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 3.3.17-5mamba
|
||||
- lgecay package
|
||||
|
||||
* Thu May 06 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.3.17-4mamba
|
||||
- provide /bin/kill and /bin/ps
|
||||
|
||||
* Sun May 02 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.3.17-3mamba
|
||||
- provide /bin/pidof
|
||||
|
||||
* Sat May 01 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 3.3.17-2mamba
|
||||
- rebuilt in /usr
|
||||
|
||||
* Thu Feb 25 2021 Automatic Build System <autodist@mambasoft.it> 3.3.17-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Mar 12 2020 Automatic Build System <autodist@mambasoft.it> 3.3.16-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jun 06 2018 Automatic Build System <autodist@mambasoft.it> 3.3.15-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Apr 20 2018 Automatic Build System <autodist@mambasoft.it> 3.3.14-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Apr 11 2018 Automatic Build System <autodist@mambasoft.it> 3.3.13-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jul 14 2016 Automatic Build System <autodist@mambasoft.it> 3.3.12-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Sep 16 2015 Automatic Build System <autodist@mambasoft.it> 3.3.11-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Nov 03 2014 Automatic Build System <autodist@mambasoft.it> 3.3.10-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Aug 09 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.3.9-2mamba
|
||||
- completed work started by Davide
|
||||
|
||||
* Tue Jul 22 2014 Davide Madrisan <davide.madrisan@gmail.com> 3.3.9-1mamba
|
||||
- update to 3.3.9
|
||||
|
||||
* Sun Sep 18 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.8-5mamba
|
||||
- added patch to support 2 components kernel versions (3.0)
|
||||
|
||||
* Sat May 07 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.8-4mamba
|
||||
- added a better patch to fix 'Unknown HZ value' message (see http://bugs.gentoo.org/show_bug.cgi?id=303120#c33)
|
||||
|
||||
* Fri Aug 20 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.8-3mamba
|
||||
- fix the make 3.82 fix to restore build of /bin/ps
|
||||
|
||||
* Wed Aug 18 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.8-2mamba
|
||||
- added Makefile fix for build with make 3.82
|
||||
|
||||
* Sat Jun 06 2009 Automatic Build System <autodist@mambasoft.it> 3.2.8-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Jun 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.7-2mamba
|
||||
- specfile updated
|
||||
|
||||
* Tue Oct 03 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.7-1qilnx
|
||||
- update to version 3.2.7 by autospec
|
||||
|
||||
* Wed Jun 28 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 3.2.6-1qilnx
|
||||
- update to version 3.2.6 by autospec
|
||||
|
||||
* Mon Sep 12 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.5-1qilnx
|
||||
- update to version 3.2.5 by autospec
|
||||
|
||||
* Fri Jul 09 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.1-1qilnx
|
||||
- new version build
|
||||
|
||||
* Sun Nov 30 2003 Davide Madrisan <davide.madrisan@qilinux.it> 3.1.14-1qilnx
|
||||
- rebuilt with latest version (linux 2.6.x compatible version)
|
||||
|
||||
* Wed Apr 09 2003 Mirko Cortillaro <mirko.cortillaro@qinet.it>
|
||||
- write a spec file for procps
|
Loading…
Reference in New Issue
Block a user