automatic version update by autodist [release 4.0.5-1mamba;Mon Dec 23 2024]
This commit is contained in:
parent
193e82d23c
commit
1287256534
@ -1,12 +0,0 @@
|
|||||||
diff -Nru procps-3.2.8.orig/proc/version.c procps-3.2.8/proc/version.c
|
|
||||||
--- procps-3.2.8.orig/proc/version.c 2011-09-18 17:05:50.489893190 +0200
|
|
||||||
+++ procps-3.2.8/proc/version.c 2011-09-18 17:07:03.757693608 +0200
|
|
||||||
@@ -39,7 +39,7 @@
|
|
||||||
|
|
||||||
if (uname(&uts) == -1) /* failure implies impending death */
|
|
||||||
exit(1);
|
|
||||||
- if (sscanf(uts.release, "%d.%d.%d", &x, &y, &z) < 3)
|
|
||||||
+ if (sscanf(uts.release, "%d.%d.%d", &x, &y, &z) < 2)
|
|
||||||
fprintf(stderr, /* *very* unlikely to happen by accident */
|
|
||||||
"Non-standard uts for running kernel:\n"
|
|
||||||
"release %s=%d.%d.%d gives version code %d\n",
|
|
@ -1,35 +0,0 @@
|
|||||||
diff -upr procps-3.2.8.orig/proc/sysinfo.c procps-3.2.8/proc/sysinfo.c
|
|
||||||
--- procps-3.2.8.orig/proc/sysinfo.c 2008-03-24 04:33:43.000000000 +0000
|
|
||||||
+++ procps-3.2.8/proc/sysinfo.c 2011-02-07 18:14:16.476982472 +0000
|
|
||||||
@@ -212,6 +212,7 @@ static int check_for_privs(void){
|
|
||||||
static void init_libproc(void) __attribute__((constructor));
|
|
||||||
static void init_libproc(void){
|
|
||||||
have_privs = check_for_privs();
|
|
||||||
+ init_Linux_version();
|
|
||||||
// ought to count CPUs in /proc/stat instead of relying
|
|
||||||
// on glibc, which foolishly tries to parse /proc/cpuinfo
|
|
||||||
//
|
|
||||||
diff -upr procps-3.2.8.orig/proc/version.c procps-3.2.8/proc/version.c
|
|
||||||
--- procps-3.2.8.orig/proc/version.c 2003-01-29 01:11:43.000000000 +0000
|
|
||||||
+++ procps-3.2.8/proc/version.c 2011-02-07 18:13:12.283649138 +0000
|
|
||||||
@@ -33,8 +33,7 @@ void display_version(void) {
|
|
||||||
|
|
||||||
int linux_version_code;
|
|
||||||
|
|
||||||
-static void init_Linux_version(void) __attribute__((constructor));
|
|
||||||
-static void init_Linux_version(void) {
|
|
||||||
+void init_Linux_version(void) {
|
|
||||||
static struct utsname uts;
|
|
||||||
int x = 0, y = 0, z = 0; /* cleared in case sscanf() < 3 */
|
|
||||||
|
|
||||||
diff -upr procps-3.2.8.orig/proc/version.h procps-3.2.8/proc/version.h
|
|
||||||
--- procps-3.2.8.orig/proc/version.h 2002-12-15 00:08:32.000000000 +0000
|
|
||||||
+++ procps-3.2.8/proc/version.h 2011-02-07 18:14:20.263649138 +0000
|
|
||||||
@@ -14,6 +14,7 @@
|
|
||||||
|
|
||||||
EXTERN_C_BEGIN
|
|
||||||
|
|
||||||
+extern void init_Linux_version(void);
|
|
||||||
extern void display_version(void); /* display suite version */
|
|
||||||
extern const char procps_version[]; /* global buf for suite version */
|
|
||||||
|
|
@ -1,43 +0,0 @@
|
|||||||
From ca004d4657d5e8b468a4552ede429be53193a3a9 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Craig Small <csmall@dropbear.xyz>
|
|
||||||
Date: Thu, 31 Aug 2023 22:24:23 +1000
|
|
||||||
Subject: build-sys: Add systemd/elogind to w
|
|
||||||
|
|
||||||
Depending on the compiler flags, w needs to be explictly linked
|
|
||||||
to libsystemd or elogind even though libproc2 is linked to it.
|
|
||||||
|
|
||||||
Signed-off-by: Craig Small <csmall@dropbear.xyz>
|
|
||||||
---
|
|
||||||
Makefile.am | 7 +++++++
|
|
||||||
NEWS | 3 +++
|
|
||||||
2 files changed, 10 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
|
||||||
index f70c8fb1..ddfc0141 100644
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -149,6 +149,13 @@ endif
|
|
||||||
|
|
||||||
dist_man_MANS += man/w.1
|
|
||||||
src_w_SOURCES = src/w.c local/fileutils.c
|
|
||||||
+src_w_LDADD = $(LDADD)
|
|
||||||
+if WITH_SYSTEMD
|
|
||||||
+src_w_LDADD += @SYSTEMD_LIBS@
|
|
||||||
+endif
|
|
||||||
+if WITH_ELOGIND
|
|
||||||
+src_w_LDADD += @ELOGIND_LIBS@
|
|
||||||
+endif
|
|
||||||
else
|
|
||||||
EXTRA_DIST += man/w.1
|
|
||||||
endif
|
|
||||||
diff --git a/NEWS b/NEWS
|
|
||||||
index 3f2158d4..4ad9f74e 100644
|
|
||||||
--- a/NEWS
|
|
||||||
+++ b/NEWS
|
|
||||||
@@ -1,3 +1,6 @@
|
|
||||||
+procps-ng-NEXT
|
|
||||||
+---------------
|
|
||||||
+
|
|
||||||
procps-ng-4.0.4
|
|
||||||
---------------
|
|
||||||
* library (API & ABI unchanged)
|
|
@ -1,5 +1,5 @@
|
|||||||
Name: procps-ng
|
Name: procps-ng
|
||||||
Version: 4.0.4
|
Version: 4.0.5
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: Command line and full screen utilities for browsing procfs
|
Summary: Command line and full screen utilities for browsing procfs
|
||||||
Group: System/Tools
|
Group: System/Tools
|
||||||
@ -8,9 +8,6 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://sourceforge.net/projects/procps-ng
|
URL: https://sourceforge.net/projects/procps-ng
|
||||||
Source: http://sourceforge.net/projects/procps-ng/files/Production/procps-ng-%{version}.tar.xz
|
Source: http://sourceforge.net/projects/procps-ng/files/Production/procps-ng-%{version}.tar.xz
|
||||||
Patch0: procps-3.2.8-sysinfo_7numbers.patch
|
|
||||||
Patch1: procps-3.2.8-kernel-3.0.patch
|
|
||||||
Patch2: procps-ng-4.0.4-add-systemd-elogind-to-w.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -50,9 +47,6 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#./autogen.sh
|
#./autogen.sh
|
||||||
#%patch0 -p1
|
|
||||||
#%patch1 -p1
|
|
||||||
%patch 2 -p1 -b .add-systemd-elogind-to-w
|
|
||||||
|
|
||||||
autoreconf -f -i
|
autoreconf -f -i
|
||||||
|
|
||||||
@ -73,11 +67,10 @@ autoreconf -f -i
|
|||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%post -n libprocps -p /sbin/ldconfig
|
|
||||||
%postun -n libprocps -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/hugetop
|
||||||
%{_bindir}/kill
|
%{_bindir}/kill
|
||||||
%{_bindir}/pidof
|
%{_bindir}/pidof
|
||||||
%{_bindir}/ps
|
%{_bindir}/ps
|
||||||
@ -115,6 +108,9 @@ autoreconf -f -i
|
|||||||
%doc NEWS
|
%doc NEWS
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 23 2024 Automatic Build System <autodist@openmamba.org> 4.0.5-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Fri Sep 01 2023 Automatic Build System <autodist@mambasoft.it> 4.0.4-1mamba
|
* Fri Sep 01 2023 Automatic Build System <autodist@mambasoft.it> 4.0.4-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user