rebuilt with libsasl2 2.1.16
support for reload in systemd service [release 2.11.3-7mamba;Fri Feb 06 2015]
This commit is contained in:
parent
dbe674e18a
commit
f809005a04
@ -1,6 +1,6 @@
|
||||
diff -uNr postfix-2.9.1.orig/README_FILES/VDA_README postfix-2.9.1/README_FILES/VDA_README
|
||||
--- postfix-2.9.1.orig/README_FILES/VDA_README 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ postfix-2.9.1/README_FILES/VDA_README 2012-03-02 08:30:12.079537052 +0100
|
||||
diff -uNr postfix-2.10.0.orig/README_FILES/VDA_README postfix-2.10.0/README_FILES/VDA_README
|
||||
--- postfix-2.10.0.orig/README_FILES/VDA_README 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ postfix-2.10.0/README_FILES/VDA_README 2013-06-07 13:21:22.837143270 +0200
|
||||
@@ -0,0 +1,10 @@
|
||||
+Postfix VDA patch for maildir++ quota support by
|
||||
+ Anderson Nadal <andernadal@gmail.com>
|
||||
@ -12,10 +12,10 @@ diff -uNr postfix-2.9.1.orig/README_FILES/VDA_README postfix-2.9.1/README_FILES/
|
||||
+provided by this patch.
|
||||
+
|
||||
+
|
||||
diff -uNr postfix-2.9.1.orig/src/global/mail_params.h postfix-2.9.1/src/global/mail_params.h
|
||||
--- postfix-2.9.1.orig/src/global/mail_params.h 2012-01-15 01:36:37.000000000 +0100
|
||||
+++ postfix-2.9.1/src/global/mail_params.h 2012-03-02 08:30:12.079537052 +0100
|
||||
@@ -2360,6 +2360,54 @@
|
||||
diff -uNr postfix-2.10.0.orig/src/global/mail_params.h postfix-2.10.0/src/global/mail_params.h
|
||||
--- postfix-2.10.0.orig/src/global/mail_params.h 2013-02-03 19:22:21.000000000 +0100
|
||||
+++ postfix-2.10.0/src/global/mail_params.h 2013-06-07 13:21:22.838143270 +0200
|
||||
@@ -2367,6 +2367,54 @@
|
||||
#define DEF_VIRT_GID_MAPS ""
|
||||
extern char *var_virt_gid_maps;
|
||||
|
||||
@ -70,9 +70,9 @@ diff -uNr postfix-2.9.1.orig/src/global/mail_params.h postfix-2.9.1/src/global/m
|
||||
#define VAR_VIRT_MINUID "virtual_minimum_uid"
|
||||
#define DEF_VIRT_MINUID 100
|
||||
extern int var_virt_minimum_uid;
|
||||
diff -uNr postfix-2.9.1.orig/src/util/file_limit.c postfix-2.9.1/src/util/file_limit.c
|
||||
--- postfix-2.9.1.orig/src/util/file_limit.c 2003-10-22 20:48:36.000000000 +0200
|
||||
+++ postfix-2.9.1/src/util/file_limit.c 2012-03-02 08:30:12.110537033 +0100
|
||||
diff -uNr postfix-2.10.0.orig/src/util/file_limit.c postfix-2.10.0/src/util/file_limit.c
|
||||
--- postfix-2.10.0.orig/src/util/file_limit.c 2003-10-22 20:48:36.000000000 +0200
|
||||
+++ postfix-2.10.0/src/util/file_limit.c 2013-06-07 13:21:22.839143270 +0200
|
||||
@@ -85,7 +85,11 @@
|
||||
#else
|
||||
struct rlimit rlim;
|
||||
@ -86,10 +86,18 @@ diff -uNr postfix-2.9.1.orig/src/util/file_limit.c postfix-2.9.1/src/util/file_l
|
||||
if (setrlimit(RLIMIT_FSIZE, &rlim) < 0)
|
||||
msg_fatal("setrlimit: %m");
|
||||
#ifdef SIGXFSZ
|
||||
diff -uNr postfix-2.9.1.orig/src/virtual/mailbox.c postfix-2.9.1/src/virtual/mailbox.c
|
||||
--- postfix-2.9.1.orig/src/virtual/mailbox.c 2011-12-24 03:13:32.000000000 +0100
|
||||
+++ postfix-2.9.1/src/virtual/mailbox.c 2012-03-02 08:30:12.110537033 +0100
|
||||
@@ -70,6 +70,70 @@
|
||||
diff -uNr postfix-2.10.0.orig/src/virtual/mailbox.c postfix-2.10.0/src/virtual/mailbox.c
|
||||
--- postfix-2.10.0.orig/src/virtual/mailbox.c 2011-12-24 03:13:32.000000000 +0100
|
||||
+++ postfix-2.10.0/src/virtual/mailbox.c 2013-06-07 13:23:03.044139705 +0200
|
||||
@@ -52,6 +52,7 @@
|
||||
#include <mymalloc.h>
|
||||
#include <stringops.h>
|
||||
#include <set_eugid.h>
|
||||
+#include <iostuff.h>
|
||||
|
||||
/* Global library. */
|
||||
|
||||
@@ -70,6 +71,70 @@
|
||||
#define YES 1
|
||||
#define NO 0
|
||||
|
||||
@ -160,6 +168,23 @@ diff -uNr postfix-2.9.1.orig/src/virtual/mailbox.c postfix-2.9.1/src/virtual/mai
|
||||
/* deliver_mailbox_file - deliver to recipient mailbox */
|
||||
|
||||
static int deliver_mailbox_file(LOCAL_STATE state, USER_ATTR usr_attr)
|
||||
@@ -80,7 +145,6 @@
|
||||
int mail_copy_status;
|
||||
int deliver_status;
|
||||
int copy_flags;
|
||||
- long end;
|
||||
struct stat st;
|
||||
|
||||
/*
|
||||
@@ -132,7 +196,7 @@
|
||||
msg_warn("specify \"%s = no\" to ignore mailbox ownership mismatch",
|
||||
VAR_STRICT_MBOX_OWNER);
|
||||
} else {
|
||||
- end = vstream_fseek(mp->fp, (off_t) 0, SEEK_END);
|
||||
+ vstream_fseek(mp->fp, (off_t) 0, SEEK_END);
|
||||
mail_copy_status = mail_copy(COPY_ATTR(state.msg_attr), mp->fp,
|
||||
copy_flags, "\n", why);
|
||||
}
|
||||
@@ -213,62 +277,72 @@
|
||||
* Look up the mailbox owner rights. Defer in case of trouble.
|
||||
*/
|
||||
@ -268,9 +293,9 @@ diff -uNr postfix-2.9.1.orig/src/virtual/mailbox.c postfix-2.9.1/src/virtual/mai
|
||||
|
||||
/*
|
||||
* Cleanup.
|
||||
diff -uNr postfix-2.9.1.orig/src/virtual/maildir.c postfix-2.9.1/src/virtual/maildir.c
|
||||
--- postfix-2.9.1.orig/src/virtual/maildir.c 2012-01-25 01:41:08.000000000 +0100
|
||||
+++ postfix-2.9.1/src/virtual/maildir.c 2012-03-02 08:33:47.724529361 +0100
|
||||
diff -uNr postfix-2.10.0.orig/src/virtual/maildir.c postfix-2.10.0/src/virtual/maildir.c
|
||||
--- postfix-2.10.0.orig/src/virtual/maildir.c 2012-01-25 01:41:08.000000000 +0100
|
||||
+++ postfix-2.10.0/src/virtual/maildir.c 2013-06-07 13:21:22.840143270 +0200
|
||||
@@ -64,28 +64,420 @@
|
||||
#include <mbox_open.h>
|
||||
#include <dsn_util.h>
|
||||
@ -1210,19 +1235,19 @@ diff -uNr postfix-2.9.1.orig/src/virtual/maildir.c postfix-2.9.1/src/virtual/mai
|
||||
+ if (*var_virt_maildir_limit_message_maps != 0 && (limit_message = mail_addr_find(virtual_maildir_limit_message_maps, state.msg_attr.user, (char **) NULL)) != 0) {
|
||||
+ errno = errnored;
|
||||
+ if (errno == EFBIG) {
|
||||
+ dsb_simple(why, "5.2.2", limit_message);
|
||||
+ dsb_simple(why, "5.2.2", limit_message, NULL);
|
||||
+ }
|
||||
+ if (errno == EDQUOT) {
|
||||
+ dsb_simple(why, "4.2.2", limit_message);
|
||||
+ dsb_simple(why, "4.2.2", limit_message, NULL);
|
||||
+ }
|
||||
+ }
|
||||
+ else {
|
||||
+ errno = errnored;
|
||||
+ if (errno == EFBIG) {
|
||||
+ dsb_simple(why, "5.2.2", var_virt_maildir_limit_message);
|
||||
+ dsb_simple(why, "5.2.2", var_virt_maildir_limit_message, NULL);
|
||||
+ }
|
||||
+ if (errno == EDQUOT) {
|
||||
+ dsb_simple(why, "4.2.2", var_virt_maildir_limit_message);
|
||||
+ dsb_simple(why, "4.2.2", var_virt_maildir_limit_message, NULL);
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
@ -1256,9 +1281,9 @@ diff -uNr postfix-2.9.1.orig/src/virtual/maildir.c postfix-2.9.1/src/virtual/mai
|
||||
+
|
||||
return (deliver_status);
|
||||
}
|
||||
diff -uNr postfix-2.9.1.orig/src/virtual/virtual.c postfix-2.9.1/src/virtual/virtual.c
|
||||
--- postfix-2.9.1.orig/src/virtual/virtual.c 2011-02-19 01:46:06.000000000 +0100
|
||||
+++ postfix-2.9.1/src/virtual/virtual.c 2012-03-02 08:30:12.111537033 +0100
|
||||
diff -uNr postfix-2.10.0.orig/src/virtual/virtual.c postfix-2.10.0/src/virtual/virtual.c
|
||||
--- postfix-2.10.0.orig/src/virtual/virtual.c 2011-02-19 01:46:06.000000000 +0100
|
||||
+++ postfix-2.10.0/src/virtual/virtual.c 2013-06-07 13:21:22.840143270 +0200
|
||||
@@ -335,12 +335,30 @@
|
||||
char *var_mail_spool_dir; /* XXX dependency fix */
|
||||
bool var_strict_mbox_owner;
|
||||
@ -1353,9 +1378,9 @@ diff -uNr postfix-2.9.1.orig/src/virtual/virtual.c postfix-2.9.1/src/virtual/vir
|
||||
MAIL_SERVER_PRIVILEGED,
|
||||
0);
|
||||
}
|
||||
diff -uNr postfix-2.9.1.orig/src/virtual/virtual.h postfix-2.9.1/src/virtual/virtual.h
|
||||
--- postfix-2.9.1.orig/src/virtual/virtual.h 2006-01-08 00:59:47.000000000 +0100
|
||||
+++ postfix-2.9.1/src/virtual/virtual.h 2012-03-02 08:30:12.111537033 +0100
|
||||
diff -uNr postfix-2.10.0.orig/src/virtual/virtual.h postfix-2.10.0/src/virtual/virtual.h
|
||||
--- postfix-2.10.0.orig/src/virtual/virtual.h 2006-01-08 00:59:47.000000000 +0100
|
||||
+++ postfix-2.10.0/src/virtual/virtual.h 2013-06-07 13:21:22.841143270 +0200
|
||||
@@ -34,6 +34,9 @@
|
||||
extern MAPS *virtual_mailbox_maps;
|
||||
extern MAPS *virtual_uid_maps;
|
@ -6,6 +6,7 @@ After=network.target
|
||||
Type=forking
|
||||
ExecStart=/usr/sbin/postfix start
|
||||
ExecStop=/usr/sbin/postfix stop
|
||||
ExecReload=/usr/sbin/postfix reload
|
||||
Restart=always
|
||||
|
||||
[Install]
|
||||
|
18
postfix.spec
18
postfix.spec
@ -9,7 +9,7 @@
|
||||
|
||||
Name: postfix
|
||||
Version: 2.11.3
|
||||
Release: 5mamba
|
||||
Release: 7mamba
|
||||
Summary: A fast, easy to administer, and secure mail transfer agent
|
||||
Group: System/Servers
|
||||
Vendor: openmamba
|
||||
@ -25,18 +25,19 @@ Source5: %{name}-mysql_virtual_mailbox_limit_maps.cf
|
||||
Source6: %{name}-mysql_relay_domains_maps.cf
|
||||
Source7: %{name}-mysql-tables.txt
|
||||
# patch path for download: http://vda.sourceforge.net/VDA/postfix-%{version}-vda-ng.patch.gz
|
||||
Patch0: http://vda.sourceforge.net/VDA/%{name}-vda-v11-2.9.1.patch
|
||||
Patch0: http://vda.sourceforge.net/VDA/postfix-vda-v13-2.10.0.patch
|
||||
License: IBM Public License
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libdb51-devel
|
||||
BuildRequires: libmysql5-devel
|
||||
BuildRequires: libmysql-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libsasl-devel
|
||||
BuildRequires: libsasl2-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: mysql-client
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libsasl2-devel >= 2.1.26
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Provides: mta
|
||||
Provides: /usr/lib/sendmail
|
||||
@ -302,6 +303,13 @@ exit 0
|
||||
%attr(0771,vmail,vmail) %dir %{_localstatedir}/spool/deleted-maildirs
|
||||
|
||||
%changelog
|
||||
* Fri Feb 06 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.11.3-7mamba
|
||||
- rebuilt with libsasl2 2.1.16
|
||||
- support for reload in systemd service
|
||||
|
||||
* Thu Feb 05 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.11.3-6mamba
|
||||
- rebuilt with vda patch updates from 2.9.1 to 2.10.0
|
||||
|
||||
* Thu Jan 22 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.11.3-5mamba
|
||||
- fix permissions of postfix.service
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user