automatic rebuild by autodist [release 1.26-2mamba;Mon Jul 29 2013]
This commit is contained in:
parent
6af63e122c
commit
8eb94ca1d4
@ -1,2 +1,7 @@
|
||||
# pommed
|
||||
|
||||
pommed handles the hotkeys found on the Apple MacBook Pro, MacBook and PowerBook laptops and adjusts the LCD backlight, sound volume, keyboard backlight or ejects the CD-ROM drive accordingly.
|
||||
pommed also monitors the ambient light sensors to automatically light up the keyboard backlight on the MacBook Pro and the latest PowerBook.
|
||||
Optional support for the Apple Remote control is available.
|
||||
mbpeventd has been renamed to pommed as we've added support for PowerBook laptops.
|
||||
|
||||
|
12
pommed-1.26-missing-ldflag.patch
Normal file
12
pommed-1.26-missing-ldflag.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru pommed-1.26.orig/gpomme/Makefile pommed-1.26/gpomme/Makefile
|
||||
--- pommed-1.26.orig/gpomme/Makefile 2013-07-29 02:23:15.428699876 +0200
|
||||
+++ pommed-1.26/gpomme/Makefile 2013-07-29 02:22:48.470944552 +0200
|
||||
@@ -18,7 +18,7 @@
|
||||
INOTIFY_CFLAGS = $(shell test -e /usr/include/sys/inotify.h || echo -DNO_SYS_INOTIFY_H)
|
||||
|
||||
CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(GLADE_CFLAGS) $(INOTIFY_CFLAGS)
|
||||
-LDFLAGS = -lpthread $(DBUS_LIBS) $(DBUSGLIB_LIBS) $(GTK_LIBS) $(CONFUSE_LIBS) $(GLADE_LIBS)
|
||||
+LDFLAGS = -lpthread -lX11 $(DBUS_LIBS) $(DBUSGLIB_LIBS) $(GTK_LIBS) $(CONFUSE_LIBS) $(GLADE_LIBS)
|
||||
|
||||
SOURCES = gpomme.c theme.c conffile.c \
|
||||
../client-common/dbus-client.c \
|
107
pommed.spec
Normal file
107
pommed.spec
Normal file
@ -0,0 +1,107 @@
|
||||
Name: pommed
|
||||
Version: 1.26
|
||||
Release: 2mamba
|
||||
Summary: Handles the hotkeys and other special functions found on the Apple MacBook Pro, MacBook and PowerBook laptops
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.technologeek.org/projects/pommed/index.html
|
||||
Source: https://alioth.debian.org/frs/download.php/2975/pommed-%{version}.tar.gz
|
||||
Patch0: pommed-1.26-missing-ldflag.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libaudiofile-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libconfuse-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdbus-glib-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libglade-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libpci-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
pommed handles the hotkeys found on the Apple MacBook Pro, MacBook and PowerBook laptops and adjusts the LCD backlight, sound volume, keyboard backlight or ejects the CD-ROM drive accordingly.
|
||||
pommed also monitors the ambient light sensors to automatically light up the keyboard backlight on the MacBook Pro and the latest PowerBook.
|
||||
Optional support for the Apple Remote control is available.
|
||||
mbpeventd has been renamed to pommed as we've added support for PowerBook laptops.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
install -D -m0755 pommed/pommed %{buildroot}%{_sbindir}/pommed
|
||||
install -d %{buildroot}%{_datadir}/pommed
|
||||
cp -a pommed/data/* %{buildroot}%{_datadir}/pommed/
|
||||
install -D -m0644 pommed.conf.mactel %{buildroot}%{_sysconfdir}/pommed.conf
|
||||
install -D -m0755 pommed.init %{buildroot}%{_initrddir}/pommed
|
||||
install -D -m0644 dbus-policy.conf %{buildroot}%{_sysconfdir}/dbus-1/system.d/pommed.conf
|
||||
|
||||
install -D -m0755 gpomme/gpomme %{buildroot}%{_bindir}/gpomme
|
||||
install -d -m0755 gpomme %{buildroot}%{_datadir}/gpomme
|
||||
cp -a gpomme/themes %{buildroot}%{_datadir}/gpomme/
|
||||
install -D -m0755 gpomme/gpomme %{buildroot}%{_bindir}/gpomme
|
||||
install -d %{buildroot}%{_datadir}/applications
|
||||
install -m0644 gpomme/gpomme*.desktop %{buildroot}%{_datadir}/applications
|
||||
install -m0644 gpomme/gpomme.glade %{buildroot}%{_datadir}/gpomme/gpomme.glade
|
||||
|
||||
cd gpomme/po
|
||||
for f in *.mo; do
|
||||
install -D -m0644 $f %{buildroot}%{_datadir}/locale/${f/.*}/LC_MESSAGES/gpomme.mo
|
||||
done
|
||||
cd ../..
|
||||
|
||||
for f in 16x16 22x22 32x32 48x48 64x64 96x96 128x128; do
|
||||
install -D icons/gpomme_$f.png %{buildroot}%{_datadir}/icons/hicolor/$f/gpomme.png
|
||||
done
|
||||
install -D icons/gpomme.svg %{buildroot}%{_datadir}/icons/hicolor/scalable/gpomme.svg
|
||||
|
||||
install -D -m0644 pommed.1 %{buildroot}%{_mandir}/man1/pommed.1
|
||||
install -D -m0644 gpomme/gpomme.1 %{buildroot}%{_mandir}/man1/gpomme.1
|
||||
|
||||
|
||||
%find_lang gpomme
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f gpomme.lang
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/dbus-1/system.d/pommed.conf
|
||||
%config(noreplace) %{_sysconfdir}/pommed.conf
|
||||
%{_initrddir}/pommed
|
||||
%{_bindir}/gpomme
|
||||
%{_sbindir}/pommed
|
||||
%{_datadir}/applications/gpomme-c.desktop
|
||||
%{_datadir}/applications/gpomme.desktop
|
||||
%{_datadir}/gpomme/gpomme.glade
|
||||
%{_datadir}/gpomme/themes
|
||||
%{_datadir}/pommed/*.wav
|
||||
%{_datadir}/icons/hicolor/*/gpomme.png
|
||||
%{_datadir}/icons/hicolor/scalable/gpomme.svg
|
||||
%{_mandir}/man1/gpomme.1.gz
|
||||
%{_mandir}/man1/pommed.1.gz
|
||||
%doc AUTHORS COPYING ChangeLog README TODO
|
||||
|
||||
%changelog
|
||||
* Mon Jul 29 2013 Automatic Build System <autodist@mambasoft.it> 1.26-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Mon Jul 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.26-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user