qt4 legacy package [release 0.112.0-2mamba;Thu Apr 09 2020]
This commit is contained in:
parent
c50d94b537
commit
eb8a48bd5b
@ -1,2 +1,4 @@
|
||||
# polkit-qt4-1
|
||||
|
||||
polkit-qt-1 aims to make it easy for Qt developers to take advantage of polkit API. It is a convenience wrapper around QAction and QAbstractButton that lets you integrate those two components easily with polkit.
|
||||
|
||||
|
17
polkit-qt-0.95.1-install-cmake-find.patch
Normal file
17
polkit-qt-0.95.1-install-cmake-find.patch
Normal file
@ -0,0 +1,17 @@
|
||||
diff -up polkit-qt-1-0.95.1/cmake/modules/CMakeLists.txt.install-cmake-find polkit-qt-1-0.95.1/cmake/modules/CMakeLists.txt
|
||||
--- polkit-qt-1-0.95.1/cmake/modules/CMakeLists.txt.install-cmake-find 2009-12-23 12:31:13.000000000 +0100
|
||||
+++ polkit-qt-1-0.95.1/cmake/modules/CMakeLists.txt 2010-01-14 15:22:30.100520720 +0100
|
||||
@@ -1,9 +1,9 @@
|
||||
|
||||
## install the cmake files
|
||||
|
||||
-#file( GLOB cmakeFiles FindPolkitQt.cmake )
|
||||
-#set(module_install_dir ${CMAKE_ROOT}/Modules )
|
||||
+file( GLOB cmakeFiles FindPolkitQt-1.cmake )
|
||||
+set(module_install_dir ${CMAKE_ROOT}/Modules )
|
||||
|
||||
-#install( FILES ${cmakeFiles}
|
||||
-# DESTINATION ${module_install_dir} )
|
||||
+install( FILES ${cmakeFiles}
|
||||
+ DESTINATION ${module_install_dir} )
|
||||
|
127
polkit-qt4-1.spec
Normal file
127
polkit-qt4-1.spec
Normal file
@ -0,0 +1,127 @@
|
||||
Name: polkit-qt4-1
|
||||
Version: 0.112.0
|
||||
Release: 2mamba
|
||||
Summary: Qt4 bindings for polkit
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://api.kde.org/kdesupport-api/kdesupport-apidocs/polkit-qt-1/html/
|
||||
Source: ftp://ftp.kde.org/pub/kde/stable/apps/KDE4.x/admin/polkit-qt-1-%{version}.tar.bz2
|
||||
Patch0: polkit-qt-0.95.1-install-cmake-find.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libpolkit-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: cmake
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
polkit-qt-1 aims to make it easy for Qt developers to take advantage of polkit API. It is a convenience wrapper around QAction and QAbstractButton that lets you integrate those two components easily with polkit.
|
||||
|
||||
%package -n libpolkit-qt-1
|
||||
Group: System/Libraries
|
||||
Summary: Qt4 bindings for polkit
|
||||
Provides: polkit-qt
|
||||
Obsoletes: polkit-qt
|
||||
Provides: polkit-qt-1
|
||||
Obsoletes: polkit-qt-1
|
||||
|
||||
%description -n libpolkit-qt-1
|
||||
Polkit-qt-1 aims to make it easy for Qt5 developers to take advantage of polkit API. It is a convenience wrapper around QAction and QAbstractButton that lets you integrate those two components easily with polkit.
|
||||
|
||||
%package -n libpolkit-qt-1-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: libpolkit-qt-1 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: polkit-qt-devel
|
||||
Obsoletes: polkit-qt-devel
|
||||
Provides: polkit-qt-1-devel
|
||||
Obsoletes: polkit-qt-1-devel
|
||||
|
||||
%description -n libpolkit-qt-1-devel
|
||||
Polkit-qt-1 aims to make it easy for Qt developers to take advantage of polkit API. It is a convenience wrapper around QAction and QAbstractButton that lets you integrate those two components easily with polkit.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n polkit-qt-1-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build \
|
||||
-DUSE_QT4=ON
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n libpolkit-qt-1
|
||||
/sbin/ldconfig
|
||||
:
|
||||
|
||||
%postun -n libpolkit-qt-1
|
||||
/sbin/ldconfig
|
||||
:
|
||||
|
||||
%files -n libpolkit-qt-1
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libpolkit-qt-agent-1.so.*
|
||||
%{_libdir}/libpolkit-qt-core-1.so.*
|
||||
%{_libdir}/libpolkit-qt-gui-1.so.*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n libpolkit-qt-1-devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/polkit-qt-1/PolkitQt1
|
||||
%{_includedir}/polkit-qt-1/polkitqt1-*.h
|
||||
%{_datadir}/cmake/Modules/FindPolkitQt-1.cmake
|
||||
%{_libdir}/cmake/PolkitQt-1/PolkitQt-1Config.cmake
|
||||
%{_libdir}/cmake/PolkitQt-1/PolkitQt-1ConfigVersion.cmake
|
||||
%{_libdir}/libpolkit-qt-agent-1.so
|
||||
%{_libdir}/libpolkit-qt-core-1.so
|
||||
%{_libdir}/libpolkit-qt-gui-1.so
|
||||
%{_libdir}/pkgconfig/polkit-qt-1.pc
|
||||
%{_libdir}/pkgconfig/polkit-qt-core-1.pc
|
||||
%{_libdir}/pkgconfig/polkit-qt-gui-1.pc
|
||||
%{_libdir}/pkgconfig/polkit-qt-agent-1.pc
|
||||
%{_libdir}/cmake/PolkitQt-1/PolkitQt-1Targets-noconfig.cmake
|
||||
%{_libdir}/cmake/PolkitQt-1/PolkitQt-1Targets.cmake
|
||||
%doc README TODO
|
||||
|
||||
%changelog
|
||||
* Thu Apr 09 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.112.0-2mamba
|
||||
- qt4 legacy package
|
||||
|
||||
* Tue Feb 03 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 0.112.0-1mamba
|
||||
- update to 0.112.0
|
||||
|
||||
* Tue Dec 20 2011 Automatic Build System <autodist@mambasoft.it> 0.103.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jan 27 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.99.0-1mamba
|
||||
- update to 0.99.0
|
||||
|
||||
* Thu Oct 28 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.96.1-1mamba
|
||||
- update to 0.96.1
|
||||
|
||||
* Thu Jun 10 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.95.1-3mamba
|
||||
- obsolete polkit-qt
|
||||
|
||||
* Mon Apr 05 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.95.1-2mamba
|
||||
- added install-cmake-find patch
|
||||
|
||||
* Sun Apr 04 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.95.1-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user