added qt6 subpackages [release 0.175.0-2mamba;Tue Jan 30 2024]
This commit is contained in:
parent
30ef5f0c6d
commit
fda66902f9
@ -1,17 +0,0 @@
|
||||
diff -up polkit-qt-1-0.95.1/cmake/modules/CMakeLists.txt.install-cmake-find polkit-qt-1-0.95.1/cmake/modules/CMakeLists.txt
|
||||
--- polkit-qt-1-0.95.1/cmake/modules/CMakeLists.txt.install-cmake-find 2009-12-23 12:31:13.000000000 +0100
|
||||
+++ polkit-qt-1-0.95.1/cmake/modules/CMakeLists.txt 2010-01-14 15:22:30.100520720 +0100
|
||||
@@ -1,9 +1,9 @@
|
||||
|
||||
## install the cmake files
|
||||
|
||||
-#file( GLOB cmakeFiles FindPolkitQt.cmake )
|
||||
-#set(module_install_dir ${CMAKE_ROOT}/Modules )
|
||||
+file( GLOB cmakeFiles FindPolkitQt-1.cmake )
|
||||
+set(module_install_dir ${CMAKE_ROOT}/Modules )
|
||||
|
||||
-#install( FILES ${cmakeFiles}
|
||||
-# DESTINATION ${module_install_dir} )
|
||||
+install( FILES ${cmakeFiles}
|
||||
+ DESTINATION ${module_install_dir} )
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: polkit-qt-1
|
||||
Version: 0.175.0
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: Qt bindings for polkit
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -8,16 +8,16 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://invent.kde.org/libraries/polkit-qt-1
|
||||
Source: https://invent.kde.org/libraries/polkit-qt-1.git/v%{version}/polkit-qt-1-%{version}.tar.bz2
|
||||
#Source: https://download.kde.org/stable/polkit-qt-1/polkit-qt-1-%{version}.tar.xz
|
||||
Patch0: polkit-qt-0.95.1-install-cmake-find.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libpolkit-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
BuildRequires: qt6-qtbase-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: cmake
|
||||
|
||||
@ -40,19 +40,41 @@ Requires: libpolkit-qt5-1 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Polkit-qt-1 aims to make it easy for Qt5 developers to take advantage of polkit API. It is a convenience wrapper around QAction and QAbstractButton that lets you integrate those two components easily with polkit.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%package -n libpolkit-qt6-1
|
||||
Group: System/Libraries
|
||||
Summary: Qt6 bindings for polkit
|
||||
|
||||
%description -n libpolkit-qt6-1
|
||||
Polkit-qt-1 aims to make it easy for Qt6 developers to take advantage of polkit API. It is a convenience wrapper around QAction and QAbstractButton that lets you integrate those two components easily with polkit.
|
||||
|
||||
%package -n libpolkit-qt6-1-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for libpolkit-qt6-1
|
||||
Requires: libpolkit-qt6-1 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libpolkit-qt6-1-devel
|
||||
Polkit-qt-1 aims to make it easy for Qt6 developers to take advantage of polkit API. It is a convenience wrapper around QAction and QAbstractButton that lets you integrate those two components easily with polkit.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
|
||||
%make
|
||||
|
||||
cd ..
|
||||
%cmake -d build-qt6\
|
||||
-DQT_MAJOR_VERSION=6
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build-qt6
|
||||
%makeinstall -C build
|
||||
|
||||
%clean
|
||||
@ -66,6 +88,14 @@ This package contains static libraries and header files needed for development.
|
||||
/sbin/ldconfig
|
||||
:
|
||||
|
||||
%post -n libpolkit-qt6-1
|
||||
/sbin/ldconfig
|
||||
:
|
||||
|
||||
%postun -n libpolkit-qt6-1
|
||||
/sbin/ldconfig
|
||||
:
|
||||
|
||||
%files -n libpolkit-qt5-1
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libpolkit-qt5-agent-1.so.*
|
||||
@ -76,22 +106,8 @@ This package contains static libraries and header files needed for development.
|
||||
%files -n libpolkit-qt5-1-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/polkit-qt5-1
|
||||
%dir %{_includedir}/polkit-qt5-1/PolkitQt1
|
||||
%{_includedir}/polkit-qt5-1/PolkitQt1/Agent/Session
|
||||
%{_includedir}/polkit-qt5-1/PolkitQt1/ActionDescription
|
||||
%{_includedir}/polkit-qt5-1/PolkitQt1/Agent
|
||||
%{_includedir}/polkit-qt5-1/PolkitQt1/Authority
|
||||
%{_includedir}/polkit-qt5-1/PolkitQt1/Details
|
||||
%dir %{_includedir}/polkit-qt5-1/PolkitQt1/Gui
|
||||
%{_includedir}/polkit-qt5-1/PolkitQt1/Gui/Action*
|
||||
%{_includedir}/polkit-qt5-1/PolkitQt1/Identity
|
||||
%{_includedir}/polkit-qt5-1/PolkitQt1/Subject
|
||||
%{_includedir}/polkit-qt5-1/PolkitQt1/TemporaryAuthorization
|
||||
%{_includedir}/polkit-qt5-1/*.h
|
||||
%{_libdir}/cmake/PolkitQt5-1/PolkitQt5-1Config.cmake
|
||||
%{_libdir}/cmake/PolkitQt5-1/PolkitQt5-1ConfigVersion.cmake
|
||||
%{_libdir}/cmake/PolkitQt5-1/PolkitQt5-1Targets-noconfig.cmake
|
||||
%{_libdir}/cmake/PolkitQt5-1/PolkitQt5-1Targets.cmake
|
||||
%{_includedir}/polkit-qt5-1/*
|
||||
%dir %{_libdir}/cmake/PolkitQt5-1
|
||||
%{_libdir}/libpolkit-qt5-agent-1.so
|
||||
%{_libdir}/libpolkit-qt5-core-1.so
|
||||
%{_libdir}/libpolkit-qt5-gui-1.so
|
||||
@ -99,10 +115,35 @@ This package contains static libraries and header files needed for development.
|
||||
%{_libdir}/pkgconfig/polkit-qt5-agent-1.pc
|
||||
%{_libdir}/pkgconfig/polkit-qt5-core-1.pc
|
||||
%{_libdir}/pkgconfig/polkit-qt5-gui-1.pc
|
||||
#%{_datadir}/cmake/Modules/FindPolkitQt-1.cmake
|
||||
%{_libdir}/cmake/PolkitQt5-1/PolkitQt5-1*.cmake
|
||||
%doc README TODO
|
||||
|
||||
%files -n libpolkit-qt6-1
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libpolkit-qt6-agent-1.so.*
|
||||
%{_libdir}/libpolkit-qt6-core-1.so.*
|
||||
%{_libdir}/libpolkit-qt6-gui-1.so.*
|
||||
%doc LICENSES
|
||||
|
||||
%files -n libpolkit-qt6-1-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/polkit-qt6-1
|
||||
%{_includedir}/polkit-qt6-1/*
|
||||
%{_libdir}/libpolkit-qt6-agent-1.so
|
||||
%{_libdir}/libpolkit-qt6-core-1.so
|
||||
%{_libdir}/libpolkit-qt6-gui-1.so
|
||||
%{_libdir}/pkgconfig/polkit-qt6-1.pc
|
||||
%{_libdir}/pkgconfig/polkit-qt6-agent-1.pc
|
||||
%{_libdir}/pkgconfig/polkit-qt6-core-1.pc
|
||||
%{_libdir}/pkgconfig/polkit-qt6-gui-1.pc
|
||||
%dir %{_libdir}/cmake/PolkitQt6-1
|
||||
%{_libdir}/cmake/PolkitQt6-1/PolkitQt6-1*.cmake
|
||||
%doc README TODO
|
||||
|
||||
%changelog
|
||||
* Tue Jan 30 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.175.0-2mamba
|
||||
- added qt6 subpackages
|
||||
|
||||
* Tue Dec 12 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.175.0-1mamba
|
||||
- update to 0.175.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user