automatic version update by autodist [release 5.22.1-1mamba;Wed Jun 16 2021]
This commit is contained in:
parent
e54c03210a
commit
02d17e38f8
22
plasma-firewall-5.22.0-find-ss-in-sbindir.patch
Normal file
22
plasma-firewall-5.22.0-find-ss-in-sbindir.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- plasma-firewall-5.22.0/kcm/backends/netstat/netstatclient.cpp.orig 2021-06-10 21:47:42.415281680 +0200
|
||||
+++ plasma-firewall-5.22.0/kcm/backends/netstat/netstatclient.cpp 2021-06-10 21:51:38.145326862 +0200
|
||||
@@ -20,7 +20,7 @@
|
||||
, m_connections(new ConnectionsModel(this))
|
||||
{
|
||||
_self = this;
|
||||
- mHasSS = !QStandardPaths::findExecutable("ss").isEmpty();
|
||||
+ mHasSS = !QStandardPaths::findExecutable("ss", {"/usr/sbin", "/usr/bin"}).isEmpty();
|
||||
}
|
||||
|
||||
bool NetstatClient::hasSS() const
|
||||
--- plasma-firewall-5.22.0/kcm/backends/netstat/netstathelper.cpp.orig 2021-06-10 21:46:46.387327547 +0200
|
||||
+++ plasma-firewall-5.22.0/kcm/backends/netstat/netstathelper.cpp 2021-06-10 21:47:23.696962293 +0200
|
||||
@@ -33,7 +33,7 @@
|
||||
*/
|
||||
|
||||
const QStringList netstatArgs( m_hasTimeoutError ? QStringList({"-tuap"}) : QStringList({"-tuapr"}));
|
||||
- const QString executable = QStringLiteral("ss");
|
||||
+ const QString executable = QStringLiteral("/usr/sbin/ss");
|
||||
|
||||
connect(
|
||||
m_executableProcess, QOverload<int, QProcess::ExitStatus>::of(&QProcess::finished),
|
87
plasma-firewall.spec
Normal file
87
plasma-firewall.spec
Normal file
@ -0,0 +1,87 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
|
||||
Name: plasma-firewall
|
||||
Version: 5.22.1
|
||||
Release: 1mamba
|
||||
Summary: KDE Plasma 5 Firewall KCM
|
||||
Group: Graphical Desktop/Applications/Internet
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://kde.org
|
||||
Source: https://download.kde.org/stable/plasma/%{version}/plasma-firewall-%{version}.tar.xz
|
||||
Patch0: plasma-firewall-5.22.0-find-ss-in-sbindir.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libkauth-devel
|
||||
BuildRequires: libkconfig-devel
|
||||
BuildRequires: libkcoreaddons-devel
|
||||
BuildRequires: libkdeclarative-devel
|
||||
BuildRequires: libki18n-devel
|
||||
BuildRequires: libkpackage-devel
|
||||
BuildRequires: libqt5-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: cmake
|
||||
BuildRequires: rpm-macros-kde5
|
||||
BuildRequires: extra-cmake-modules
|
||||
Requires: ufw
|
||||
Requires: iproute
|
||||
Provides: firewallgui
|
||||
Provides: kcm_ufw
|
||||
Obsoletes: kcm_ufw <= 5.0
|
||||
|
||||
%description
|
||||
KDE Plasma 5 Firewall KCM.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%cmake_kde5 -d build
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
%find_lang %{name}5_qt --with-qt --with-man --with-html --all-name || touch %{name}5_qt.lang
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f %{name}5_qt.lang
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libkcm_firewall_core.so
|
||||
%{_libdir}/qt5/plugins/kcms/kcm_firewall.so
|
||||
%{_libdir}/qt5/plugins/kf5/plasma_firewall/firewalldbackend.so
|
||||
%{_libdir}/qt5/plugins/kf5/plasma_firewall/ufwbackend.so
|
||||
%{_libexecdir}/kde_ufw_plugin_helper.py
|
||||
%{_libexecdir}/kf5/kauth/kde_ufw_plugin_helper
|
||||
%{_datadir}/dbus-1/system-services/org.kde.ufw.service
|
||||
%{_datadir}/dbus-1/system.d/org.kde.ufw.conf
|
||||
%{_datadir}/kcm_ufw/defaults
|
||||
%dir %{_datadir}/kpackage/kcms/kcm_firewall
|
||||
%dir %{_datadir}/kpackage/kcms/kcm_firewall/contents
|
||||
%dir %{_datadir}/kpackage/kcms/kcm_firewall/contents/ui
|
||||
%{_datadir}/kpackage/kcms/kcm_firewall/contents/ui/*
|
||||
%{_datadir}/kpackage/kcms/kcm_firewall/metadata.*
|
||||
%{_datadir}/kservices5/kcm_firewall.desktop
|
||||
%{_datadir}/metainfo/org.kde.plasma.firewall.metainfo.xml
|
||||
%{_datadir}/polkit-1/actions/org.kde.ufw.policy
|
||||
%doc LICENSES
|
||||
|
||||
%changelog
|
||||
* Wed Jun 16 2021 Automatic Build System <autodist@mambasoft.it> 5.22.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jun 10 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 5.22.0-2mamba
|
||||
- require iproute and ufw; patched to find ss from iproute in %_sbindir
|
||||
|
||||
* Thu Jun 10 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 5.22.0-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user