libboost 1.52 mass rebuild [release 0.7.6-2mamba;Sat Dec 15 2012]

This commit is contained in:
Silvan Calarco 2024-01-06 10:07:33 +01:00
parent 8bdf34b953
commit 88341eeea9
4 changed files with 153 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# pingus
Pingus is a free Lemmings clone for GNU/Linux. The player takes command in the game of a bunch of small animals and has to guide them around in levels. Since the animals walk on their own, the player can only influence them by giving them commands, like build a bridge, dig a hole or redirect all animals in the other direction. The goal of each level is to reach the exit, for fix multiple combination of commands are necessary.

23
pingus-0.7.2-gcc44.patch Normal file
View File

@ -0,0 +1,23 @@
diff -Nru pingus-0.7.2.orig/src/input/evdev_device.cpp pingus-0.7.2/src/input/evdev_device.cpp
--- pingus-0.7.2.orig/src/input/evdev_device.cpp 2007-10-01 19:24:54.000000000 +0200
+++ pingus-0.7.2/src/input/evdev_device.cpp 2009-06-04 14:33:13.000000000 +0200
@@ -25,6 +25,8 @@
#include <stdexcept>
#include <iostream>
#include <errno.h>
+#include <cstdio>
+#include <string.h>
#include "evdev_device.hpp"
diff -Nru pingus-0.7.2.orig/src/tinygettext/po_file_reader.cpp pingus-0.7.2/src/tinygettext/po_file_reader.cpp
--- pingus-0.7.2.orig/src/tinygettext/po_file_reader.cpp 2007-10-18 19:54:01.000000000 +0200
+++ pingus-0.7.2/src/tinygettext/po_file_reader.cpp 2009-06-04 14:33:27.000000000 +0200
@@ -18,6 +18,7 @@
// Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#include <config.h>
+#include <cstdio>
#include <vector>
#include <iconv.h>
#include <errno.h>

View File

@ -0,0 +1,22 @@
--- a/src/pingus/pingus_main.cpp
+++ b/src/pingus/pingus_main.cpp
@@ -465,7 +465,7 @@
void
PingusMain::print_greeting_message()
{
- std::string greeting = "Welcome to Pingus "VERSION;
+ std::string greeting = "Welcome to Pingus " VERSION;
greeting += "!";
std::cout << greeting << std::endl;
for (unsigned int i = 0; i < greeting.length(); ++i)
--- a/src/pingus/screens/pingus_menu.cpp
+++ b/src/pingus/screens/pingus_menu.cpp
@@ -153,7 +153,7 @@
gc.get_height()/2 - 280));
gc.print_left(Fonts::pingus_small, Vector2i(gc.get_width()/2 - 400 + 25, gc.get_height()-140),
- "Pingus "VERSION" - Copyright (C) 1998-2011 Ingo Ruhnke <grumbel@gmail.com>\n"
+ "Pingus " VERSION " - Copyright (C) 1998-2011 Ingo Ruhnke <grumbel@gmail.com>\n"
"See the file AUTHORS for a complete list of contributors.\n"
"Pingus comes with ABSOLUTELY NO WARRANTY. This is free software, and you are\n"
"welcome to redistribute it under certain conditions; see the file COPYING for details.\n");

106
pingus.spec Normal file
View File

@ -0,0 +1,106 @@
Name: pingus
Version: 0.7.6
Release: 2mamba
Summary: A free Lemmings clone for GNU/Linux
Group: Graphical Desktop/Applications/Games
Vendor: openmamba
Distribution: openmamba
Packager: Tiziana Ferro <tiziana.ferro@email.it>
URL: http://pingus.seul.org/
Source: http://pingus.googlecode.com/files/pingus-%{version}.tar.bz2
Patch0: %{name}-0.7.2-gcc44.patch
Patch1: pingus-0.7.6-gcc-4.7.patch
License: GPL
## AUTOBUILDREQ-BEGIN
#BuildRequires: file /usr/lib/libboost_signals-mt.so is not owned by any package
BuildRequires: glibc-devel
BuildRequires: libgcc
BuildRequires: libpng-devel
BuildRequires: libSDL-devel
BuildRequires: libSDL_image-devel
BuildRequires: libSDL_mixer-devel
BuildRequires: libstdc++6-devel
## AUTOBUILDREQ-END
BuildRequires: libboost-devel
BuildRequires: scons
BuildRequires: libXi-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
%description
Pingus is a free Lemmings clone for GNU/Linux. The player takes command in the game of a bunch of small animals and has to guide them around in levels. Since the animals walk on their own, the player can only influence them by giving them commands, like build a bridge, dig a hole or redirect all animals in the other direction. The goal of each level is to reach the exit, for fix multiple combination of commands are necessary.
%prep
%setup -q
#%patch0 -p1
%patch1 -p1
# note: it loads *.po files directly, no need to use msgfmt
mv -f data/po/sr{,@latin}.po
rm -f data/po/pingus.pot
%build
scons
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall PREFIX=%{_prefix}
# Create the system menu entry
mkdir -p %{buildroot}%{_datadir}/applications/
cat > %{buildroot}%{_datadir}/applications/%{name}.desktop << EOF
[Desktop Entry]
Encoding=UTF-8
Name=Pingus
Comment=A Lemmings clone
GenericName=A Lemmings clone
Comment[it]=Un clone di Lemmings
GenericName[it]=Un clone di Lemmings
Exec=pingus
Icon=tux
Terminal=0
Type=Application
Categories=KDE;Game;ArcadeGame;
EOF
mv %{buildroot}%{_mandir}/man1 %{buildroot}%{_mandir}/man6
#install -d %{buildroot}{%{_bindir},%{_desktopdir},%{_pixmapsdir}}
#install %{name} %{buildroot}%{_bindir}
#cp -r data %{buildroot}%{_datadir}/%{name}
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files
%defattr(-,root,root)
%{_bindir}/pingus
%{_bindir}/pingus.bin
%{_datadir}/applications/%{name}.desktop
%dir %{_datadir}/pingus/
%{_datadir}/pingus/*
%{_mandir}/man6/pingus.*
%doc AUTHORS COPYING
# ChangeLog NEWS README TODO
%changelog
* Sat Dec 15 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.6-2mamba
- libboost 1.52 mass rebuild
* Fri Jul 06 2012 Automatic Build System <autodist@mambasoft.it> 0.7.6-1mamba
- update to 0.7.6
* Tue Dec 14 2010 Automatic Build System <autodist@mambasoft.it> 0.7.2-4mamba
- automatic rebuild by autodist
* Sun Jun 13 2010 Automatic Build System <autodist@mambasoft.it> 0.7.2-3mamba
- automatic rebuild by autodist
* Thu Jun 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.7.2-2mamba
- rebuilt with libboost 1.39.0
* Sat May 03 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.7.2-1mamba
- update to 0.7.2, switch from ClanLib to SDL
* Thu Aug 18 2005 Massimo Pintore <massimo.pintore@qilinux.it> 0.6.0-1qilnx
- first build