automatic update by autodist [release 3.0.5-1mamba;Sun Dec 29 2013]

This commit is contained in:
Automatic Build System 2024-01-06 10:00:08 +01:00
parent 83164d5e8d
commit a620124133
5 changed files with 226 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# phplist
phplist is a one-way email announcement delivery system. It is great for newsletters, publicity lists, notifications, and many other uses.

View File

@ -0,0 +1,11 @@
diff -Nru phplist-2.10.14.orig//public_html/lists/admin/languages.php phplist-2.10.14/public_html/lists/admin/languages.php
--- phplist-2.10.14.orig//public_html/lists/admin/languages.php 2010-04-05 21:57:29.000000000 +0200
+++ phplist-2.10.14/public_html/lists/admin/languages.php 2011-06-08 20:14:53.579889859 +0200
@@ -14,6 +14,7 @@
"es"=>array("español","iso-8859-1","iso-8859-1, windows-1252"),
#"fa" => array('Persian','utf-8','utf-8'),
"fr"=>array("français ","iso-8859-1","iso-8859-1, windows-1252 "),
+"it"=>array("italiano ","iso-8859-1","iso-8859-1, windows-1252 "),
"pl"=>array("Polish ","iso-8859-2","iso-8859-2"),
"pt-br"=>array("português ","iso-8859-1","iso-8859-1, windows-1252"),
"zh-tw" => array("Traditional Chinese","utf-8","utf-8"),

View File

@ -0,0 +1,12 @@
diff -Nru phplist-2.10.5.orig/public_html/lists/config/config.php phplist-2.10.5/public_html/lists/config/config.php
--- phplist-2.10.5.orig/public_html/lists/config/config.php 2006-12-16 03:25:08.000000000 +0100
+++ phplist-2.10.5/public_html/lists/config/config.php 2008-02-26 03:56:59.000000000 +0100
@@ -188,7 +188,7 @@
# if test is true (not 0) it will not actually send ANY messages,
# but display what it would have sent
-define ("TEST",1);
+define ("TEST",0);
# if you set verbose to 1, it will show the messages that will be sent. Do not do this
# if you have a lot of users, because it is likely to crash your browser

View File

@ -0,0 +1,14 @@
diff -Nru phplist-2.10.5.orig/public_html/lists/config/config.php phplist-2.10.5/public_html/lists/config/config.php
--- phplist-2.10.5.orig/public_html/lists/config/config.php 2006-12-16 03:25:08.000000000 +0100
+++ phplist-2.10.5/public_html/lists/config/config.php 2008-02-26 04:44:52.000000000 +0100
@@ -45,8 +45,8 @@
# if you change the path to the PHPlist system, make the change here as well
# path should be relative to the root directory of your webserver (document root)
# you cannot actually change the "admin", but you can change the "lists"
-$pageroot = '/lists';
-$adminpages = '/lists/admin';
+$pageroot = '/';
+$adminpages = '/admin';
/*

187
phplist.spec Normal file
View File

@ -0,0 +1,187 @@
%define serverdir %(apxs -q htdocsdir 2>/dev/null)
# To create a customized installation of phplist:
# autospec -u phplist -a5 \
# -d "installdir=%serverdir/../www.example.com, \
# sitename=example, \
# adminmail=webmaster@example.com"
%if "%{?installdir}" == ""
%define installdir %{serverdir}/phplist
%endif
%if "%{?sitename}" != ""
%if "%{?servername}" == ""
%define servername %(basename %installdir 2>/dev/null)
%endif
%define serverlogdir %(apxs -q logfiledir 2>/dev/null)
%else
%if "%{?aliasdir}" == ""
%define aliasdir /phplist
%endif
%endif
Name: %{?sitename:%sitename-website-}phplist
Epoch: 1
Version: 3.0.5
Release: 1mamba
Summary: A one-way email announcement delivery system
Group: Applications/Web
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.phplist.com/
Source: http://downloads.sourceforge.net/sourceforge/phplist/phplist-%{version}.tgz
Source1: admin_lan_it.zip
Source2: admin_help_it.zip
Source3: admin_info_it.zip
Patch0: phplist-2.10.14-languages.patch
Patch1: phplist-2.10.5-disable_testmode.patch
Patch2: phplist-2.10.5-move_to_root.patch
License: GPL
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildArch: noarch
## AUTOBUILDREQ-BEGIN
## AUTOBUILDREQ-END
Requires: php
Requires: phpmailer
Requires: php-imap
%description
phplist is a one-way email announcement delivery system. It is great for newsletters, publicity lists, notifications, and many other uses.
%prep
%setup -q -n phplist-%{version}
exit 0
%patch0 -p1
%patch1 -p1
%patch2 -p1
# install italian localization
cd public_html/lists/admin/lan
unzip %{SOURCE1}
cd ../help
unzip %{SOURCE2}
cd ../info
unzip %{SOURCE3}
%build
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
install -d %{buildroot}%{installdir}
cp -a public_html/lists/* %{buildroot}%{installdir}
install -d %{buildroot}%{_sysconfdir}/httpd/httpd.d
%if "%{?sitename}" != ""
cat > %{buildroot}%{_sysconfdir}/httpd/httpd.d/%{servername}.conf << EOF
%else
cat > %{buildroot}%{_sysconfdir}/httpd/httpd.d/%{name}.conf << EOF
%endif
%if "%{?sitename}" == ""
%if "%(dirname %installdir)" != "%{serverdir}"
Alias %{aliasdir} %{installdir}
%endif
%endif
<Directory %{installdir}>
AllowOverride All
Order allow,deny
Allow from All
DirectoryIndex index.php index.html
</Directory>
%if "%{?sitename}" != ""
%if "%(dirname %installdir)" != "%{serverdir}"
<VirtualHost *:80>
%{?adminmail:ServerAdmin %adminmail}
DocumentRoot %{installdir}
ServerName %{servername}
ErrorLog %{serverlogdir}/%{servername}-error_log
CustomLog %{serverlogdir}/%{servername}-access_log common
</VirtualHost>
%endif
%endif
EOF
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%dir %{installdir}
%{installdir}/*.php
%{installdir}/index.html
%dir %{installdir}/admin
%{installdir}/admin/.htaccess
%{installdir}/admin/.minceconf
%{installdir}/admin/*
%config(noreplace) %{installdir}/config/*
%config(noreplace) %{installdir}/config/.htaccess
%dir %{installdir}/images
%{installdir}/images/*
%{installdir}/js/*
%{installdir}/styles/*
%{installdir}/texts/*
%if "%{?sitename}" != ""
%config(noreplace) %{_sysconfdir}/httpd/httpd.d/%{servername}.conf
%else
%config(noreplace) %{_sysconfdir}/httpd/httpd.d/%{name}.conf
%endif
%doc COPYING
#NEWS BUGS README README.batches README.bounces README.commandline
#%doc README.passwords README.repetition README.rssfeeds README.security
#%doc README.usertables TODO
%changelog
* Sun Dec 29 2013 Automatic Build System <autodist@mambasoft.it> 3.0.5-1mamba
- automatic update by autodist
* Mon Sep 30 2013 Automatic Build System <autodist@mambasoft.it> 3.0.4-1mamba
- automatic update by autodist
* Thu Aug 22 2013 Automatic Build System <autodist@mambasoft.it> 3.0.2-1mamba
- automatic update by autodist
* Wed Feb 06 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.19-2mamba
- fix apxs path
* Thu Jan 10 2013 Automatic Build System <autodist@mambasoft.it> 2.10.19-1mamba
- automatic version update by autodist
* Tue Aug 07 2012 Automatic Build System <autodist@mambasoft.it> 2.10.18-1mamba
- automatic version update by autodist
* Mon Oct 24 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.17-1mamba
- update to 2.10.17
* Wed Jun 08 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.14-1mamba
- update to 2.10.14
- downgraded to stable release
* Tue Aug 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.11.3-2mamba
- added requirement for php-imap
* Wed Jul 15 2009 Automatic Build System <autodist@mambasoft.it> 2.11.3-1mamba
- automatic update by autodist
* Tue May 26 2009 Automatic Build System <autodist@mambasoft.it> 2.10.10-1mamba
- automatic update by autodist
* Tue Feb 03 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.9-1mamba
- update to 2.10.9
* Wed Dec 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.8-1mamba
- automatic update by autodist
* Tue Feb 26 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.5-2mamba
- added patch that disables demo mode by default
- added requirement for phpmailer
* Mon Feb 25 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.5-1mamba
- package created by autospec
- added italian translation from
www.dharmstyle.it/2007/04/23/traduzione-phplist-in-italiano