php-fpm: configure to use alternative rundir /run/php7-fpm [release 7.4.33-3mamba;Tue Jan 16 2024]
This commit is contained in:
parent
99ff345280
commit
a1f9bcf47c
@ -1,2 +1,6 @@
|
||||
# php7
|
||||
|
||||
PHP is an HTML-embeddable scripting language.
|
||||
PHP offers built-in database integration for several commercial and non-commercial database management systems, so writing a database-enabled script with PHP is fairly simple.
|
||||
The most common use of PHP coding is probably as a replacement for CGI scripts.
|
||||
|
||||
|
8759
hardening-patch-5.1.6-0.4.15.patch
Normal file
8759
hardening-patch-5.1.6-0.4.15.patch
Normal file
File diff suppressed because it is too large
Load Diff
12
php-5.0.5-phpbuilddir.patch
Normal file
12
php-5.0.5-phpbuilddir.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ru php-5.0.5/scripts/Makefile.frag php-5.0.5-fix/scripts/Makefile.frag
|
||||
--- php-5.0.5/scripts/Makefile.frag 2005-06-07 23:57:06.000000000 +0200
|
||||
+++ php-5.0.5-fix/scripts/Makefile.frag 2005-09-19 10:01:03.000000000 +0200
|
||||
@@ -4,7 +4,7 @@
|
||||
#
|
||||
|
||||
phpincludedir = $(includedir)/php
|
||||
-phpbuilddir = $(libdir)/build
|
||||
+phpbuilddir = $(libdir)/php/build
|
||||
|
||||
BUILD_FILES = \
|
||||
scripts/phpize.m4 \
|
74
php-7.4.23-php-fpm.patch
Normal file
74
php-7.4.23-php-fpm.patch
Normal file
@ -0,0 +1,74 @@
|
||||
--- sapi/fpm/Makefile.frag.orig
|
||||
+++ sapi/fpm/Makefile.frag
|
||||
@@ -15,8 +15,8 @@
|
||||
else \
|
||||
echo "Installing PHP FPM defconfig: $(INSTALL_ROOT)$(sysconfdir)/" && \
|
||||
$(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d; \
|
||||
- $(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default; \
|
||||
- $(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d/www.conf.default; \
|
||||
+ $(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf; \
|
||||
+ $(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d/www.conf; \
|
||||
fi
|
||||
|
||||
@echo "Installing PHP FPM man page: $(INSTALL_ROOT)$(mandir)/man8/"
|
||||
--- sapi/fpm/php-fpm.conf.in.orig
|
||||
+++ sapi/fpm/php-fpm.conf.in
|
||||
@@ -14,14 +14,14 @@
|
||||
; Pid file
|
||||
; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
|
||||
; Default Value: none
|
||||
-;pid = run/php-fpm.pid
|
||||
+;pid = /run/php-fpm/php-fpm.pid
|
||||
|
||||
; Error log file
|
||||
; If it's set to "syslog", log is sent to syslogd instead of being written
|
||||
; into a local file.
|
||||
; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
|
||||
; Default Value: log/php-fpm.log
|
||||
-;error_log = log/php-fpm.log
|
||||
+error_log = syslog
|
||||
|
||||
; syslog_facility is used to specify what type of program is logging the
|
||||
; message. This lets syslogd specify that messages from different facilities
|
||||
--- sapi/fpm/www.conf.in.orig
|
||||
+++ sapi/fpm/www.conf.in
|
||||
@@ -33,7 +33,7 @@
|
||||
; (IPv6 and IPv4-mapped) on a specific port;
|
||||
; '/path/to/unix/socket' - to listen on a unix socket.
|
||||
; Note: This value is mandatory.
|
||||
-listen = 127.0.0.1:9000
|
||||
+listen = /run/php-fpm/php-fpm.sock
|
||||
|
||||
; Set listen(2) backlog.
|
||||
; Default Value: 511 (-1 on FreeBSD and OpenBSD)
|
||||
@@ -45,8 +45,8 @@
|
||||
; and group can be specified either by name or by their numeric IDs.
|
||||
; Default Values: user and group are set as the running user
|
||||
; mode is set to 0660
|
||||
-;listen.owner = @php_fpm_user@
|
||||
-;listen.group = @php_fpm_group@
|
||||
+listen.owner = @php_fpm_user@
|
||||
+listen.group = @php_fpm_group@
|
||||
;listen.mode = 0660
|
||||
; When POSIX Access Control Lists are supported you can set them using
|
||||
; these options, value is a comma separated list of user/group names.
|
||||
@@ -387,7 +387,7 @@
|
||||
; Chdir to this directory at the start.
|
||||
; Note: relative path can be used.
|
||||
; Default Value: current directory or / when chroot
|
||||
-;chdir = /var/www
|
||||
+;chdir = /srv/http
|
||||
|
||||
; Redirect worker stdout and stderr into main error log. If not set, stdout and
|
||||
; stderr will be redirected to /dev/null according to FastCGI specs.
|
||||
--- sapi/fpm/php-fpm.service.in.orig
|
||||
+++ sapi/fpm/php-fpm.service.in
|
||||
@@ -8,7 +8,7 @@
|
||||
|
||||
[Service]
|
||||
Type=@php_fpm_systemd@
|
||||
-PIDFile=@EXPANDED_LOCALSTATEDIR@/run/php-fpm.pid
|
||||
+PIDFile=/run/php-fpm/php-fpm.pid
|
||||
ExecStart=@EXPANDED_SBINDIR@/php-fpm --nodaemonize --fpm-config @EXPANDED_SYSCONFDIR@/php-fpm.conf
|
||||
ExecReload=/bin/kill -USR2 $MAINPID
|
||||
|
12
php-7.4.33-openssl-3.patch
Normal file
12
php-7.4.33-openssl-3.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- a/ext/openssl/openssl.c
|
||||
+++ b/ext/openssl/openssl.c
|
||||
@@ -1482,7 +1482,9 @@
|
||||
REGISTER_LONG_CONSTANT("PKCS7_NOSIGS", PKCS7_NOSIGS, CONST_CS|CONST_PERSISTENT);
|
||||
|
||||
REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_PADDING", RSA_PKCS1_PADDING, CONST_CS|CONST_PERSISTENT);
|
||||
+#ifdef RSA_SSLV23_PADDING
|
||||
REGISTER_LONG_CONSTANT("OPENSSL_SSLV23_PADDING", RSA_SSLV23_PADDING, CONST_CS|CONST_PERSISTENT);
|
||||
+#endif
|
||||
REGISTER_LONG_CONSTANT("OPENSSL_NO_PADDING", RSA_NO_PADDING, CONST_CS|CONST_PERSISTENT);
|
||||
REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_OAEP_PADDING", RSA_PKCS1_OAEP_PADDING, CONST_CS|CONST_PERSISTENT);
|
||||
|
1124
php-httpd-conf
Normal file
1124
php-httpd-conf
Normal file
File diff suppressed because it is too large
Load Diff
1
php7-fpm.tmpfiles
Normal file
1
php7-fpm.tmpfiles
Normal file
@ -0,0 +1 @@
|
||||
d /run/php7-fpm 755 root root
|
Loading…
Reference in New Issue
Block a user