update to 7.4.6 [release 7.4.6-1mamba;Fri May 29 2020]
This commit is contained in:
parent
774aa22348
commit
a82fd78564
70
php-7.4.6-mariadb-10.4.13.patch
Normal file
70
php-7.4.6-mariadb-10.4.13.patch
Normal file
@ -0,0 +1,70 @@
|
||||
diff -up php-7.2.4/ext/mysqli/mysqli_api.c.omv~ php-7.2.4/ext/mysqli/mysqli_api.c
|
||||
--- php-7.2.4/ext/mysqli/mysqli_api.c.omv~ 2018-04-06 21:50:05.183703414 +0200
|
||||
+++ php-7.2.4/ext/mysqli/mysqli_api.c 2018-04-06 21:50:16.436829372 +0200
|
||||
@@ -616,7 +616,7 @@ PHP_FUNCTION(mysqli_change_user)
|
||||
size_t user_len, password_len, dbname_len;
|
||||
zend_ulong rc;
|
||||
#if !defined(MYSQLI_USE_MYSQLND) && defined(HAVE_MYSQLI_SET_CHARSET)
|
||||
- const CHARSET_INFO * old_charset;
|
||||
+ const MY_CHARSET_INFO * old_charset;
|
||||
#endif
|
||||
|
||||
if (zend_parse_method_parameters(ZEND_NUM_ARGS(), getThis(), "Osss!", &mysql_link, mysqli_link_class_entry, &user, &user_len, &password, &password_len, &dbname, &dbname_len) == FAILURE) {
|
||||
diff -up php-7.2.4/ext/mysqli/mysqli.c.omv~ php-7.2.4/ext/mysqli/mysqli.c
|
||||
--- php-7.2.4/ext/mysqli/mysqli.c.omv~ 2018-04-06 21:49:41.782434506 +0200
|
||||
+++ php-7.2.4/ext/mysqli/mysqli.c 2018-04-06 21:49:52.708561249 +0200
|
||||
@@ -26,6 +26,7 @@
|
||||
|
||||
#include <signal.h>
|
||||
|
||||
+#include <server/mysql_version.h>
|
||||
#include "php.h"
|
||||
#include "php_ini.h"
|
||||
#include "ext/standard/info.h"
|
||||
diff -up php-7.2.4/ext/mysqli/mysqli_nonapi.c.omv~ php-7.2.4/ext/mysqli/mysqli_nonapi.c
|
||||
--- php-7.2.4/ext/mysqli/mysqli_nonapi.c.omv~ 2018-04-06 21:51:43.217399945 +0200
|
||||
+++ php-7.2.4/ext/mysqli/mysqli_nonapi.c 2018-04-06 21:58:52.799445824 +0200
|
||||
@@ -263,7 +263,7 @@ void mysqli_common_connect(INTERNAL_FUNC
|
||||
php_mysqli_set_error(mysql_errno(mysql->mysql), (char *) mysql_error(mysql->mysql));
|
||||
|
||||
#if !defined(MYSQLI_USE_MYSQLND)
|
||||
- mysql->mysql->reconnect = MyG(reconnect);
|
||||
+/* mysql->mysql->reconnect = MyG(reconnect); */
|
||||
#endif
|
||||
|
||||
mysql_options(mysql->mysql, MYSQL_OPT_LOCAL_INFILE, (char *)&MyG(allow_local_infile));
|
||||
diff -up php-7.2.4/ext/mysqli/mysqli_prop.c.omv~ php-7.2.4/ext/mysqli/mysqli_prop.c
|
||||
--- php-7.2.4/ext/mysqli/mysqli_prop.c.omv~ 2018-04-06 21:50:25.687842714 +0200
|
||||
+++ php-7.2.4/ext/mysqli/mysqli_prop.c 2018-04-06 21:50:35.116768902 +0200
|
||||
@@ -23,6 +23,7 @@
|
||||
|
||||
#include <signal.h>
|
||||
|
||||
+#include <server/mysql_version.h>
|
||||
#include "php.h"
|
||||
#include "php_ini.h"
|
||||
#include "ext/standard/info.h"
|
||||
diff -up php-7.2.4/ext/mysqli/php_mysqli_structs.h.omv~ php-7.2.4/ext/mysqli/php_mysqli_structs.h
|
||||
--- php-7.2.4/ext/mysqli/php_mysqli_structs.h.omv~ 2018-04-06 21:49:12.161080045 +0200
|
||||
+++ php-7.2.4/ext/mysqli/php_mysqli_structs.h 2018-04-06 21:58:44.599503172 +0200
|
||||
@@ -79,11 +79,7 @@
|
||||
#include <my_sys.h>
|
||||
#include <mysql.h>
|
||||
#include <errmsg.h>
|
||||
-#include <my_list.h>
|
||||
-#include <m_string.h>
|
||||
#include <mysqld_error.h>
|
||||
-#include <my_list.h>
|
||||
-#include <m_ctype.h>
|
||||
#include "mysqli_libmysql.h"
|
||||
#endif /* MYSQLI_USE_MYSQLND */
|
||||
|
||||
@@ -326,7 +322,7 @@ ZEND_BEGIN_MODULE_GLOBALS(mysqli)
|
||||
char *default_user;
|
||||
char *default_socket;
|
||||
char *default_pw;
|
||||
- zend_long reconnect;
|
||||
+/* zend_long reconnect; */
|
||||
zend_long allow_local_infile;
|
||||
zend_long strict;
|
||||
zend_long error_no;
|
84
php.spec
84
php.spec
@ -6,7 +6,7 @@
|
||||
%define with_hardening_patch 0
|
||||
|
||||
Name: php
|
||||
Version: 7.3.2
|
||||
Version: 7.4.6
|
||||
Release: 1mamba
|
||||
Summary: The PHP HTML-embedded scripting language
|
||||
Group: Applications/Development
|
||||
@ -22,49 +22,38 @@ Patch2: %{name}-5.2.5-phpize_dir.patch
|
||||
Patch3: %{name}-5.2.9-db47.patch
|
||||
Patch4: %{name}-5.2.11-BID_36555.patch
|
||||
Patch5: %{name}-5.3.13-apache-2.4.patch
|
||||
Patch6: php-7.4.6-mariadb-10.4.13.patch
|
||||
License: PHP License
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXpm-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcares-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libdb51-devel
|
||||
BuildRequires: libdb53-devel
|
||||
BuildRequires: libe2fs-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgd-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgss-devel
|
||||
BuildRequires: libidn-devel
|
||||
BuildRequires: libjbig-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libkeyutils-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libimap-c-client-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: libltdl-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libmcrypt-devel
|
||||
BuildRequires: libmysqlclient-devel
|
||||
BuildRequires: libodbc-devel
|
||||
BuildRequires: libonig-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpam-devel
|
||||
BuildRequires: libpostgresql-devel
|
||||
BuildRequires: libpsl-devel
|
||||
BuildRequires: librtmp-devel
|
||||
BuildRequires: libsasl-devel
|
||||
BuildRequires: libsasl2-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libssh2-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libvpx-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libxslt-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: pam-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: apache-devel
|
||||
BuildRequires: libapr-devel
|
||||
@ -79,6 +68,8 @@ BuildRequires: pkgconfig
|
||||
BuildRequires: /usr/sbin/sendmail
|
||||
BuildRequires: flex, bison
|
||||
BuildRequires: re2c
|
||||
BuildRequires: libmariadb-devel >= 10.4.13
|
||||
BuildRequires: libonig-devel
|
||||
Requires(pre): libapr >= 1.2.2
|
||||
Requires(pre): libaprutil >= 1.2.2
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
@ -251,26 +242,32 @@ The most common use of PHP coding is probably as a replacement for CGI scripts.
|
||||
|
||||
This package adds PHP support to the Apache Web Server.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%if %with_hardening_patch
|
||||
%patch0 -p1 -b .hardening
|
||||
%endif
|
||||
%patch1 -p1 -b .phpbuilddir
|
||||
%patch2 -p1
|
||||
#%patch3 -p1
|
||||
#%patch4 -p4
|
||||
#%patch6 -p1
|
||||
|
||||
# phpize dir
|
||||
sed -i "s|@libdir@\`/build|@libdir@\`/php/build|" scripts/phpize.in
|
||||
|
||||
# prevent %%doc confusion over LICENSE files
|
||||
cp Zend/LICENSE Zend/ZEND_LICENSE
|
||||
cp TSRM/LICENSE TSRM_LICENSE
|
||||
cp ext/gd/libgd/README gd_README
|
||||
#cp ext/gd/libgd/README gd_README
|
||||
|
||||
# remove unneded packages
|
||||
#rm -f HTML_Template_IT-*.tar Net_UserAgent_Detect-*.tar
|
||||
#popd
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
EXTENSION_DIR=%{_libdir}/php/extensions; export EXTENSION_DIR
|
||||
# Required to set default INCLUDE_PATH with %{_libdir}/php
|
||||
PEAR_INSTALLDIR="%{_libdir}/php"; export PEAR_INSTALLDIR
|
||||
@ -297,19 +294,20 @@ PEAR_INSTALLDIR="%{_libdir}/php"; export PEAR_INSTALLDIR
|
||||
--with-freetype-dir=%{_prefix} \
|
||||
--with-pgsql=shared,%{_prefix} \
|
||||
--with-mysql=shared,%{_prefix} \
|
||||
--with-mysqli=shared,%{_bindir}/mysql_config \
|
||||
--with-mysql-sock=/run/mysqld/mysql.sock \
|
||||
--with-mysqli=shared,mysqlnd \
|
||||
--with-pdo-mysql=shared,mysqlnd \
|
||||
--with-unixODBC=shared,%{_prefix} \
|
||||
--with-imap=shared,%{_libdir}/imap/ \
|
||||
--with-imap=shared,%{_libdir}/imap/lib \
|
||||
--with-imap-ssl \
|
||||
--with-mcrypt \
|
||||
--with-db4=%{_includedir}/db51 \
|
||||
--with-db4=%{_includedir}/db53 \
|
||||
--with-xsl=shared \
|
||||
--without-pear \
|
||||
--with-kerberos \
|
||||
--with-bz2 \
|
||||
--with-curl \
|
||||
--with-xmlrpc \
|
||||
--with-pdo-mysql=shared \
|
||||
--with-pdo-odbc=shared,unixODBC,%{_prefix} \
|
||||
--with-pdo-pgsql=shared \
|
||||
--with-pdo-sqlite=shared \
|
||||
@ -320,8 +318,7 @@ PEAR_INSTALLDIR="%{_libdir}/php"; export PEAR_INSTALLDIR
|
||||
--enable-soap \
|
||||
--enable-zip \
|
||||
--enable-exif \
|
||||
--enable-intl \
|
||||
--with-mysql-sock=/run/mysqld/mysql.sock
|
||||
--enable-intl
|
||||
|
||||
%make
|
||||
|
||||
@ -341,11 +338,6 @@ s|\(extension_dir = \).*|\1%{_libdir}/php/extensions|
|
||||
s|\(;extension=\)php_\(.*\)dll|\1\2so|g;s|w32api.so|odbc.so|" \
|
||||
%{buildroot}%{_sysconfdir}/php/php.ini
|
||||
|
||||
# remove execution permission from some files
|
||||
chmod 0664 %{buildroot}%{_libdir}/php/build/*.awk
|
||||
chmod 0664 %{buildroot}%{_libdir}/php/build/*.global
|
||||
chmod 0664 %{buildroot}%{_libdir}/php/build/*.m4
|
||||
|
||||
# create php.conf file for httpd
|
||||
install -d %{buildroot}%{_sysconfdir}/httpd/httpd.d
|
||||
cat > %{buildroot}%{_sysconfdir}/httpd/httpd.d/php.conf << _EOF
|
||||
@ -436,7 +428,6 @@ exit 0
|
||||
%{_mandir}/man1/phpdbg.1*
|
||||
%dir %{_localstatedir}/lib/php
|
||||
%dir %{_localstatedir}/lib/php/session
|
||||
%doc CREDITS
|
||||
%doc LICENSE Zend/ZEND_LICENSE TSRM_LICENSE
|
||||
%doc php.ini-development php.ini-production
|
||||
|
||||
@ -448,8 +439,7 @@ exit 0
|
||||
%{_includedir}/php/*
|
||||
%{_mandir}/man1/php-config.1*
|
||||
%{_mandir}/man1/phpize.1*
|
||||
%doc CODING_STANDARDS EXTENSIONS README.*
|
||||
%doc NEWS gd_README
|
||||
%doc CODING_STANDARDS.md EXTENSIONS README.md NEWS
|
||||
|
||||
%files -n apache-mod_php
|
||||
%defattr(-,root,root)
|
||||
@ -490,6 +480,12 @@ exit 0
|
||||
%defattr(-,root,root)
|
||||
|
||||
%changelog
|
||||
* Fri May 29 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 7.4.6-1mamba
|
||||
- update to 7.4.6
|
||||
|
||||
* Thu May 28 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 7.3.18-1mamba
|
||||
- update to 7.3.18
|
||||
|
||||
* Wed Feb 20 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 7.3.2-1mamba
|
||||
- update to 7.3.2
|
||||
|
||||
@ -868,7 +864,7 @@ exit 0
|
||||
- fixed AddType line configuration in httpd.conf
|
||||
- shared extensions enabled
|
||||
|
||||
* Thu Dec 23 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3.4-2qilnx
|
||||
* Tue Dec 23 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3.4-2qilnx
|
||||
- added libmcrypt support
|
||||
|
||||
* Thu Dec 18 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 4.3.4-1qilnx
|
||||
|
Loading…
Reference in New Issue
Block a user