build with gettext shared [release 8.3.9-2mamba;Thu Jul 11 2024]

This commit is contained in:
Silvan Calarco 2024-07-12 13:33:05 +02:00
parent 89a8a185bc
commit 88512533c6
7 changed files with 22 additions and 217 deletions

View File

@ -1,12 +0,0 @@
diff -ru php-5.0.5/scripts/Makefile.frag php-5.0.5-fix/scripts/Makefile.frag
--- php-5.0.5/scripts/Makefile.frag 2005-06-07 23:57:06.000000000 +0200
+++ php-5.0.5-fix/scripts/Makefile.frag 2005-09-19 10:01:03.000000000 +0200
@@ -4,7 +4,7 @@
#
phpincludedir = $(includedir)/php
-phpbuilddir = $(libdir)/build
+phpbuilddir = $(libdir)/php/build
BUILD_FILES = \
scripts/phpize.m4 \

View File

@ -1,13 +0,0 @@
--- php/php-src/branches/PHP_5_2/ext/standard/file.c 2009/09/25 01:53:02 288706
+++ php/php-src/branches/PHP_5_2/ext/standard/file.c 2009/09/29 14:14:02 288945
@@ -838,6 +838,10 @@
convert_to_string_ex(arg1);
convert_to_string_ex(arg2);
+ if (PG(safe_mode) &&(!php_checkuid(Z_STRVAL_PP(arg1), NULL, CHECKUID_ALLOW_ONLY_DIR))) {
+ RETURN_FALSE;
+ }
+
if (php_check_open_basedir(Z_STRVAL_PP(arg1) TSRMLS_CC)) {
RETURN_FALSE;
}

View File

@ -1,12 +0,0 @@
diff -Nru php-5.2.5.orig/scripts/phpize.in php-5.2.5/scripts/phpize.in
--- php-5.2.5.orig/scripts/phpize.in 2007-06-29 03:10:35.000000000 +0200
+++ php-5.2.5/scripts/phpize.in 2007-12-03 18:27:11.000000000 +0100
@@ -3,7 +3,7 @@
# Variable declaration
prefix='@prefix@'
exec_prefix="`eval echo @exec_prefix@`"
-phpdir="`eval echo @libdir@`/build"
+phpdir="`eval echo @libdir@`/php/build"
includedir="`eval echo @includedir@`/php"
builddir="`pwd`"
SED="@SED@"

View File

@ -1,12 +0,0 @@
diff -Nru php-5.2.9.orig/configure php-5.2.9/configure
--- php-5.2.9.orig/configure 2009-02-25 16:39:40.000000000 +0100
+++ php-5.2.9/configure 2009-06-09 02:34:50.000000000 +0200
@@ -28610,7 +28610,7 @@
if test -z "$THIS_INCLUDE"; then
{ echo "configure: error: DBA: Could not find necessary header file(s)." 1>&2; exit 1; }
fi
- for LIB in db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db; do
+ for LIB in db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db; do
if test -f $THIS_PREFIX/$PHP_LIBDIR/lib$LIB.a || test -f $THIS_PREFIX/$PHP_LIBDIR/lib$LIB.$SHLIB_SUFFIX_NAME; then
lib_found="";

View File

@ -1,88 +0,0 @@
Index: sapi/apache2handler/config.m4
===================================================================
--- sapi/apache2handler/config.m4 (revision 323592)
+++ sapi/apache2handler/config.m4 (working copy)
@@ -38,7 +38,6 @@
APXS_BINDIR=`$APXS -q BINDIR`
APXS_HTTPD=`$APXS -q SBINDIR`/`$APXS -q TARGET`
APXS_CFLAGS=`$APXS -q CFLAGS`
- APXS_MPM=`$APXS -q MPM_NAME`
APU_BINDIR=`$APXS -q APU_BINDIR`
APR_BINDIR=`$APXS -q APR_BINDIR`
@@ -117,8 +116,16 @@
;;
esac
- if test "$APXS_MPM" != "prefork" && test "$APXS_MPM" != "peruser" && test "$APXS_MPM" != "itk"; then
- PHP_BUILD_THREAD_SAFE
+ if test "$APACHE_VERSION" -lt 2004001; then
+ APXS_MPM=`$APXS -q MPM_NAME`
+ if test "$APXS_MPM" != "prefork" && test "$APXS_MPM" != "peruser" && test "$APXS_MPM" != "itk"; then
+ PHP_BUILD_THREAD_SAFE
+ fi
+ else
+ APACHE_THREADED_MPM=`$APXS_HTTPD -V | grep 'threaded:.*yes'`
+ if test -n "$APACHE_THREADED_MPM"; then
+ PHP_BUILD_THREAD_SAFE
+ fi
fi
AC_MSG_RESULT(yes)
PHP_SUBST(APXS)
Index: sapi/apache2filter/config.m4
===================================================================
--- sapi/apache2filter/config.m4 (revision 323592)
+++ sapi/apache2filter/config.m4 (working copy)
@@ -39,7 +39,6 @@
APXS_BINDIR=`$APXS -q BINDIR`
APXS_HTTPD=`$APXS -q SBINDIR`/`$APXS -q TARGET`
APXS_CFLAGS=`$APXS -q CFLAGS`
- APXS_MPM=`$APXS -q MPM_NAME`
APU_BINDIR=`$APXS -q APU_BINDIR`
APR_BINDIR=`$APXS -q APR_BINDIR`
@@ -118,8 +117,16 @@
;;
esac
- if test "$APXS_MPM" != "prefork" && test "$APXS_MPM" != "peruser"; then
- PHP_BUILD_THREAD_SAFE
+ if test "$APACHE_VERSION" -lt 2004001; then
+ APXS_MPM=`$APXS -q MPM_NAME`
+ if test "$APXS_MPM" != "prefork" && test "$APXS_MPM" != "peruser" && test "$APXS_MPM" != "itk"; then
+ PHP_BUILD_THREAD_SAFE
+ fi
+ else
+ APACHE_THREADED_MPM=`$APXS_HTTPD -V | grep 'threaded:.*yes'`
+ if test -n "$APACHE_THREADED_MPM"; then
+ PHP_BUILD_THREAD_SAFE
+ fi
fi
AC_MSG_RESULT(yes)
PHP_SUBST(APXS)
Index: configure.in
===================================================================
--- configure.in (revision 323592)
+++ configure.in (working copy)
@@ -1550,6 +1550,21 @@
X
fi
+ if test "$PHP_SAPI" = "apache2handler" || test "$PHP_SAPI" = "apache2filter"; then
+ if test "$APACHE_VERSION" -ge 2004001; then
+ if test -z "$APACHE_THREADED_MPM"; then
+cat <<X
++--------------------------------------------------------------------+
+| *** WARNING *** |
+| |
+| You have built PHP for Apache's current non-threaded MPM. |
+| If you change Apache to use a threaded MPM you must reconfigure |
+| PHP with --enable-maintainer-zts |
+X
+ fi
+ fi
+ fi
+
# Warn about linking Apache with libpthread if oci8 extension is enabled on linux.
if test "$PHP_OCI8" != "no"; then
if test "$PHP_SAPI" = "apache"; then

View File

@ -1,70 +0,0 @@
diff -up php-7.2.4/ext/mysqli/mysqli_api.c.omv~ php-7.2.4/ext/mysqli/mysqli_api.c
--- php-7.2.4/ext/mysqli/mysqli_api.c.omv~ 2018-04-06 21:50:05.183703414 +0200
+++ php-7.2.4/ext/mysqli/mysqli_api.c 2018-04-06 21:50:16.436829372 +0200
@@ -616,7 +616,7 @@ PHP_FUNCTION(mysqli_change_user)
size_t user_len, password_len, dbname_len;
zend_ulong rc;
#if !defined(MYSQLI_USE_MYSQLND) && defined(HAVE_MYSQLI_SET_CHARSET)
- const CHARSET_INFO * old_charset;
+ const MY_CHARSET_INFO * old_charset;
#endif
if (zend_parse_method_parameters(ZEND_NUM_ARGS(), getThis(), "Osss!", &mysql_link, mysqli_link_class_entry, &user, &user_len, &password, &password_len, &dbname, &dbname_len) == FAILURE) {
diff -up php-7.2.4/ext/mysqli/mysqli.c.omv~ php-7.2.4/ext/mysqli/mysqli.c
--- php-7.2.4/ext/mysqli/mysqli.c.omv~ 2018-04-06 21:49:41.782434506 +0200
+++ php-7.2.4/ext/mysqli/mysqli.c 2018-04-06 21:49:52.708561249 +0200
@@ -26,6 +26,7 @@
#include <signal.h>
+#include <server/mysql_version.h>
#include "php.h"
#include "php_ini.h"
#include "ext/standard/info.h"
diff -up php-7.2.4/ext/mysqli/mysqli_nonapi.c.omv~ php-7.2.4/ext/mysqli/mysqli_nonapi.c
--- php-7.2.4/ext/mysqli/mysqli_nonapi.c.omv~ 2018-04-06 21:51:43.217399945 +0200
+++ php-7.2.4/ext/mysqli/mysqli_nonapi.c 2018-04-06 21:58:52.799445824 +0200
@@ -263,7 +263,7 @@ void mysqli_common_connect(INTERNAL_FUNC
php_mysqli_set_error(mysql_errno(mysql->mysql), (char *) mysql_error(mysql->mysql));
#if !defined(MYSQLI_USE_MYSQLND)
- mysql->mysql->reconnect = MyG(reconnect);
+/* mysql->mysql->reconnect = MyG(reconnect); */
#endif
mysql_options(mysql->mysql, MYSQL_OPT_LOCAL_INFILE, (char *)&MyG(allow_local_infile));
diff -up php-7.2.4/ext/mysqli/mysqli_prop.c.omv~ php-7.2.4/ext/mysqli/mysqli_prop.c
--- php-7.2.4/ext/mysqli/mysqli_prop.c.omv~ 2018-04-06 21:50:25.687842714 +0200
+++ php-7.2.4/ext/mysqli/mysqli_prop.c 2018-04-06 21:50:35.116768902 +0200
@@ -23,6 +23,7 @@
#include <signal.h>
+#include <server/mysql_version.h>
#include "php.h"
#include "php_ini.h"
#include "ext/standard/info.h"
diff -up php-7.2.4/ext/mysqli/php_mysqli_structs.h.omv~ php-7.2.4/ext/mysqli/php_mysqli_structs.h
--- php-7.2.4/ext/mysqli/php_mysqli_structs.h.omv~ 2018-04-06 21:49:12.161080045 +0200
+++ php-7.2.4/ext/mysqli/php_mysqli_structs.h 2018-04-06 21:58:44.599503172 +0200
@@ -79,11 +79,7 @@
#include <my_sys.h>
#include <mysql.h>
#include <errmsg.h>
-#include <my_list.h>
-#include <m_string.h>
#include <mysqld_error.h>
-#include <my_list.h>
-#include <m_ctype.h>
#include "mysqli_libmysql.h"
#endif /* MYSQLI_USE_MYSQLND */
@@ -326,7 +322,7 @@ ZEND_BEGIN_MODULE_GLOBALS(mysqli)
char *default_user;
char *default_socket;
char *default_pw;
- zend_long reconnect;
+/* zend_long reconnect; */
zend_long allow_local_infile;
zend_long strict;
zend_long error_no;

View File

@ -7,7 +7,7 @@
Name: php
Version: 8.3.9
Release: 1mamba
Release: 2mamba
Summary: The PHP HTML-embedded scripting language
Group: Applications/Development
Vendor: openmamba
@ -18,12 +18,6 @@ Source0: http://it2.php.net/distributions/php-%{version}.tar.xz
Source1: php-httpd-conf
Source2: php-fpm.tmpfiles
Patch0: http://www.hardened-php.net/hardening-patch-%{hardeningp_phpver}-%{hardeningp_ver}.patch.gz
Patch1: %{name}-5.0.5-phpbuilddir.patch
Patch2: %{name}-5.2.5-phpize_dir.patch
Patch3: %{name}-5.2.9-db47.patch
Patch4: %{name}-5.2.11-BID_36555.patch
Patch5: %{name}-5.3.13-apache-2.4.patch
Patch6: php-7.4.6-mariadb-10.4.13.patch
Patch7: php-8.2.4-php-fpm.patch
License: PHP License
## AUTOBUILDREQ-BEGIN
@ -64,6 +58,7 @@ BuildRequires: re2c
BuildRequires: /usr/sbin/sendmail
Requires(pre): libapr >= 1.2.2
Requires(pre): libaprutil >= 1.2.2
Recommends: php-gettext = %{?epoch:%epoch:}%{version}-%{release}
%description
PHP is an HTML-embeddable scripting language.
@ -93,6 +88,18 @@ PHP offers built-in database integration for several commercial and non-commerci
The most common use of PHP coding is probably as a replacement for CGI scripts.
This package contains the FastCGI Process Manager for PHP.
%package gettext
Summary: PHP Gettext extension
Group: System/Servers
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description gettext
PHP is an HTML-embeddable scripting language.
PHP offers built-in database integration for several commercial and non-commercial database management systems, so writing a database-enabled script with PHP is fairly simple.
The most common use of PHP coding is probably as a replacement for CGI scripts.
This package contains the Gettext extension for PHP.
%package imap
Summary: PHP IMAP extension
Group: System/Servers
@ -267,8 +274,6 @@ This package adds PHP support to the Apache Web Server.
%if %with_hardening_patch
%patch 0 -p1 -b .hardening
%endif
#%patch 1 -p1 -b .phpbuilddir
#%patch6 -p1
%patch 7 -p0
# prevent %%doc confusion over LICENSE files
@ -299,7 +304,7 @@ _phpconfig="\
--with-config-file-path=%{_sysconfdir}/php \
--with-config-file-scan-dir=%{_sysconfdir}/php/php.d \
--with-openssl=shared,%{_prefix} \
--with-gettext \
--with-gettext=shared \
--enable-ftp \
--with-ldap=shared,%{_prefix} \
--with-zlib \
@ -528,6 +533,10 @@ fi
%{_datadir}/php/fpm/status.html
%{_mandir}/man8/php-fpm.8*
%files gettext
%defattr(-,root,root)
%{_libdir}/php/extensions/gettext.so
%files imap -f files.imap
%defattr(-,root,root)
@ -570,6 +579,9 @@ fi
%config(noreplace) %{_sysconfdir}/httpd/httpd.d/php.conf
%changelog
* Thu Jul 11 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 8.3.9-2mamba
- build with gettext shared
* Wed Jul 03 2024 Automatic Build System <autodist@openmamba.org> 8.3.9-1mamba
- automatic version update by autodist