update to 7.4.33 [release 7.4.33-1mamba;Mon Jan 15 2024]
This commit is contained in:
parent
501aec6079
commit
777807c378
12
php-7.4.33-openssl-3.patch
Normal file
12
php-7.4.33-openssl-3.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- a/ext/openssl/openssl.c
|
||||
+++ b/ext/openssl/openssl.c
|
||||
@@ -1482,7 +1482,9 @@
|
||||
REGISTER_LONG_CONSTANT("PKCS7_NOSIGS", PKCS7_NOSIGS, CONST_CS|CONST_PERSISTENT);
|
||||
|
||||
REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_PADDING", RSA_PKCS1_PADDING, CONST_CS|CONST_PERSISTENT);
|
||||
+#ifdef RSA_SSLV23_PADDING
|
||||
REGISTER_LONG_CONSTANT("OPENSSL_SSLV23_PADDING", RSA_SSLV23_PADDING, CONST_CS|CONST_PERSISTENT);
|
||||
+#endif
|
||||
REGISTER_LONG_CONSTANT("OPENSSL_NO_PADDING", RSA_NO_PADDING, CONST_CS|CONST_PERSISTENT);
|
||||
REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_OAEP_PADDING", RSA_PKCS1_OAEP_PADDING, CONST_CS|CONST_PERSISTENT);
|
||||
|
55
php.spec
55
php.spec
@ -6,7 +6,7 @@
|
||||
%define with_hardening_patch 0
|
||||
|
||||
Name: php
|
||||
Version: 7.4.23
|
||||
Version: 7.4.33
|
||||
Release: 1mamba
|
||||
Summary: The PHP HTML-embedded scripting language
|
||||
Group: Applications/Development
|
||||
@ -25,68 +25,36 @@ Patch4: %{name}-5.2.11-BID_36555.patch
|
||||
Patch5: %{name}-5.3.13-apache-2.4.patch
|
||||
Patch6: php-7.4.6-mariadb-10.4.13.patch
|
||||
Patch7: php-7.4.23-php-fpm.patch
|
||||
Patch8: php-7.4.33-openssl-3.patch
|
||||
License: PHP License
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
#libdl.so.2()(64bit): /usr/lib64/libdl.so: file not owned by any package
|
||||
#librt.so.1()(64bit): /usr/lib64/librt.so: file not owned by any package
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXpm-devel
|
||||
BuildRequires: libacl-devel
|
||||
BuildRequires: libapparmor-devel
|
||||
BuildRequires: libattr-devel
|
||||
BuildRequires: libbrotli-devel
|
||||
BuildRequires: libbsd-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcares-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libdb53-devel
|
||||
BuildRequires: libe2fs-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgd-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgsasl-devel
|
||||
BuildRequires: libgss-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libidn-devel
|
||||
BuildRequires: libidn2-devel
|
||||
BuildRequires: libimap-c-client-devel
|
||||
BuildRequires: libjbig-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libnghttp2-devel
|
||||
BuildRequires: libntlm-devel
|
||||
BuildRequires: libodbc-devel
|
||||
BuildRequires: libonig-devel
|
||||
BuildRequires: libopenldap-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpam-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpostgresql-devel
|
||||
BuildRequires: libpsl-devel
|
||||
BuildRequires: librtmp-devel
|
||||
BuildRequires: libsasl2-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libssh2-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libsystemd-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libunistring-devel
|
||||
BuildRequires: libwebp-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxcrypt-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libxslt-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzip-devel
|
||||
BuildRequires: libzstd-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: apache-devel
|
||||
BuildRequires: libapr-devel
|
||||
@ -297,14 +265,16 @@ This package adds PHP support to the Apache Web Server.
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -D -T
|
||||
:<< _EOF
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%if %with_hardening_patch
|
||||
%patch0 -p1 -b .hardening
|
||||
%endif
|
||||
%patch1 -p1 -b .phpbuilddir
|
||||
#%patch6 -p1
|
||||
%patch7 -p0
|
||||
%patch 8 -p1 -b .openssl-3
|
||||
|
||||
# phpize dir
|
||||
sed -i "s|@libdir@\`/build|@libdir@\`/php/build|" scripts/phpize.in
|
||||
@ -315,7 +285,7 @@ cp TSRM/LICENSE TSRM_LICENSE
|
||||
#cp ext/gd/libgd/README gd_README
|
||||
|
||||
%build
|
||||
:<< _EOF
|
||||
#:<< _EOF
|
||||
|
||||
EXTENSION_DIR=%{_libdir}/php/extensions
|
||||
export EXTENSION_DIR
|
||||
@ -362,7 +332,7 @@ _phpconfig="\
|
||||
--enable-exif \
|
||||
--enable-intl \
|
||||
--enable-gd \
|
||||
--with-external-gd
|
||||
--with-external-gd=no
|
||||
"
|
||||
|
||||
# FPM
|
||||
@ -385,7 +355,7 @@ cd ..
|
||||
# Apache
|
||||
# reuse the previous run; this will save us a lot of time
|
||||
cp -a build-fpm build-apache
|
||||
_EOF
|
||||
|
||||
cd build-apache
|
||||
|
||||
%ifarch arm aarch64
|
||||
@ -594,6 +564,9 @@ fi
|
||||
%config(noreplace) %{_sysconfdir}/httpd/httpd.d/php.conf
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 7.4.33-1mamba
|
||||
- update to 7.4.33
|
||||
|
||||
* Mon Aug 30 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 7.4.23-1mamba
|
||||
- update to 7.4.23
|
||||
- added php-fpm
|
||||
|
Loading…
Reference in New Issue
Block a user