78 lines
3.0 KiB
RPMSpec
78 lines
3.0 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-XML-SAX-Writer
|
|
Version: 0.54
|
|
Release: 1mamba
|
|
Summary: XML::SAX::Writer - SAX2 Writer
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.cpan.org
|
|
Source: http://search.cpan.org/CPAN/authors/id/P/PE/PERIGRIN/XML-SAX-Writer-%{version}.tar.gz
|
|
License: Artistic, GPL
|
|
Requires: perl >= %perl_major_ver
|
|
Requires: perl-Text-Iconv >= 1.7
|
|
Requires: perl-XML-NamespaceSupport
|
|
Requires: perl-XML-Filter-BufferText
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: perl-devel >= %perl_major_ver
|
|
BuildRequires: perl-Text-Iconv
|
|
BuildRequires: perl-XML-Filter-BufferText
|
|
BuildRequires: perl-XML-NamespaceSupport
|
|
BuildRequires: perl-XML-SAX
|
|
## AUTOBUILDREQ-END
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
A new XML Writer was needed to match the SAX2 effort because quite naturally no existing writer understood SAX2. My first intention had been to start patching XML::Handler::YAWriter as it had previously been my favourite writer in the SAX1 world.
|
|
|
|
However the more I patched it the more I realised that what I thought was going to be a simple patch (mostly adding a few event handlers and changing the attribute syntax) was turning out to be a rewrite due to various ideas I'd been collecting along the way. Besides, I couldn't find a way to elegantly make it work with SAX2 without breaking the SAX1 compatibility which people are probably still using. There are of course ways to do that, but most require user interaction which is something I wanted to avoid.
|
|
|
|
So in the end there was a new writer. I think it's in fact better this way as it helps keep SAX1 and SAX2 separated.
|
|
|
|
%prep
|
|
|
|
%setup -q -n XML-SAX-Writer-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Tue Dec 17 2013 Automatic Build System <autodist@mambasoft.it> 0.54-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Apr 28 2013 Automatic Build System <autodist@mambasoft.it> 0.53-1mamba
|
|
- update to 0.53
|
|
|
|
* Tue Nov 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.50-3mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Thu Nov 06 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.50-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Mon Sep 15 2008 gil <puntogil@libero.it> 0.50-1mamba
|
|
- package created by autospec
|