rebuilt with perl 5.24 [release 4.17-2mamba;Wed Nov 09 2016]

This commit is contained in:
Silvan Calarco 2024-01-06 09:52:43 +01:00
parent 83a2556627
commit cb3619d2ef
2 changed files with 45 additions and 1 deletions

View File

@ -0,0 +1,34 @@
From 0be0223422e6e5f4091c6e4e058d213623eed105 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Mon, 12 Sep 2016 14:40:44 +0200
Subject: [PATCH] Skip preprocessor symbol only CURL_STRICTER
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
CURL_STRICTER leaked into curl-constants.c when building against
curl-7.50.2. This is a preprocessor only macro without a value.
CPAN RT#117793
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Makefile.PL | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.PL b/Makefile.PL
index f9170bb..ad2bd3d 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -127,7 +127,7 @@ if (!defined($curl_h)) {
close H;
for my $e (sort @syms) {
- if($e =~ /(OBSOLETE|^CURL_EXTERN|_LAST\z|_LASTENTRY\z)/) {
+ if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_STRICTER\z|_LAST\z|_LASTENTRY\z)/) {
next;
}
my ($group) = $e =~ m/^([^_]+_)/;
--
2.7.4

View File

@ -2,7 +2,7 @@
Name: perl-WWW-Curl Name: perl-WWW-Curl
Version: 4.17 Version: 4.17
Release: 1mamba Release: 2mamba
Summary: WWW - Perl extension interface for libcurl Summary: WWW - Perl extension interface for libcurl
Group: System/Libraries/Perl Group: System/Libraries/Perl
Vendor: openmamba Vendor: openmamba
@ -10,7 +10,13 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it> Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.cpan.org URL: http://www.cpan.org
Source: http://search.cpan.org/CPAN/authors/id/S/SZ/SZBALINT/WWW-Curl-%{version}.tar.gz Source: http://search.cpan.org/CPAN/authors/id/S/SZ/SZBALINT/WWW-Curl-%{version}.tar.gz
Patch0: perl-WWW-Curl-4.17-gcc-6.2.patch
License: MPL, MIT License: MPL, MIT
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libcurl-devel
BuildRequires: perl-devel
## AUTOBUILDREQ-END
Requires: perl >= %perl_major_ver Requires: perl >= %perl_major_ver
BuildRequires: perl-devel >= %perl_major_ver BuildRequires: perl-devel >= %perl_major_ver
BuildRoot: %{_tmppath}/%{name}-%{version}-root BuildRoot: %{_tmppath}/%{name}-%{version}-root
@ -20,6 +26,7 @@ WWW - Perl extension interface for libcurl.
%prep %prep
%setup -q -n WWW-Curl-%{version} %setup -q -n WWW-Curl-%{version}
%patch0 -p1
%build %build
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
@ -53,6 +60,9 @@ rm -f .packlist
%defattr(-,root,root) %defattr(-,root,root)
%changelog %changelog
* Wed Nov 09 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.17-2mamba
- rebuilt with perl 5.24
* Sat Feb 22 2014 Automatic Build System <autodist@mambasoft.it> 4.17-1mamba * Sat Feb 22 2014 Automatic Build System <autodist@mambasoft.it> 4.17-1mamba
- automatic update by autodist - automatic update by autodist