added patch for curl 7.73.0 [release 4.17-3mamba;Mon Dec 07 2020]

This commit is contained in:
Silvan Calarco 2024-01-06 09:52:43 +01:00
parent cb3619d2ef
commit 9bbabb5d79
2 changed files with 31 additions and 2 deletions

View File

@ -0,0 +1,24 @@
--- a/Curl.xs 2014-02-21 11:08:30.000000000 -0500
+++ b/Curl.xs 2020-06-25 09:36:37.868826340 -0400
@@ -18,6 +18,10 @@
#include <curl/easy.h>
#include <curl/multi.h>
+#if defined(CURLINC_MULTI_H) && !defined(__CURL_MULTI_H)
+# define __CURL_MULTI_H
+#endif
+
#define header_callback_func writeheader_callback_func
/* Do a favor for older perl versions */
--- a/Makefile.PL 2014-02-21 11:08:09.000000000 -0500
+++ b/Makefile.PL 2020-06-25 09:24:50.549812170 -0400
@@ -127,7 +127,7 @@
close H;
for my $e (sort @syms) {
- if($e =~ /(OBSOLETE|^CURL_EXTERN|_LAST\z|_LASTENTRY\z)/) {
+ if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_WIN32\z|^CURLOPT\z|^CURL_STRICTER\z|^CURL_DID_MEMORY_FUNC_TYPEDEFS\z|_LAST\z|_LASTENTRY\z)/) {
next;
}
my ($group) = $e =~ m/^([^_]+_)/;

View File

@ -2,7 +2,7 @@
Name: perl-WWW-Curl Name: perl-WWW-Curl
Version: 4.17 Version: 4.17
Release: 2mamba Release: 3mamba
Summary: WWW - Perl extension interface for libcurl Summary: WWW - Perl extension interface for libcurl
Group: System/Libraries/Perl Group: System/Libraries/Perl
Vendor: openmamba Vendor: openmamba
@ -11,6 +11,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.cpan.org URL: http://www.cpan.org
Source: http://search.cpan.org/CPAN/authors/id/S/SZ/SZBALINT/WWW-Curl-%{version}.tar.gz Source: http://search.cpan.org/CPAN/authors/id/S/SZ/SZBALINT/WWW-Curl-%{version}.tar.gz
Patch0: perl-WWW-Curl-4.17-gcc-6.2.patch Patch0: perl-WWW-Curl-4.17-gcc-6.2.patch
Patch1: perl-WWW-Curl-4.17-curl-7.73.0.patch
License: MPL, MIT License: MPL, MIT
## AUTOBUILDREQ-BEGIN ## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel BuildRequires: glibc-devel
@ -26,7 +27,8 @@ WWW - Perl extension interface for libcurl.
%prep %prep
%setup -q -n WWW-Curl-%{version} %setup -q -n WWW-Curl-%{version}
%patch0 -p1 #%patch0 -p1
%patch1 -p1
%build %build
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
@ -60,6 +62,9 @@ rm -f .packlist
%defattr(-,root,root) %defattr(-,root,root)
%changelog %changelog
* Mon Dec 07 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.17-3mamba
- added patch for curl 7.73.0
* Wed Nov 09 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.17-2mamba * Wed Nov 09 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.17-2mamba
- rebuilt with perl 5.24 - rebuilt with perl 5.24