automatic update by autodist [release 0.98.11_01-1mamba;Wed Jan 13 2010]
This commit is contained in:
parent
4d8d1a9181
commit
373ee9db77
@ -1,2 +1,6 @@
|
|||||||
# perl-Video-DVDRip
|
# perl-Video-DVDRip
|
||||||
|
|
||||||
|
dvd::rip is a full featured DVD copy program written in Perl. It provides an easy to use but feature-rich Gtk+ GUI to control almost all aspects of the ripping and transcoding process. It uses the widely known video processing swissknife transcode and many other Open Source tools. dvd::rip itself is licensed under GPL / Perl Artistic License.
|
||||||
|
|
||||||
|
"And note: it's spelled dvd::rip, and nothing else."
|
||||||
|
|
||||||
|
12
perl-Video-DVDRip-0.52.5-noNPTL.patch
Normal file
12
perl-Video-DVDRip-0.52.5-noNPTL.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru Video-DVDRip-0.52.5.orig/lib/Video/DVDRip/Config.pm Video-DVDRip-0.52.5/lib/Video/DVDRip/Config.pm
|
||||||
|
--- Video-DVDRip-0.52.5.orig/lib/Video/DVDRip/Config.pm 2005-07-01 16:35:27.000000000 +0200
|
||||||
|
+++ Video-DVDRip-0.52.5/lib/Video/DVDRip/Config.pm 2005-07-01 16:36:34.000000000 +0200
|
||||||
|
@@ -306,7 +306,7 @@
|
||||||
|
workaround_nptl_bugs => {
|
||||||
|
label => __"Workaround transcode NPTL bugs",
|
||||||
|
type => 'switch',
|
||||||
|
- value => 1,
|
||||||
|
+ value => 0,
|
||||||
|
},
|
||||||
|
);
|
||||||
|
|
19
perl-Video-DVDRip-0.98.9-desktop.patch
Normal file
19
perl-Video-DVDRip-0.98.9-desktop.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
--- dvdrip-0.98.9/dvdrip.desktop 2007-04-28 09:59:37.000000000 +0200
|
||||||
|
+++ dvdrip-0.98.9/dvdrip.desktop-gil 2008-10-20 20:20:40.000000000 +0200
|
||||||
|
@@ -3,8 +3,11 @@
|
||||||
|
Encoding=UTF-8
|
||||||
|
Name=dvd::rip
|
||||||
|
GenericName=DVD copy program
|
||||||
|
-Comment=A full featured DVD copy program
|
||||||
|
+GenericName[it]=Programma per copiare DVD
|
||||||
|
+Comment=A full featured DVD copy program written in perl
|
||||||
|
+Comment[it]=Il programma di ripper per i DVD scritto in perl
|
||||||
|
+Exec=/usr/bin/dvdrip
|
||||||
|
Type=Application
|
||||||
|
-Exec=dvdrip
|
||||||
|
-Icon=dvdrip
|
||||||
|
-Categories=AudioVideo;Video;
|
||||||
|
+Terminal=0
|
||||||
|
+Icon=/usr/lib/perl5/vendor_perl/5.8.8/Video/DVDRip/icon.xpm
|
||||||
|
+Categories=AudioVideo;Video;
|
||||||
|
\ No newline at end of file
|
11
perl-Video-DVDRip-0.98.9-use_POSIX.patch
Normal file
11
perl-Video-DVDRip-0.98.9-use_POSIX.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -Nru dvdrip-0.98.9.orig/lib/Video/DVDRip/Config.pm dvdrip-0.98.9/lib/Video/DVDRip/Config.pm
|
||||||
|
--- dvdrip-0.98.9.orig/lib/Video/DVDRip/Config.pm 2008-10-01 12:02:39.000000000 +0200
|
||||||
|
+++ dvdrip-0.98.9/lib/Video/DVDRip/Config.pm 2008-11-09 15:58:36.000000000 +0100
|
||||||
|
@@ -19,6 +19,7 @@
|
||||||
|
use FileHandle;
|
||||||
|
use Data::Dumper;
|
||||||
|
use Carp;
|
||||||
|
+use POSIX;
|
||||||
|
|
||||||
|
sub config { shift->{config} }
|
||||||
|
|
105
perl-Video-DVDRip-packagenames.patch
Normal file
105
perl-Video-DVDRip-packagenames.patch
Normal file
@ -0,0 +1,105 @@
|
|||||||
|
diff -Nru Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/CheckedEntry.pm Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/CheckedEntry.pm
|
||||||
|
--- Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/CheckedEntry.pm 2004-10-07 17:09:59.000000000 +0200
|
||||||
|
+++ Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/CheckedEntry.pm 2004-10-07 17:13:07.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-package Video::DVDRip::CheckedEntry;
|
||||||
|
+package Video::DVDRip::GUI::CheckedEntry;
|
||||||
|
|
||||||
|
# use strict;
|
||||||
|
|
||||||
|
diff -Nru Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/BurnTab.pm Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/BurnTab.pm
|
||||||
|
--- Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/BurnTab.pm 2004-10-07 17:09:59.000000000 +0200
|
||||||
|
+++ Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/BurnTab.pm 2004-10-07 17:12:46.000000000 +0200
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
# redistribute it and/or modify it under the same terms as Perl itself.
|
||||||
|
#-----------------------------------------------------------------------
|
||||||
|
|
||||||
|
-package Video::DVDRip::GUI::Project;
|
||||||
|
+package Video::DVDRip::GUI::Project::BurnTab;
|
||||||
|
|
||||||
|
use Carp;
|
||||||
|
use strict;
|
||||||
|
diff -Nru Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/ClipZoomTab.pm Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/ClipZoomTab.pm
|
||||||
|
--- Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/ClipZoomTab.pm 2004-10-07 17:09:59.000000000 +0200
|
||||||
|
+++ Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/ClipZoomTab.pm 2004-10-07 17:12:46.000000000 +0200
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
# redistribute it and/or modify it under the same terms as Perl itself.
|
||||||
|
#-----------------------------------------------------------------------
|
||||||
|
|
||||||
|
-package Video::DVDRip::GUI::Project;
|
||||||
|
+package Video::DVDRip::GUI::Project::ClipZoomTab;
|
||||||
|
|
||||||
|
use Carp;
|
||||||
|
use strict;
|
||||||
|
diff -Nru Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/LoggingTab.pm Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/LoggingTab.pm
|
||||||
|
--- Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/LoggingTab.pm 2004-10-07 17:09:59.000000000 +0200
|
||||||
|
+++ Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/LoggingTab.pm 2004-10-07 17:12:46.000000000 +0200
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
# redistribute it and/or modify it under the same terms as Perl itself.
|
||||||
|
#-----------------------------------------------------------------------
|
||||||
|
|
||||||
|
-package Video::DVDRip::GUI::Project;
|
||||||
|
+package Video::DVDRip::GUI::Project::LoggingTab;
|
||||||
|
|
||||||
|
use Video::DVDRip::GUI::Logger;
|
||||||
|
|
||||||
|
diff -Nru Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/StorageTab.pm Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/StorageTab.pm
|
||||||
|
--- Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/StorageTab.pm 2004-10-07 17:09:59.000000000 +0200
|
||||||
|
+++ Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/StorageTab.pm 2004-10-07 17:12:46.000000000 +0200
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
# redistribute it and/or modify it under the same terms as Perl itself.
|
||||||
|
#-----------------------------------------------------------------------
|
||||||
|
|
||||||
|
-package Video::DVDRip::GUI::Project;
|
||||||
|
+package Video::DVDRip::GUI::Project::StorageTab;
|
||||||
|
|
||||||
|
use Carp;
|
||||||
|
use strict;
|
||||||
|
diff -Nru Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/SubtitleTab.pm Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/SubtitleTab.pm
|
||||||
|
--- Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/SubtitleTab.pm 2004-10-07 17:09:59.000000000 +0200
|
||||||
|
+++ Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/SubtitleTab.pm 2004-10-07 17:12:46.000000000 +0200
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
# redistribute it and/or modify it under the same terms as Perl itself.
|
||||||
|
#-----------------------------------------------------------------------
|
||||||
|
|
||||||
|
-package Video::DVDRip::GUI::Project;
|
||||||
|
+package Video::DVDRip::GUI::Project::SubtitleTab;
|
||||||
|
|
||||||
|
use Carp;
|
||||||
|
use strict;
|
||||||
|
diff -Nru Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/TitleTab.pm Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/TitleTab.pm
|
||||||
|
--- Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/TitleTab.pm 2004-10-07 17:09:59.000000000 +0200
|
||||||
|
+++ Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/TitleTab.pm 2004-10-07 17:12:46.000000000 +0200
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
# redistribute it and/or modify it under the same terms as Perl itself.
|
||||||
|
#-----------------------------------------------------------------------
|
||||||
|
|
||||||
|
-package Video::DVDRip::GUI::Project;
|
||||||
|
+package Video::DVDRip::GUI::Project::TitleTab;
|
||||||
|
|
||||||
|
use Carp;
|
||||||
|
use strict;
|
||||||
|
diff -Nru Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/TranscodeTabAudio.pm Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/TranscodeTabAudio.pm
|
||||||
|
--- Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/TranscodeTabAudio.pm 2004-10-07 17:09:59.000000000 +0200
|
||||||
|
+++ Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/TranscodeTabAudio.pm 2004-10-07 17:12:46.000000000 +0200
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
# redistribute it and/or modify it under the same terms as Perl itself.
|
||||||
|
#-----------------------------------------------------------------------
|
||||||
|
|
||||||
|
-package Video::DVDRip::GUI::Project;
|
||||||
|
+package Video::DVDRip::GUI::Project::TranscodeTabAudio;
|
||||||
|
|
||||||
|
use Carp;
|
||||||
|
use strict;
|
||||||
|
diff -Nru Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/TranscodeTab.pm Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/TranscodeTab.pm
|
||||||
|
--- Video-DVDRip-0.50.18.orig/lib/Video/DVDRip/GUI/Project/TranscodeTab.pm 2004-10-07 17:09:59.000000000 +0200
|
||||||
|
+++ Video-DVDRip-0.50.18/lib/Video/DVDRip/GUI/Project/TranscodeTab.pm 2004-10-07 17:12:46.000000000 +0200
|
||||||
|
@@ -8,7 +8,7 @@
|
||||||
|
# redistribute it and/or modify it under the same terms as Perl itself.
|
||||||
|
#-----------------------------------------------------------------------
|
||||||
|
|
||||||
|
-package Video::DVDRip::GUI::Project;
|
||||||
|
+package Video::DVDRip::GUI::Project::TranscodeTab;
|
||||||
|
|
||||||
|
use Video::DVDRip::GUI::MinSizeGroup;
|
||||||
|
use Video::DVDRip::GUI::Project::TranscodeTabAudio;
|
134
perl-Video-DVDRip.spec
Normal file
134
perl-Video-DVDRip.spec
Normal file
@ -0,0 +1,134 @@
|
|||||||
|
%define PERL_VERSION %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
||||||
|
|
||||||
|
|
||||||
|
Name: perl-Video-DVDRip
|
||||||
|
Version: 0.98.11_01
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Full featured DVD copy program written in Perl.
|
||||||
|
Group: Development/Libraries/Perl
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.exit1.org/dvdrip/
|
||||||
|
Source: http://www.exit1.org/dvdrip/dist/dvdrip-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-packagenames.patch
|
||||||
|
Patch1: %{name}-0.52.5-noNPTL.patch
|
||||||
|
Patch2: %{name}-0.98.9-desktop.patch
|
||||||
|
Patch3: %{name}-0.98.9-use_POSIX.patch
|
||||||
|
License: Artistic
|
||||||
|
Requires: xine-ui
|
||||||
|
BuildRequires: perl-AnyEvent
|
||||||
|
BuildRequires: perl-Glib
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: perl-devel
|
||||||
|
BuildRequires: perl-Event
|
||||||
|
BuildRequires: perl-Event-ExecFlow
|
||||||
|
BuildRequires: perl-Event-RPC
|
||||||
|
BuildRequires: perl-Gtk2
|
||||||
|
BuildRequires: perl-Gtk2-Ex-FormFactory
|
||||||
|
BuildRequires: perl-libintl
|
||||||
|
BuildRequires: xine-ui
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
%description
|
||||||
|
dvd::rip is a full featured DVD copy program written in Perl. It provides an easy to use but feature-rich Gtk+ GUI to control almost all aspects of the ripping and transcoding process. It uses the widely known video processing swissknife transcode and many other Open Source tools. dvd::rip itself is licensed under GPL / Perl Artistic License.
|
||||||
|
|
||||||
|
"And note: it's spelled dvd::rip, and nothing else."
|
||||||
|
|
||||||
|
%prep
|
||||||
|
|
||||||
|
%setup -q -n dvdrip-%{version}
|
||||||
|
#%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
|
||||||
|
%define __find_provides %{_builddir}/dvdrip-%{version}/find_provides.sh
|
||||||
|
cat > find_provides.sh << _EOF
|
||||||
|
#! /bin/sh
|
||||||
|
|
||||||
|
grep -v %{buildroot}%{_libdir}/OpenOffice/program/|\
|
||||||
|
%{_prefix}/lib/rpm/find-provides %{buildroot} %{_target_cpu}
|
||||||
|
echo "perl(Video::DVDRip::GUI::CheckedEntry)"
|
||||||
|
echo "perl(Video::DVDRip::GUI::Project::BurnTab)"
|
||||||
|
echo "perl(Video::DVDRip::GUI::Project::ClipZoomTab)"
|
||||||
|
echo "perl(Video::DVDRip::GUI::Project::StorageTab)"
|
||||||
|
echo "perl(Video::DVDRip::GUI::Project::SubtitleTab)"
|
||||||
|
echo "perl(Video::DVDRip::GUI::Project::TitleTab)"
|
||||||
|
echo "perl(Video::DVDRip::GUI::Project::TranscodeTab)"
|
||||||
|
echo "perl(Video::DVDRip::GUI::Project::TranscodeTabAudio)"
|
||||||
|
echo "perl(Video::DVDRip::GUI::Project::LoggingTab)"
|
||||||
|
_EOF
|
||||||
|
|
||||||
|
chmod +x %{_builddir}/dvdrip-%{version}/find_provides.sh
|
||||||
|
|
||||||
|
%build
|
||||||
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
||||||
|
%make
|
||||||
|
#FIXME text fail
|
||||||
|
#%make test
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall_perl
|
||||||
|
packlist=`find %{buildroot} -name .packlist`
|
||||||
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
||||||
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
||||||
|
sort -u > .packlist && rm $packlist
|
||||||
|
|
||||||
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
||||||
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
||||||
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
||||||
|
done
|
||||||
|
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/applications
|
||||||
|
install -m 644 dvdrip.desktop %{buildroot}%{_datadir}/applications/DVD-Rip.desktop
|
||||||
|
|
||||||
|
%clean
|
||||||
|
test x"%buildroot" != x/ && rm -rf "%buildroot"
|
||||||
|
rm -f .packlist
|
||||||
|
|
||||||
|
%files -f .packlist
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_datadir}/applications/DVD-Rip.desktop
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Jan 13 2010 Automatic Build System <autodist@mambasoft.it> 0.98.11_01-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Mar 10 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.98.10-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sun Nov 09 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.98.9-3mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Oct 20 2008 gil <puntogil@libero.it> 0.98.9-2mamba
|
||||||
|
- added desktop patch
|
||||||
|
|
||||||
|
* Mon Oct 20 2008 gil <puntogil@libero.it> 0.98.9-1mamba
|
||||||
|
- update to 0.98.9
|
||||||
|
|
||||||
|
* Fri Jul 01 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.52.5-2qilnx
|
||||||
|
- added noNTPL patch to disable an NPTL workaround enabled by default
|
||||||
|
|
||||||
|
* Thu Jun 30 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.52.5-1qilnx
|
||||||
|
- update to version 0.52.5 by autospec
|
||||||
|
|
||||||
|
* Tue Oct 19 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.50.18-6qilnx
|
||||||
|
- xine requirement changed to xine-ui
|
||||||
|
|
||||||
|
* Fri Oct 08 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.50.18-5qilnx
|
||||||
|
- added another missing provide
|
||||||
|
|
||||||
|
* Fri Oct 08 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.50.18-4qilnx
|
||||||
|
- remove patch and fix requirements problems
|
||||||
|
|
||||||
|
* Thu Oct 07 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.50.18-3qilnx
|
||||||
|
- added requirements for xine
|
||||||
|
|
||||||
|
* Thu Oct 07 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.50.18-2qilnx
|
||||||
|
- rebuilt, renamed and moved from devel-contrib to devel
|
||||||
|
|
||||||
|
* Thu Sep 23 2004 Matteo Bernasconi <voyagernm@virgilio.it> 0.50.18-1qilnx
|
||||||
|
- First Build
|
||||||
|
|
Loading…
Reference in New Issue
Block a user