67 lines
2.4 KiB
RPMSpec
67 lines
2.4 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Unicode-Stringprep
|
|
Version: 1.105
|
|
Release: 1mamba
|
|
Summary: Unicode::Stringprep - Preparation of Internationalized Strings (RFC 3454)
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.cpan.org
|
|
Source: http://search.cpan.org/CPAN/authors/id/C/CF/CFAERBER/Unicode-Stringprep-%{version}.tar.gz
|
|
License: Artistic, GPL
|
|
Requires: perl >= %perl_major_ver
|
|
BuildRequires: perl-devel >= %perl_major_ver
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
This module implements the stringprep framework for preparing Unicode text strings in order to increase the likelihood that string input and string comparison work in ways that make sense for typical users throughout the world. The stringprep protocol is useful for protocol identifier values, company and personal names, internationalized domain names, and other text strings.
|
|
|
|
The stringprep framework does not specify how protocols should prepare text strings. Protocols must create profiles of stringprep in order to fully specify the processing options.
|
|
|
|
%prep
|
|
|
|
%setup -q -n Unicode-Stringprep-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Wed Oct 01 2014 Automatic Build System <autodist@mambasoft.it> 1.105-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sun Apr 28 2013 Automatic Build System <autodist@mambasoft.it> 1.104-1mamba
|
|
- update to 1.104
|
|
|
|
* Tue Nov 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.00-3mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.00-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Mon Oct 20 2008 gil <puntogil@libero.it> 1.00-1mamba
|
|
- package created by autospec
|