diff --git a/README.md b/README.md
index 2e6f1da..a72df6b 100644
--- a/README.md
+++ b/README.md
@@ -1,2 +1,7 @@
# perl-Unicode-EastAsianWidth
+This module provide user-defined Unicode properties that deal with East Asian characters' width status, as specified in .
+It exports the following functions to the caller's scope, to be used by Perl's Unicode matching system: "InEastAsianFullwidth", "InEastAsianHalfwidth", "InEastAsianAmbiguous", "InEastAsianNarrow" "InEastAsianWide", "InEastAsianNeutral".
+In accord to TR11 cited above, two additional context-sensitive properties are exported: "InFullwidth" (union of "Fullwidth" and "Wide") and "InHalfwidth" (union of "Halfwidth", "Narrow" and "Neutral").
+*Ambiguous* characters are treated by default as part of "InHalfwidth", but you can modify this behaviour by assigning a true value to $Unicode::EastAsianWidth::EastAsian.
+
diff --git a/perl-Unicode-EastAsianWidth.spec b/perl-Unicode-EastAsianWidth.spec
new file mode 100644
index 0000000..7f4ce72
--- /dev/null
+++ b/perl-Unicode-EastAsianWidth.spec
@@ -0,0 +1,61 @@
+%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
+
+Name: perl-Unicode-EastAsianWidth
+Version: 1.33
+Release: 1mamba
+Summary: Unicode::EastAsianWidth - East Asian Width properties
+Group: System/Libraries/Perl
+Vendor: openmamba
+Distribution: openmamba
+Packager: Silvan Calarco
+URL: http://www.cpan.org
+Source: http://search.cpan.org/CPAN/authors/id/A/AU/AUDREYT/Unicode-EastAsianWidth-%{version}.tar.gz
+License: MIT
+Requires: perl >= %perl_major_ver
+## AUTOBUILDREQ-BEGIN
+BuildRequires: perl-devel
+## AUTOBUILDREQ-END
+BuildRequires: perl-devel >= %perl_major_ver
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
+
+%description
+This module provide user-defined Unicode properties that deal with East Asian characters' width status, as specified in .
+It exports the following functions to the caller's scope, to be used by Perl's Unicode matching system: "InEastAsianFullwidth", "InEastAsianHalfwidth", "InEastAsianAmbiguous", "InEastAsianNarrow" "InEastAsianWide", "InEastAsianNeutral".
+In accord to TR11 cited above, two additional context-sensitive properties are exported: "InFullwidth" (union of "Fullwidth" and "Wide") and "InHalfwidth" (union of "Halfwidth", "Narrow" and "Neutral").
+*Ambiguous* characters are treated by default as part of "InHalfwidth", but you can modify this behaviour by assigning a true value to $Unicode::EastAsianWidth::EastAsian.
+
+%prep
+
+%setup -q -n Unicode-EastAsianWidth-%{version}
+
+%build
+perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
+%make
+%make test
+
+%install
+[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
+%makeinstall_perl
+packlist=`find %{buildroot} -name .packlist`
+[ -z "$packlist" ] && exit 1 || cat $packlist | \
+ sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
+ sort -u > .packlist && rm $packlist
+
+strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
+for dir in `find %{buildroot} -type d | grep $strid`; do
+ echo "%dir ${dir#%buildroot}" >> .packlist
+done
+
+%clean
+[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
+rm -f .packlist
+
+%files -f .packlist
+%defattr(-,root,root)
+
+%changelog
+* Fri Feb 22 2013 Silvan Calarco 1.33-1mamba
+- update to 1.33
+
+* Sat Oct 23 2010 gil 1.30-1mamba
+- package created by autospec