75 lines
2.2 KiB
RPMSpec
75 lines
2.2 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Test-PerlTidy
|
|
Version: 20230226
|
|
Release: 1mamba
|
|
Summary: Check that all your files are tidy
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org
|
|
Source: https://cpan.metacpan.org/modules/by-module/Test/Test-PerlTidy-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-Path-Tiny
|
|
BuildRequires: perl-Perl-Tidy
|
|
BuildRequires: perl-Test-Simple
|
|
BuildRequires: perl-Text-Diff
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl-devel
|
|
Requires: perl >= %perl_major_ver
|
|
|
|
%description
|
|
Check that all your files are tidy.
|
|
|
|
%prep
|
|
%setup -q -n Test-PerlTidy-%{version}
|
|
|
|
%build
|
|
%{__perl} Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
|
|
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm -f $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
## note: eventually add the remaining documents (if any)
|
|
# %doc CHANGES README
|
|
|
|
%changelog
|
|
* Sun Feb 26 2023 Automatic Build System <autodist@mambasoft.it> 20230226-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 02 2022 Automatic Build System <autodist@mambasoft.it> 20220902-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 09 2021 Automatic Build System <autodist@mambasoft.it> 20210709-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Feb 24 2021 Automatic Build System <autodist@mambasoft.it> 20200930-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Dec 14 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 20130104-1mamba
|
|
- package created using the webbuild interface
|