perl-Test-NoTabs/perl-Test-NoTabs.spec

60 lines
1.7 KiB
RPMSpec

%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
Name: perl-Test-NoTabs
Version: 2.02
Release: 2mamba
Summary: Test::NoTabs - Check the presence of tabs in your project
Group: System/Libraries/Perl
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://www.cpan.org
Source: https://cpan.metacpan.org/authors/id/E/ET/ETHER/Test-NoTabs-%{version}.tar.gz
License: GPL, Artistic
## AUTOBUILDREQ-BEGIN
BuildRequires: libperl
BuildRequires: perl-devel
## AUTOBUILDREQ-END
BuildRequires: perl >= 2:5.36.0
Requires: perl >= %perl_major_ver
%description
Test::NoTabs - Check the presence of tabs in your project.
%prep
%setup -q -n Test-NoTabs-%{version}
%build
%{__perl} Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
%make
%make test
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall_perl
packlist=`find %{buildroot} -name .packlist`
[ -z "$packlist" ] && exit 1 || cat $packlist | \
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
sort -u > .packlist && rm -f $packlist
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
for dir in `find %{buildroot} -type d | grep $strid`; do
echo "%dir ${dir#%buildroot}" >> .packlist
done
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f .packlist
%defattr(-,root,root)
%doc LICENSE
%changelog
* Mon Apr 17 2023 Sdk Build System <sdk@mambasoft.it> 2.02-2mamba
- rebuilt with perl 5.36.0
* Fri Feb 03 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.02-1mamba
- package created using the webbuild interface