66 lines
1.9 KiB
RPMSpec
66 lines
1.9 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Test-Needs
|
|
Version: 0.002010
|
|
Release: 2mamba
|
|
Summary: Test::Needs - Skip tests when modules not available
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org/
|
|
Source: https://cpan.metacpan.org/modules/by-module/Test/Test-Needs-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl >= 2:5.36.0
|
|
BuildRequires: perl-devel
|
|
Requires: perl >= %perl_major_ver
|
|
|
|
%description
|
|
Test::Needs - Skip tests when modules not available.
|
|
|
|
%prep
|
|
%setup -q -n Test-Needs-%{version}
|
|
|
|
%build
|
|
%{__perl} Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
|
|
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm -f $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
%doc LICENSE
|
|
|
|
%changelog
|
|
* Mon Apr 17 2023 Sdk Build System <sdk@mambasoft.it> 0.002010-2mamba
|
|
- rebuilt with perl 5.36.0
|
|
|
|
* Mon Jan 23 2023 Automatic Build System <autodist@mambasoft.it> 0.002010-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 25 2021 Automatic Build System <autodist@mambasoft.it> 0.002009-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Feb 01 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.002006-1mamba
|
|
- package created using the webbuild interface
|