perl 5.16 mass rebuild [release 1.4-3mamba;Tue Nov 13 2012]
This commit is contained in:
parent
dad52d36b4
commit
cf38531655
@ -1,2 +1,4 @@
|
|||||||
# perl-Sys-Hostname-Long
|
# perl-Sys-Hostname-Long
|
||||||
|
|
||||||
|
Sys::Hostname::Long - Try every conceivable way to get full hostname.
|
||||||
|
|
||||||
|
53
perl-Sys-Hostname-Long-no_win32.patch
Normal file
53
perl-Sys-Hostname-Long-no_win32.patch
Normal file
@ -0,0 +1,53 @@
|
|||||||
|
diff -Nru Sys-Hostname-Long-1.4.orig/lib/Sys/Hostname/Long.pm Sys-Hostname-Long-1.4/lib/Sys/Hostname/Long.pm
|
||||||
|
--- Sys-Hostname-Long-1.4.orig/lib/Sys/Hostname/Long.pm 2005-06-26 00:34:10.000000000 +0200
|
||||||
|
+++ Sys-Hostname-Long-1.4/lib/Sys/Hostname/Long.pm 2007-05-09 12:11:41.000000000 +0200
|
||||||
|
@@ -33,17 +33,6 @@
|
||||||
|
},
|
||||||
|
},
|
||||||
|
|
||||||
|
- 'win32_registry1' => {
|
||||||
|
- 'title' => 'WIN32 Registry',
|
||||||
|
- 'description' => 'LMachine/System/CurrentControlSet/Service/VxD/MSTCP/Domain',
|
||||||
|
- 'exec' => sub {
|
||||||
|
- return eval q{
|
||||||
|
- use Win32::TieRegistry ( TiedHash => '%RegistryHash' );
|
||||||
|
- $RegistryHash{'LMachine'}{'System'}{'CurrentControlSet'}{'Services'}{'VxD'}{'MSTCP'}{'Domain'};
|
||||||
|
- };
|
||||||
|
- },
|
||||||
|
- },
|
||||||
|
-
|
||||||
|
'uname' => {
|
||||||
|
'title' => 'POSIX::unae',
|
||||||
|
'description' => '',
|
||||||
|
@@ -56,18 +45,6 @@
|
||||||
|
},
|
||||||
|
},
|
||||||
|
|
||||||
|
- # XXX This is the same as above - what happened to the other one !!!
|
||||||
|
- 'win32_registry2' => {
|
||||||
|
- 'title' => 'WIN32 Registry',
|
||||||
|
- 'description' => 'LMachine/System/CurrentControlSet/Services/VxD/MSTCP/Domain',
|
||||||
|
- 'exec' => sub {
|
||||||
|
- return eval q{
|
||||||
|
- use Win32::TieRegistry ( TiedHash => '%RegistryHash' );
|
||||||
|
- $RegistryHash{'LMachine'}{'System'}{'CurrentControlSet'}{'Services'}{'VxD'}{'MSTCP'}{'Domain'};
|
||||||
|
- };
|
||||||
|
- },
|
||||||
|
- },
|
||||||
|
-
|
||||||
|
'exec_hostname_fqdn' => {
|
||||||
|
'title' => 'Execute "hostname --fqdn"',
|
||||||
|
'description' => '',
|
||||||
|
@@ -171,12 +148,6 @@
|
||||||
|
} elsif ($^O eq 'IRIX') { # XXX Patter match string !
|
||||||
|
$hostlong = dispatcher('exec_hostname');
|
||||||
|
|
||||||
|
- } elsif ($^O eq 'cygwin') {
|
||||||
|
- $hostlong = dispatcher('win32_registry1');
|
||||||
|
-
|
||||||
|
- } elsif ($^O eq 'MSWin32') {
|
||||||
|
- $hostlong = dispatcher('win32_registry2');
|
||||||
|
-
|
||||||
|
} elsif ($^O =~ m/(bsd|nto)/i) {
|
||||||
|
$hostlong = dispatcher('exec_hostname');
|
||||||
|
|
59
perl-Sys-Hostname-Long.spec
Normal file
59
perl-Sys-Hostname-Long.spec
Normal file
@ -0,0 +1,59 @@
|
|||||||
|
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
||||||
|
|
||||||
|
Name: perl-Sys-Hostname-Long
|
||||||
|
Version: 1.4
|
||||||
|
Release: 3mamba
|
||||||
|
Summary: Sys::Hostname::Long - Try every conceivable way to get full hostname
|
||||||
|
Group: System/Libraries/Perl
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.cpan.org
|
||||||
|
Source: http://search.cpan.org/CPAN/authors/id/S/SC/SCOTT/Sys-Hostname-Long-%{version}.tar.gz
|
||||||
|
Patch0: %{name}-no_win32.patch
|
||||||
|
License: BSD
|
||||||
|
Requires: perl >= %perl_major_ver
|
||||||
|
BuildRequires: perl-devel >= %perl_major_ver
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Sys::Hostname::Long - Try every conceivable way to get full hostname.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n Sys-Hostname-Long-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
||||||
|
%make
|
||||||
|
%make test
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall_perl
|
||||||
|
packlist=`find %{buildroot} -name .packlist`
|
||||||
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
||||||
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
||||||
|
sort -u > .packlist && rm $packlist
|
||||||
|
|
||||||
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
||||||
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
||||||
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
||||||
|
done
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
rm -f .packlist
|
||||||
|
|
||||||
|
%files -f .packlist
|
||||||
|
%defattr(-,root,root)
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Nov 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4-3mamba
|
||||||
|
- perl 5.16 mass rebuild
|
||||||
|
|
||||||
|
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Wed May 09 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user