82 lines
2.7 KiB
RPMSpec
82 lines
2.7 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-SVG
|
|
Version: 2.87
|
|
Release: 1mamba
|
|
Summary: SVG - Perl extension for generating Scalable Vector Graphics (SVG) documents
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org
|
|
Source: https://cpan.metacpan.org/modules/by-module/SVG/SVG-%{version}.tar.gz
|
|
License: Artistic, GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libperl
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl-devel >= %perl_major_ver
|
|
Requires: perl >= %perl_major_ver
|
|
|
|
%description
|
|
SVG is a 100% Perl module which generates a nested data structure containing the DOM representation of an SVG (Scalable Vector Graphics) image.
|
|
Using SVG, you can generate SVG objects, embed other SVG instances into it, access the DOM object, create and access javascript, and generate SMIL animation content.
|
|
|
|
%prep
|
|
%setup -q -n SVG-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Fri May 20 2022 Automatic Build System <autodist@mambasoft.it> 2.87-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 23 2021 Automatic Build System <autodist@mambasoft.it> 2.86-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Feb 24 2021 Automatic Build System <autodist@mambasoft.it> 2.85-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.50-2mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Tue Apr 13 2010 Automatic Build System <autodist@mambasoft.it> 2.50-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Feb 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.49-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.36-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Mon Oct 01 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.36-1mamba
|
|
- update to 2.36
|
|
|
|
* Tue Jul 25 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 2.33-1qilnx
|
|
- updated to version 2.33 by autospec
|
|
|
|
* Thu Oct 28 2004 Mirko Cortillaro <mirko.cortillaro@qilinux.it> 2.32-1qilnx
|
|
- package created by autospec
|