147 lines
5.0 KiB
RPMSpec
147 lines
5.0 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-PPIx-Regexp
|
|
Version: 0.088
|
|
Release: 1mamba
|
|
Summary: PPIx::Regexp - Represent a regular expression of some sort
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Automatic Build System <autodist@mambasoft.it>
|
|
URL: https://www.cpan.org
|
|
Source: http://search.cpan.org/CPAN/authors/id/W/WY/WYANT/PPIx-Regexp-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
BuildRequires: perl(List::MoreUtils)
|
|
BuildRequires: perl(Module::Build)
|
|
BuildRequires: perl(PPI::Document)
|
|
BuildRequires: perl(Task::Weaken)
|
|
BuildRequires: perl(Test::More)
|
|
BuildRequires: perl-devel
|
|
Requires: perl >= %perl_major_ver
|
|
Requires: perl(PPI::Document)
|
|
Requires: perl(Task::Weaken)
|
|
|
|
%description
|
|
The purpose of the PPIx-Regexp package is to parse regular expressions in a manner similar to the
|
|
way the PPI package parses Perl. This class forms the root of the parse tree, playing a role similar to
|
|
PPI::Document.
|
|
|
|
%prep
|
|
%setup -q -n PPIx-Regexp-%{version}
|
|
|
|
chmod -x eg/*
|
|
sed -i '1 s|/usr/local/bin/perl|/usr/bin/perl|' eg/*
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make %{?_smp_mflags}
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
%doc LICENSES
|
|
|
|
%changelog
|
|
* Tue Feb 28 2023 Automatic Build System <autodist@mambasoft.it> 0.088-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 28 2023 Automatic Build System <autodist@mambasoft.it> 0.087-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Dec 17 2022 Automatic Build System <autodist@mambasoft.it> 0.086-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 17 2022 Automatic Build System <autodist@mambasoft.it> 0.085-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 03 2022 Automatic Build System <autodist@mambasoft.it> 0.084-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 18 2022 Automatic Build System <autodist@mambasoft.it> 0.083-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 10 2022 Automatic Build System <autodist@mambasoft.it> 0.082-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Feb 21 2021 Automatic Build System <autodist@mambasoft.it> 0.078-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 03 2020 Automatic Build System <autodist@mambasoft.it> 0.071-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Nov 23 2017 Automatic Build System <autodist@mambasoft.it> 0.053-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Oct 26 2017 Automatic Build System <autodist@mambasoft.it> 0.052_01-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Sep 01 2016 Automatic Build System <autodist@mambasoft.it> 0.050-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Feb 05 2016 Automatic Build System <autodist@mambasoft.it> 0.047-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Jun 09 2015 Automatic Build System <autodist@mambasoft.it> 0.040-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Fri Apr 03 2015 Automatic Build System <autodist@mambasoft.it> 0.039-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Mar 11 2015 Automatic Build System <autodist@mambasoft.it> 0.038-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Dec 10 2014 Automatic Build System <autodist@mambasoft.it> 0.037-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu Nov 06 2014 Automatic Build System <autodist@mambasoft.it> 0.036_01-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sat May 24 2014 Automatic Build System <autodist@mambasoft.it> 0.036-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sat Nov 16 2013 Automatic Build System <autodist@mambasoft.it> 0.035-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Thu May 16 2013 Automatic Build System <autodist@mambasoft.it> 0.034-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 01 2013 Automatic Build System <autodist@mambasoft.it> 0.033-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jan 23 2013 Automatic Build System <autodist@mambasoft.it> 0.030-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 19 2013 Automatic Build System <autodist@mambasoft.it> 0.029-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 11 2013 Automatic Build System <autodist@mambasoft.it> 0.028_02-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 19 2012 Automatic Build System <autodist@mambasoft.it> 0.028-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.021-2mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Sat Nov 19 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.021-1mamba
|
|
- update to 0.021
|
|
|
|
* Fri Feb 18 2011 gil <puntogil@libero.it> 0.018-1mamba
|
|
- package created by autospec
|