92 lines
3.1 KiB
RPMSpec
92 lines
3.1 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-PDL
|
|
Version: 2.098
|
|
Release: 2mamba
|
|
Summary: A perl extension that is designed for scientific and bulk numeric data processing and display
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org
|
|
Source: https://cpan.metacpan.org/authors/id/E/ET/ETJ/PDL-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-File-Which
|
|
BuildRequires: perl-Inline-C
|
|
BuildRequires: perl-Module-Compile
|
|
BuildRequires: perl-OpenGL
|
|
BuildRequires: perl-OpenGL-GLUT
|
|
BuildRequires: perl-Pod-Parser
|
|
BuildRequires: perl-Scalar-List-Utils
|
|
BuildRequires: perl-Term-ReadKey
|
|
BuildRequires: perl-Test-Deep
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl-File-Map
|
|
Requires: perl >= %perl_major_ver
|
|
|
|
%description
|
|
PDL is the Perl Data Language, a perl extension that is designed for scientific and bulk numeric data processing and display. It extends perl's syntax and includes fully vectorized, multidimensional array handling, plus several paths for device-independent graphics output.
|
|
|
|
%prep
|
|
%setup -q -n PDL-%{version}
|
|
# make as optional requirements
|
|
%global __requires_exclude ^perl\\(PDL::.*\\)$|^perl\\(Win32::.*\\)$|^perl\\(OpenGL::Config\\)$
|
|
|
|
%build
|
|
%{__perl} Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
|
|
|
|
%make
|
|
#% make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm -f $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
#find %{buildroot} -name *.so -exec chmod u+w {} \;
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
%doc COPYING
|
|
|
|
%changelog
|
|
* Sat Jan 04 2025 Silvan Calarco <silvan.calarco@mambasoft.it> 2.098-2mamba
|
|
- rebuilt with auto requires and provides
|
|
|
|
* Sat Jan 04 2025 Automatic Build System <autodist@openmamba.org> 2.098-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 03 2025 Automatic Build System <autodist@openmamba.org> 2.097-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 02 2025 Automatic Build System <autodist@openmamba.org> 2.096-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 05 2024 Automatic Build System <autodist@openmamba.org> 2.095-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Nov 03 2024 Automatic Build System <autodist@openmamba.org> 2.094-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Oct 05 2024 Automatic Build System <autodist@openmamba.org> 2.093-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 27 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.092-1mamba
|
|
- package created using the webbuild interface
|