76 lines
2.2 KiB
RPMSpec
76 lines
2.2 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-PAR
|
|
Version: 1.020
|
|
Release: 1mamba
|
|
Summary: PAR::Heavy - PAR guts
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org
|
|
Source: https://cpan.metacpan.org/authors/id/R/RS/RSCHUPP/PAR-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-Archive-Zip
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl >= 2:5.36.0
|
|
BuildRequires: perl-devel
|
|
Requires: perl >= %perl_major_ver
|
|
|
|
%description
|
|
PAR::Heavy - PAR guts.
|
|
|
|
%prep
|
|
%setup -q -n PAR-%{version}
|
|
|
|
%build
|
|
%{__perl} Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
|
|
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm -f $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
%doc AUTHORS LICENSE
|
|
## note: eventually add the remaining documents (if any)
|
|
# %doc README
|
|
|
|
%changelog
|
|
* Mon Mar 04 2024 Automatic Build System <autodist@openmamba.org> 1.020-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 01 2023 Automatic Build System <autodist@mambasoft.it> 1.019-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Apr 15 2023 Sdk Build System <sdk@mambasoft.it> 1.018-2mamba
|
|
- rebuilt with perl 5.36.0
|
|
|
|
* Thu Sep 29 2022 Automatic Build System <autodist@mambasoft.it> 1.018-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Feb 21 2021 Automatic Build System <autodist@mambasoft.it> 1.017-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 31 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 1.016-1mamba
|
|
- package created using the webbuild interface
|