automatic update by autodist [release 1.58-1mamba;Tue Feb 18 2014]
This commit is contained in:
parent
7a95c78dca
commit
35bfa5cf4f
99
perl-Net-SSLeay.spec
Normal file
99
perl-Net-SSLeay.spec
Normal file
@ -0,0 +1,99 @@
|
||||
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
||||
|
||||
Name: perl-Net-SSLeay
|
||||
Version: 1.58
|
||||
Release: 1mamba
|
||||
Summary: Net::SSLeay - Perl module for using OpenSSL
|
||||
Group: Development/Libraries/Perl
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.cpan.org
|
||||
Source: http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-%{version}.tar.gz
|
||||
Patch: perl-Net_SSLeay-no_net_tests.patch
|
||||
License: GPL
|
||||
BuildRequires: perl-Sub-Uplevel
|
||||
BuildRequires: perl-Test-Exception
|
||||
BuildRequires: perl-Array-Compare
|
||||
BuildRequires: perl-Tree-DAG_Node
|
||||
BuildRequires: perl-Test-Warn
|
||||
BuildRequires: perl-Test-NoWarnings
|
||||
BuildRequires: perl-Test-Kwalitee
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: perl-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: openssl
|
||||
Requires: perl >= %perl_major_ver
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Net::SSLeay Perl module for using OpenSSL.
|
||||
|
||||
%prep
|
||||
%setup -q -n Net-SSLeay-%{version}
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor << _EOF
|
||||
n
|
||||
_EOF
|
||||
|
||||
%make
|
||||
|
||||
%ifnarch arm
|
||||
%make test
|
||||
%endif
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall_perl
|
||||
packlist=`find %{buildroot} -name .packlist`
|
||||
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
||||
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
||||
sort -u > .packlist && rm $packlist
|
||||
|
||||
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
||||
for dir in `find %{buildroot} -type d | grep $strid`; do
|
||||
echo "%dir ${dir#%buildroot}" >> .packlist
|
||||
done
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
rm -f .packlist
|
||||
|
||||
%files -f .packlist
|
||||
%defattr(-,root,root)
|
||||
|
||||
%changelog
|
||||
* Tue Feb 18 2014 Automatic Build System <autodist@mambasoft.it> 1.58-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sat Jun 08 2013 Automatic Build System <autodist@mambasoft.it> 1.55-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Mar 25 2013 Automatic Build System <autodist@mambasoft.it> 1.54-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Feb 08 2013 Automatic Build System <autodist@mambasoft.it> 1.52-1mamba
|
||||
- update to 1.52
|
||||
|
||||
* Sat Nov 10 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.36-2mamba
|
||||
- perl 5.16 mass rebuild
|
||||
|
||||
* Thu Aug 05 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.36-1mamba
|
||||
- update to 1.36
|
||||
|
||||
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.35-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Mon Oct 20 2008 gil <puntogil@libero.it> 1.35-1mamba
|
||||
- update to 1.35
|
||||
|
||||
* Fri Nov 09 2007 Aleph0 <aleph0@openmamba.org> 1.32-1mamba
|
||||
- update to 1.32
|
||||
|
||||
* Fri Oct 15 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.25-1qilnx
|
||||
- package created by autospec
|
74
perl-Net_SSLeay-no_net_tests.patch
Normal file
74
perl-Net_SSLeay-no_net_tests.patch
Normal file
@ -0,0 +1,74 @@
|
||||
diff -Nru Net_SSLeay.pm-1.25.orig/test.pl Net_SSLeay.pm-1.25/test.pl
|
||||
--- Net_SSLeay.pm-1.25.orig/test.pl 2004-10-15 11:22:04.000000000 +0200
|
||||
+++ Net_SSLeay.pm-1.25/test.pl 2004-10-15 11:28:50.000000000 +0200
|
||||
@@ -163,70 +163,6 @@
|
||||
&Net::SSLeay::FILETYPE_PEM());
|
||||
print &test(13, $r);
|
||||
|
||||
-#app.iplanet.com
|
||||
-my @sites = qw(
|
||||
-www.cdw.com
|
||||
-banking.wellsfargo.com
|
||||
-secure.worldgaming.net
|
||||
-www.ubs.com
|
||||
- );
|
||||
-#www.engelschall.com
|
||||
-#www.openssl.org
|
||||
-
|
||||
-if ($trace) {
|
||||
-print " Now about to contact external sites...\n\twww.bacus.pt\n";
|
||||
-print map "\t$_\n", @sites;
|
||||
-print " You have 5 seconds of time to hit Ctrl-C if you do not like this.\n";
|
||||
-print " So far there were no errors in tests.\n" unless $errors;
|
||||
-print "*** $errors tests failed already.\n" if $errors;
|
||||
-print " Following tests _will_ fail if you do not have network\n"
|
||||
- . " connectivity (or if the servers are down or have changed).\n";
|
||||
-sleep 5;
|
||||
-}
|
||||
-
|
||||
-$ENV{RND_SEED} = '1234567890123456789012345678901234567890';
|
||||
-print &test('14 www.bacus.pt',
|
||||
- &Net::SSLeay::sslcat("www.bacus.pt", 443,
|
||||
- "get\n\r\n\r") =~ /<TITLE>/);
|
||||
-
|
||||
-sub test_site ($$) {
|
||||
- my ($test_nro, $site) = @_;
|
||||
- my ($p, $r) = ('','');
|
||||
- my %h;
|
||||
- warn "Trying $site...\n";
|
||||
- $Net::SSLeay::trace=0;
|
||||
- $Net::SSLeay::version=0;
|
||||
-
|
||||
- ($p, $r, %h) = Net::SSLeay::get_https($site, 443, '/');
|
||||
- if (!defined($h{SERVER})) {
|
||||
- print &test("$test_nro $site ($r)", scalar($r =~ /^HTTP\/1/s));
|
||||
- print "\t$site, initial attempt with auto negotiate failed\n";
|
||||
-
|
||||
- $Net::SSLeay::trace=3;
|
||||
- $Net::SSLeay::version=2;
|
||||
- print "\tset version to 2\n";
|
||||
- ($p, $r, %h) = Net::SSLeay::get_https($site, 443, '/');
|
||||
-
|
||||
- $Net::SSLeay::version=3;
|
||||
- print "\tset version to 3\n";
|
||||
- ($p, $r, %h) = Net::SSLeay::get_https($site, 443, '/');
|
||||
- $Net::SSLeay::trace=0;
|
||||
- }
|
||||
-
|
||||
- print join '', map("\t$_=>$h{$_}\n", sort keys %h) if $trace>1;
|
||||
-
|
||||
- if (defined($h{SERVER})) {
|
||||
- print &test("$test_nro $site ($h{SERVER})", scalar($r =~ /^HTTP\/1/s));
|
||||
- } else {
|
||||
- print &test("$test_nro $site ($r)", scalar($r =~ /^HTTP\/1/s));
|
||||
- }
|
||||
-}
|
||||
-
|
||||
-my $i = 15;
|
||||
-my $s;
|
||||
-for $s (@sites) {
|
||||
- &test_site($i++, $s );
|
||||
-}
|
||||
|
||||
die "*** WARNING: There were $errors errors in the tests.\n" if $errors;
|
||||
print "All tests completed OK.\n" if $trace;
|
Loading…
Reference in New Issue
Block a user