66 lines
2.0 KiB
RPMSpec
66 lines
2.0 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Net-IP
|
|
Version: 1.26
|
|
Release: 3mamba
|
|
Summary: Net::IP - Perl extension for manipulating IPv4/IPv6 addresses
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org/
|
|
Source: http://search.cpan.org/CPAN/authors/id/M/MA/MANU/Net-IP-%{version}.tar.gz
|
|
License: BSD
|
|
Requires: perl >= %perl_major_ver
|
|
BuildRequires: perl-devel >= %perl_major_ver
|
|
|
|
%description
|
|
Net::IP - Perl extension for manipulating IPv4/IPv6 addresses.
|
|
|
|
%prep
|
|
%setup -q -n Net-IP-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
rm -f .packlist
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Fri Apr 26 2024 Automatic Build System <autodist@openmamba.org> 1.26-3mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Thu Apr 25 2024 Automatic Build System <autodist@openmamba.org> 1.26-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Wed Jan 09 2013 Automatic Build System <autodist@mambasoft.it> 1.26-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.25-3mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.25-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Wed May 09 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.25-1mamba
|
|
- package created by autospec
|