86 lines
2.6 KiB
RPMSpec
86 lines
2.6 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Net-DNS-SEC
|
|
Version: 1.26
|
|
Release: 1mamba
|
|
Summary: Net::DNS::SEC - DNSSEC extensions to Net::DNS
|
|
Group: System/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.cpan.org
|
|
Source: https://cpan.metacpan.org/authors/id/N/NL/NLNETLABS/Net-DNS-SEC-%{version}.tar.gz
|
|
License: GPL, Artistic
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libopenssl-devel
|
|
BuildRequires: libperl
|
|
BuildRequires: perl-Net-DNS
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl >= 2:5.36.0
|
|
Requires: perl >= %perl_major_ver
|
|
|
|
%description
|
|
Net::DNS::SEC - DNSSEC extensions to Net::DNS.
|
|
|
|
%prep
|
|
%setup -q -n Net-DNS-SEC-%{version}
|
|
|
|
%build
|
|
%{__perl} Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
|
|
|
|
%make
|
|
%make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm -f $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
find %{buildroot} -name *.so -exec chmod u+w {} \;
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
%doc LICENSE
|
|
|
|
%changelog
|
|
* Mon Jul 29 2024 Automatic Build System <autodist@openmamba.org> 1.26-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 26 2024 Automatic Build System <autodist@openmamba.org> 1.25-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 25 2024 Automatic Build System <autodist@openmamba.org> 1.24-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 08 2023 Automatic Build System <autodist@mambasoft.it> 1.23-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Sep 13 2023 Automatic Build System <autodist@mambasoft.it> 1.22-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 01 2023 Automatic Build System <autodist@mambasoft.it> 1.21-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Apr 17 2023 Sdk Build System <sdk@mambasoft.it> 1.20-2mamba
|
|
- rebuilt with perl 5.36.0
|
|
|
|
* Sat Oct 22 2022 Automatic Build System <autodist@mambasoft.it> 1.20-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Feb 19 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.19-1mamba
|
|
- package created using the webbuild interface
|