78 lines
2.2 KiB
RPMSpec
78 lines
2.2 KiB
RPMSpec
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
|
|
|
|
Name: perl-Module-Signature
|
|
Version: 0.68
|
|
Release: 2mamba
|
|
Summary: A module to check and create SIGNATURE files for CPAN distributions
|
|
Group: Development/Libraries/Perl
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.cpan.org
|
|
Source: http://cpan.panu.it/authors/id/F/FL/FLORA/Module-Signature-%{version}.tar.gz
|
|
License: GPL
|
|
BuildRequires: perl-devel >= %perl_major_ver, gnupg >= 1.2.6
|
|
Requires: perl >= %perl_major_ver
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
BuildArch: noarch
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: perl-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: perl-IPC-Run
|
|
|
|
%description
|
|
A module to check and create SIGNATURE files for CPAN distributions.
|
|
|
|
%prep
|
|
%setup -q -n Module-Signature-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor << _EOF
|
|
|
|
_EOF
|
|
|
|
%make
|
|
make test
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall_perl
|
|
|
|
packlist=`find %{buildroot} -name .packlist`
|
|
[ -z "$packlist" ] && exit 1 || cat $packlist | \
|
|
sed "s,%{buildroot},,g;s,.*/man/.*,&.gz,g" | \
|
|
sort -u > .packlist && rm $packlist
|
|
|
|
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
|
|
for dir in `find %{buildroot} -type d | grep $strid`; do
|
|
echo "%dir ${dir#%buildroot}" >> .packlist
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f .packlist
|
|
%defattr(-,root,root)
|
|
|
|
%changelog
|
|
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.68-2mamba
|
|
- perl 5.16 mass rebuild
|
|
|
|
* Sun Jul 01 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.68-1mamba
|
|
- update to 0.68
|
|
- updated specfile and maintainer
|
|
|
|
* Tue Jan 12 2010 Automatic Build System <autodist@mambasoft.it> 0.61-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.55-2mamba
|
|
- automatic rebuild by autodist
|
|
|
|
* Wed Jun 18 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.55-1mamba
|
|
- update to 0.55
|
|
- switch to noarch
|
|
- add buildrequirements
|
|
|
|
* Fri Nov 19 2004 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.41-1qilnx
|
|
- package created by autospec
|