perl-Module-Install/perl-Module-Install.spec

107 lines
3.4 KiB
RPMSpec

%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
Name: perl-Module-Install
Version: 1.21
Release: 1mamba
Summary: Module::Install - A standalone, extensible installer for Perl modules
Group: System/Libraries/Perl
Vendor: openmamba
Distribution: openmamba
Packager: Aleph0 <aleph0@openmamba.org>
URL: https://www.cpan.org/
Source: http://www.cpan.org/modules/by-module/Module/Module-Install-%{version}.tar.gz
License: Artistic
## AUTOBUILDREQ-BEGIN
BuildRequires: libperl
BuildRequires: perl-File-Remove
BuildRequires: perl-YAML-Tiny
BuildRequires: perl-devel
## AUTOBUILDREQ-END
BuildRequires: perl >= 2:5.36.0
BuildRequires: perl-Module-ScanDeps
BuildRequires: perl-PAR-Dist
BuildRequires: perl-devel >= %perl_major_ver
Requires: perl >= %perl_major_ver
%description
Module::Install, a standalone, extensible installer for Perl modules.
It is designed to be a drop-in replacement for ExtUtils::MakeMaker, and is a descendent of CPAN::MakeMaker.
%prep
%setup -q -n Module-Install-%{version}
%build
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
%make
#% make test
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall_perl
packlist=`find %{buildroot} -name .packlist`
[ -z "$packlist" ] && exit 1 || cat $packlist | \
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
sort -u > .packlist && rm $packlist
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
for dir in `find %{buildroot} -type d | grep $strid`; do
echo "%dir ${dir#%buildroot}" >> .packlist
done
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
rm -f .packlist
%files -f .packlist
%defattr(-,root,root)
%changelog
* Sat Apr 29 2023 Automatic Build System <autodist@mambasoft.it> 1.21-1mamba
- automatic version update by autodist
* Mon Apr 17 2023 Sdk Build System <sdk@mambasoft.it> 1.19-2mamba
- rebuilt with perl 5.36.0
* Tue Apr 21 2020 Automatic Build System <autodist@mambasoft.it> 1.19-1mamba
- automatic update by autodist
* Sun Oct 22 2017 Automatic Build System <autodist@mambasoft.it> 1.18-1mamba
- automatic update by autodist
* Fri May 15 2015 Automatic Build System <autodist@mambasoft.it> 1.16-1mamba
- automatic update by autodist
* Wed Nov 12 2014 Automatic Build System <autodist@mambasoft.it> 1.14-1mamba
- automatic update by autodist
* Sat Sep 20 2014 Automatic Build System <autodist@mambasoft.it> 1.12-1mamba
- automatic update by autodist
* Fri Aug 08 2014 Automatic Build System <autodist@mambasoft.it> 1.10-1mamba
- automatic update by autodist
* Sat May 24 2014 Automatic Build System <autodist@mambasoft.it> 1.08-1mamba
- automatic update by autodist
* Mon Nov 12 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.06-2mamba
- perl 5.16 mass rebuild
* Tue Apr 24 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.06-1mamba
- update to 1.06
* Tue Oct 04 2011 Automatic Build System <autodist@mambasoft.it> 1.02-1mamba
- automatic version update by autodist
* Tue Aug 09 2011 Automatic Build System <autodist@mambasoft.it> 1.01-1mamba
- automatic version update by autodist
* Sun Jan 24 2010 Automatic Build System <autodist@mambasoft.it> 0.86-1mamba
- automatic update by autodist
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.68-2mamba
- automatic rebuild by autodist
* Mon Nov 12 2007 Aleph0 <aleph0@openmamba.org> 0.68-1mamba
- package created by autospec