automatic update by autodist [release 5.505-1mamba;Mon Nov 18 2013]

This commit is contained in:
Automatic Build System 2024-01-06 09:17:14 +01:00
parent 3435494c05
commit 5c5aff34c0
3 changed files with 146 additions and 0 deletions

View File

@ -0,0 +1,41 @@
diff -Nru MIME-tools-5.420.orig/examples/mimesend MIME-tools-5.420/examples/mimesend
--- MIME-tools-5.420.orig/examples/mimesend 2004-09-07 17:09:55.000000000 +0200
+++ MIME-tools-5.420/examples/mimesend 2007-03-01 17:47:04.000000000 +0100
@@ -50,8 +50,9 @@
# Usage:
@ARGV or die <<EOF;
Usage:
- mimesend [-t to] [-s subj] (-f file [-m type])+
+ mimesend [F from] [-t to] [-s subj] (-f file [-m type])+
-n Don't actually send it; just print it to stdout.
+ -F from The "from" address.
-t to The "to" address.
-s subj The subject of the message.
-f file Path to attached file.
@@ -77,6 +78,10 @@
$nosend = 1;
next ARG;
};
+ /^-F(.*)/ and do {
+ $from = $1 || shift @ARGV;
+ next ARG;
+ };
/^-t(.*)/ and do {
$to = $1 || shift @ARGV;
next ARG;
@@ -115,6 +120,7 @@
Type => ($type || type_for($path)),
Path => $path,
Encoding => '-SUGGEST';
+ $from and $top->head->add('From', $from);
$top->head->add('To', $to);
$top->head->add('Subject', $subj);
}
@@ -122,6 +128,7 @@
# Start with top:
$top = build MIME::Entity Type=>"multipart/mixed";
+ $from and $top->head->add('From', $from);
$top->head->add('To', $to);
$top->head->add('Subject', $subj);

View File

@ -1,2 +1,5 @@
# perl-MIME-Tools
A MIME tools module for Perl.
MIME-tools is a collection of Perl5 MIME:: modules for parsing, decoding, and generating single- or multipart (even nested multipart) MIME messages.

102
perl-MIME-Tools.spec Normal file
View File

@ -0,0 +1,102 @@
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
Name: perl-MIME-Tools
Version: 5.505
Release: 1mamba
Summary: MIME-tools - A modules for parsing and creating MIME entities
Group: Development/Libraries/Perl
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.cpan.org
Source: http://www.cpan.org/authors/id/D/DS/DSKOLL/MIME-tools-%{version}.tar.gz
Patch0: MIME-tools-5.420-mimesend_add_from.patch
License: GPL
Requires: perl >= %perl_major_ver
Requires: perl(MIME::Base64) >= 3.03
BuildRequires: perl-devel >= %perl_major_ver
BuildRequires: perl-IO-stringy >= 1.211, perl-Mail-Tools >= 1.64
BuildRequires: perl-Convert-BinHex >= 1.119
BuildRequires: perl(MIME::Base64) >= 3.03
Provides: perl-MIME-tools
Obsoletes: perl-MIME-tools
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
A MIME tools module for Perl.
MIME-tools is a collection of Perl5 MIME:: modules for parsing, decoding, and generating single- or multipart (even nested multipart) MIME messages.
%prep
%setup -q -n MIME-tools-%{version}
%patch0 -p1
%build
perl Makefile.PL
%make
%make test
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
make pure_install DESTDIR=%{buildroot}
packlist=`find %{buildroot} -name .packlist`
[[ -z "$packlist" ]] && exit 1 || cat $packlist | \
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
sort -u > .packlist && rm $packlist
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
for dir in `find %{buildroot} -type d | grep $strid`; do
echo "%dir ${dir#%buildroot}" >> .packlist
done
install -d %{buildroot}%{_bindir}
install -m0755 examples/mime{abuse,encode,postcard,ref,sender,dump,explode,print,send,tour} %{buildroot}%{_bindir}
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
rm -f .packlist
%files -f .packlist
%defattr(-,root,root)
%{_bindir}/mime*
%changelog
* Mon Nov 18 2013 Automatic Build System <autodist@mambasoft.it> 5.505-1mamba
- automatic update by autodist
* Fri Feb 08 2013 Automatic Build System <autodist@mambasoft.it> 5.504-1mamba
- automatic version update by autodist
* Sun Jul 01 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 5.503-2mamba
- fixed package name (was: perl-MIME-tools)
- updated specfile and maintainer
* Wed Jun 13 2012 Automatic Build System <autodist@mambasoft.it> 5.503-1mamba
- automatic version update by autodist
* Sat Mar 12 2011 Automatic Build System <autodist@mambasoft.it> 5.502-1mamba
- automatic update by autodist
* Sat Feb 19 2011 Automatic Build System <autodist@mambasoft.it> 5.501-1mamba
- automatic update by autodist
* Wed Nov 05 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 5.420-2mamba
- automatic rebuild by autodist
* Thu Mar 01 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 5.420-1qilnx
- update to 5.420
- install examples
- mimesend: added patch to support the from field
* Mon May 09 2005 Davide Madrisan <davide.madrisan@qilinux.it> 5.417-1qilnx
- update to version 5.417 by autospec
- also fixes the "virus detection evasion" security bug
- requires perl 5.8.5 (MIME::Base64 v.3.03)
* Wed Nov 03 2004 Davide Madrisan <davide.madrisan@qilinux.it> 5.411-6qilnx
- rebuilt
* Fri Oct 22 2004 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 5.411-4qilnx
- package created by autospec (rebuilt after SRPM loss)
* Wed Sep 03 2003 Silvan Calarco <silvan.calarco@qinet.it> 3.01-1qilnx
- first build